[PATCH] gnu: Add cryfs

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Brendan Tildesley
Owner
unassigned
Submitted by
Brendan Tildesley
Severity
normal
B
B
Brendan Tildesley wrote on 6 Sep 2021 15:34
(address . guix-patches@gnu.org)
20210906133437.3691-1-mail@brendan.scot
* gnu/packages/crypto.scm (cryfs): New variable.
---
gnu/packages/crypto.scm | 75 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 75 insertions(+)

Toggle diff (108 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index c511d0a711..7f4f8590f5 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
;;; Copyright © 2021 Ellis Keny? <me@elken.dev>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,8 +47,10 @@
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages crates-io)
#:use-module (gnu packages cryptsetup)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnupg)
@@ -58,6 +61,7 @@
#:use-module (gnu packages libbsd)
#:use-module (gnu packages libffi)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages logging)
#:use-module (gnu packages lsof)
#:use-module (gnu packages man)
#:use-module (gnu packages multiprecision)
@@ -1385,3 +1389,74 @@ them out. The process will degrade gracefully, so even people without your
encryption password can safely commit changes to the repository's
non-encrypted files.")
(license license:expat)))
+
+(define-public cryfs
+ (package
+ (name "cryfs")
+ (version "0.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/cryfs/cryfs/releases/download/"
+ version "/cryfs-" version ".tar.xz"))
+ (sha256
+ (base32 "0dxphbj5sssm82rkkdb71algrcki16qlpzlvrjyvvm6b7x7zi0sm"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ `("-DCRYFS_UPDATE_CHECKS=OFF" ;; Note: This also disables checking for security issues.
+ "-DCMAKE_BUILD_TYPE=Release" ;; Build man pages.
+ ;; This helps us use some dependencies from Guix instead of conan.
+ ;; crypto++ is still bundled: https://github.com/cryfs/cryfs/issues/369
+ ,(string-append "-DDEPENDENCY_CONFIG=" (getcwd)
+ "/cmake-utils/DependenciesFromLocalSystem.cmake"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-configure
+ (lambda* (#:key tests? #:allow-other-keys)
+ (chdir "..")
+ (delete-file-recursively ".circleci")
+ (when tests?
+ (substitute* "CMakeLists.txt"
+ (("option.BUILD_TESTING .build test cases. OFF.")
+ "option(BUILD_TESTING \"build test cases\" ON)")))))
+ (replace 'check
+ (lambda* (#:key tests? outputs #:allow-other-keys)
+ (use-modules (srfi srfi-1))
+ (when tests?
+ (with-directory-excursion "/tmp/build/test"
+ (let ((tests (find-files "." "-test$"))
+ (tests-output (assoc-ref outputs "tests")))
+ ;; Install tests to a separate output so users can run them.
+ (copy-recursively "." tests-output)
+ ;; XXX: Disable failing tests. Unfortunately there are a
+ ;; few. Some only fail in the build environment. ;; build
+ ;; environment.
+ (for-each invoke
+ (lset-difference string-contains
+ tests
+ '("cpp-utils-test"
+ "cryfs-cli-test"
+ "blobstore-test"
+ "fspp-test"))))))
+ #t)))))
+ (outputs '("out" "tests"))
+ (native-inputs
+ `(("python" ,python-wrapper)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("boost" ,boost)
+ ("curl" ,curl)
+ ("fuse" ,fuse)
+ ("range-v3" ,range-v3)
+ ("spdlog" ,spdlog)))
+ (home-page "https://www.cryfs.org/")
+ (synopsis "Encrypted FUSE filesystem for the cloud")
+ (description "CryFS encrypts your files, so you can safely store them anywhere.
+ It works well together with cloud services like Dropbox, iCloud, OneDrive and
+others. CryFS creates an encrypted userspace filesystem that can be mounted
+via FUSE without root permissions. It is similar to EncFS, but provides
+additional security and privacy measures such as hiding file sizes and directory
+structure. However CryFS is not considered stable yet by the developers.")
+ (license license:lgpl3+)))
--
2.33.0
L
L
Ludovic Courtès wrote on 14 Sep 2021 11:50
control message for bug #50428
(address . control@debbugs.gnu.org)
87sfy75vv3.fsf@gnu.org
reopen 50428
tags 50428 - fixed patch
quit
L
L
Ludovic Courtès wrote on 14 Sep 2021 11:50
Re: bug#50428: [PATCH] gnu: Add cryfs
(name . Brendan Tildesley)(address . mail@brendan.scot)(address . 50428-done@debbugs.gnu.org)
87tuin5vvs.fsf@gnu.org
Hi,

Brendan Tildesley <mail@brendan.scot> skribis:

Toggle quote (2 lines)
> * gnu/packages/crypto.scm (cryfs): New variable.

Overall LGTM modulo the minor issues below:

Toggle quote (4 lines)
> + '(#:configure-flags
> + `("-DCRYFS_UPDATE_CHECKS=OFF" ;; Note: This also disables checking for security issues.
> + "-DCMAKE_BUILD_TYPE=Release" ;; Build man pages.

Normally this is set by #:build-type. It defaults to “RelWithDebInfo”,
which is nice because then you get debugging symbols if you pass
‘--with-debug-info=cryfs’. So I’d suggest removing this second flag.

Toggle quote (4 lines)
> + (replace 'check
> + (lambda* (#:key tests? outputs #:allow-other-keys)
> + (use-modules (srfi srfi-1))

Please use #:modules ((srfi srfi-1) …) instead of this non-top-level
‘use-modules’ form.

Toggle quote (7 lines)
> + (when tests?
> + (with-directory-excursion "/tmp/build/test"
> + (let ((tests (find-files "." "-test$"))
> + (tests-output (assoc-ref outputs "tests")))
> + ;; Install tests to a separate output so users can run them.
> + (copy-recursively "." tests-output)

Installing tests is unusual. Do you really think it’s going to be
useful?

Toggle quote (4 lines)
> + ;; XXX: Disable failing tests. Unfortunately there are a
> + ;; few. Some only fail in the build environment. ;; build
> + ;; environment.

Typo.

Toggle quote (2 lines)
> + (description "CryFS encrypts your files, so you can safely store them anywhere.
> + It works well together with cloud services like Dropbox, iCloud, OneDrive and
^
Extra space. :-)

Could you send an updated patch?

Thanks!

Ludo’.
Closed
B
B
Brendan Tildesley wrote on 14 Sep 2021 14:13
(name . Ludovic Courtès)(address . ludo@gnu.org)(name . 50428@debbugs.gnu.org)(address . 50428@debbugs.gnu.org)
1201589804.62472.1631621592628@office.mailbox.org
Update attached.

Toggle quote (20 lines)
> On 09/14/2021 11:50 AM Ludovic Courtès <ludo@gnu.org> wrote:
>
>
> Hi,
>
> Brendan Tildesley <mail@brendan.scot> skribis:
>
> > * gnu/packages/crypto.scm (cryfs): New variable.
>
> Overall LGTM modulo the minor issues below:
>
> > + '(#:configure-flags
> > + `("-DCRYFS_UPDATE_CHECKS=OFF" ;; Note: This also disables checking for security issues.
> > + "-DCMAKE_BUILD_TYPE=Release" ;; Build man pages.
>
> Normally this is set by #:build-type. It defaults to “RelWithDebInfo”,
> which is nice because then you get debugging symbols if you pass
> ‘--with-debug-info=cryfs’. So I’d suggest removing this second flag.
>

I found a way to build man pages without it.

Toggle quote (8 lines)
> > + (replace 'check
> > + (lambda* (#:key tests? outputs #:allow-other-keys)
> > + (use-modules (srfi srfi-1))
>
> Please use #:modules ((srfi srfi-1) …) instead of this non-top-level
> ‘use-modules’ form.
>

done.

Toggle quote (10 lines)
> > + (when tests?
> > + (with-directory-excursion "/tmp/build/test"
> > + (let ((tests (find-files "." "-test$"))
> > + (tests-output (assoc-ref outputs "tests")))
> > + ;; Install tests to a separate output so users can run them.
> > + (copy-recursively "." tests-output)
>
> Installing tests is unusual. Do you really think it’s going to be
> useful?

Not sure. I felt since the cryfs is for encrypting peoples files, they may want to run the tests themselves
to see if there any nasty issues. Most of the tests fail due to FUSE not being available, which works outside
the chroot. Anyways I removed installing them.
L
L
Ludovic Courtès wrote on 16 Sep 2021 11:42
(name . Brendan Tildesley)(address . mail@brendan.scot)(address . 50428-done@debbugs.gnu.org)
87v93026x2.fsf@gnu.org
Hi,

Brendan Tildesley <mail@brendan.scot> skribis:

Toggle quote (2 lines)
> * gnu/packages/crypto.scm (cryfs): New variable.

Overall LGTM modulo the minor issues below:

Toggle quote (4 lines)
> + '(#:configure-flags
> + `("-DCRYFS_UPDATE_CHECKS=OFF" ;; Note: This also disables checking for security issues.
> + "-DCMAKE_BUILD_TYPE=Release" ;; Build man pages.

Normally this is set by #:build-type. It defaults to “RelWithDebInfo”,
which is nice because then you get debugging symbols if you pass
‘--with-debug-info=cryfs’. So I’d suggest removing this second flag.

Toggle quote (4 lines)
> + (replace 'check
> + (lambda* (#:key tests? outputs #:allow-other-keys)
> + (use-modules (srfi srfi-1))

Please use #:modules ((srfi srfi-1) …) instead of this non-top-level
‘use-modules’ form.

Toggle quote (7 lines)
> + (when tests?
> + (with-directory-excursion "/tmp/build/test"
> + (let ((tests (find-files "." "-test$"))
> + (tests-output (assoc-ref outputs "tests")))
> + ;; Install tests to a separate output so users can run them.
> + (copy-recursively "." tests-output)

Installing tests is unusual. Do you really think it’s going to be
useful?

Toggle quote (4 lines)
> + ;; XXX: Disable failing tests. Unfortunately there are a
> + ;; few. Some only fail in the build environment. ;; build
> + ;; environment.

Typo.

Toggle quote (2 lines)
> + (description "CryFS encrypts your files, so you can safely store them anywhere.
> + It works well together with cloud services like Dropbox, iCloud, OneDrive and
^
Extra space. :-)

Could you send an updated patch?

Thanks!

Ludo’.
Closed
L
L
Ludovic Courtès wrote on 16 Sep 2021 21:56
(name . Brendan Tildesley)(address . mail@brendan.scot)(name . 50428@debbugs.gnu.org)(address . 50428-done@debbugs.gnu.org)
87tuikz43l.fsf@gnu.org
Hi,

Brendan Tildesley <mail@brendan.scot> skribis:

Toggle quote (7 lines)
> From 6604ab84de9a38907ca6d930dcb5c0d79de28d88 Mon Sep 17 00:00:00 2001
> From: Brendan Tildesley <mail@brendan.scot>
> Date: Sat, 4 Sep 2021 16:52:23 +1000
> Subject: [PATCH] gnu: Add cryfs.
>
> * gnu/packages/crypto.scm (cryfs): New variable.

Applied, thanks!

Ludo’.
Closed
?