(address . guix-patches@gnu.org)
* gnu/packages/python-xyz.scm (python-dotenv): New variable.
---
gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1d1a679133..c06a32d027 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26435,3 +26435,31 @@ a (rather superficial) static analysis, and
constructs a directed graph of the
objects in the combined source, and how they define or use each other. The
graph can be output for rendering by GraphViz or yEd.")
(license license:gpl2)))
+
+(define-public python-dotenv
+ (package
+ (name "python-dotenv")
+ (version "0.19.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-dotenv" version))
+ (sha256
+ (base32
+ "0wk1kfzbpqk9swvmpa9z3q170ffqql2id4b2dxrkrq58r4mbq8gm"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-mock" ,python-mock)
+ ("python-sh" ,python-sh)))
+ (propagated-inputs
+ `(("python-click" ,python-click)))
+ (home-page
+ "https://saurabh-kumar.com/python-dotenv/")
+ (synopsis
+ "Read key-value pairs from a .env file and set them as
environment variables")
+ (description
+ "Python-dotenv reads key-value pairs from a .env file and can set them as
+environment variables. It helps in the development of applications
following the
+@url{http://12factor.net,12-factor} principles.")
+ (license license:bsd-3)))
--
2.33.0