[PATCH] gnu: Add python-dotenv.

  • Open
  • quality assurance status badge
Details
3 participants
  • Sarah Morgensen
  • jgart
  • Zac Berkowitz
Owner
unassigned
Submitted by
Zac Berkowitz
Severity
normal
Z
Z
Zac Berkowitz wrote on 1 Sep 2021 17:39
(address . guix-patches@gnu.org)
CANNGBfnfBfU3BWPBv5+uTE5F2JNr=F5EUM=NhZjmDDCjF6RAGQ@mail.gmail.com
* gnu/packages/python-xyz.scm (python-dotenv): New variable.
---
gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1d1a679133..c06a32d027 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26435,3 +26435,31 @@ a (rather superficial) static analysis, and
constructs a directed graph of the
objects in the combined source, and how they define or use each other. The
graph can be output for rendering by GraphViz or yEd.")
(license license:gpl2)))
+
+(define-public python-dotenv
+ (package
+ (name "python-dotenv")
+ (version "0.19.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-dotenv" version))
+ (sha256
+ (base32
+ "0wk1kfzbpqk9swvmpa9z3q170ffqql2id4b2dxrkrq58r4mbq8gm"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-mock" ,python-mock)
+ ("python-sh" ,python-sh)))
+ (propagated-inputs
+ `(("python-click" ,python-click)))
+ (home-page
+ "https://saurabh-kumar.com/python-dotenv/")
+ (synopsis
+ "Read key-value pairs from a .env file and set them as
environment variables")
+ (description
+ "Python-dotenv reads key-value pairs from a .env file and can set them as
+environment variables. It helps in the development of applications
following the
+@url{http://12factor.net,12-factor} principles.")
+ (license license:bsd-3)))
--
2.33.0
J
J
jgart wrote on 2 Sep 2021 16:06
patch available already for python-dotenv at 50213
(address . 50324@debbugs.gnu.org)
20210902100607.GB3068@gac.attlocal.net
Hi,

There is a patch open already for python-dotenv as part of this issue: http://issues.guix.gnu.org/50213#28

It is part of upgrading flask to 2.0.1

Maybe we can commit together if there is anything you would like to merge with the patch you just sent?

all best,

jgart
_________________________________________
/ 3B1D 7F19 E36B B60C 0F5B 2CA9 A52A A2B4 \
\ 77B6 DD35 /
-----------------------------------------
\ ^__^
\ (oo)\_______
(__)\ )\/\
||----w |
|| ||
S
J
J
jgart wrote on 3 Sep 2021 03:48
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)(address . 50324@debbugs.gnu.org)
20210902214818.GB16733@gac.attlocal.net
On Thu, 02 Sep 2021 17:50:31 -0700 Sarah Morgensen <iskarian@mgsn.dev> wrote:
Toggle quote (7 lines)
>
> jgart <jgart@dismail.de> writes:
>
> > There is a patch open already for python-dotenv as part of this issue: http://issues.guix.gnu.org/50213#28
>
> There is also one at #49834 [0], so that makes three :)

Hahahaha dotenv is in high demand!
?