[PATCH] gnu: Add emacs-dictionary.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Simon South
Owner
unassigned
Submitted by
Simon South
Severity
normal

Debbugs page

Simon South wrote 4 years ago
(address . guix-patches@gnu.org)
20210831185257.7801-1-simon@simonsouth.net
* gnu/packages/emacs-xyz.scm (emacs-dictionary): New variable.
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 222be589d7..bfdf4e12ef 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29360,6 +29360,27 @@ shorter than usual, using mostly unprefixed keys.")
@acronym{CWL, Common Workflow Language} files.")
(license license:gpl3+)))
+(define-public emacs-dictionary
+ (package
+ (name "emacs-dictionary")
+ (version "1.11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/myrkr/dictionary-el")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zsjbpq0s0xdxd9r541f04bj1khhgzhdlzr0m4p17zjh1zardbpi"))))
+ (build-system emacs-build-system)
+ (home-page "http://www.myrkr.in-berlin.de/dictionary/index.html")
+ (synopsis "Emacs client for dictionary servers")
+ (description "This package provides commands for interacting with a
+dictionary server (as defined by RFC 2229; by default, the public server at
+dict.org) from within Emacs.")
+ (license license:gpl2+)))
+
(define-public emacs-multitran
(package
(name "emacs-multitran")
--
2.33.0
Arun Isaac wrote 4 years ago
875yvin249.fsf@systemreboot.net
Hi Simon,

I pushed your patch to master after adding a copyright header. Thanks
for contributing to Guix! :-)

Regards,
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmExNoYbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzTiMH/1j/BcDdWfP1xaM64rzI
igqUnDjAOj5KAknZg0PSkiA5l5x95oGpwxgbNh5XrAF9pttu1ceNnZIdeQShie6h
L7veRyS31FxyWhjzJaG/tgaGCwqLMZJ1yBmef/1j88YI2SxKjCqVjam4FnPh2ga4
P/EvbAkfLoKw7tiFRCwQ5M5row1TCBmrugFqMQAEqw3SizPWy7HVPIFASjg1Wj4I
XZsKYe0zD/Hh3VPGSLZKmaSTshzx9wsuAYICjpsxjCngc+lfuDP7MNQpqctoI6/y
Rj4BOur7Z30u5GrmrdKQ/JPdwUOk8Fq0UFL3N8Rx0BA+GehvRPsbO+RIGYum1v4I
GO4=
=lORU
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 50305@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50305
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help