Simon South wrote 4 years ago
(address . guix-patches@gnu.org)
* gnu/packages/emacs-xyz.scm (emacs-dictionary): New variable.
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 222be589d7..bfdf4e12ef 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29360,6 +29360,27 @@ shorter than usual, using mostly unprefixed keys.")
@acronym{CWL, Common Workflow Language} files.")
(license license:gpl3+)))
+(define-public emacs-dictionary
+ (package
+ (name "emacs-dictionary")
+ (version "1.11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/myrkr/dictionary-el")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zsjbpq0s0xdxd9r541f04bj1khhgzhdlzr0m4p17zjh1zardbpi"))))
+ (build-system emacs-build-system)
+ (home-page "http://www.myrkr.in-berlin.de/dictionary/index.html")
+ (synopsis "Emacs client for dictionary servers")
+ (description "This package provides commands for interacting with a
+dictionary server (as defined by RFC 2229; by default, the public server at
+dict.org) from within Emacs.")
+ (license license:gpl2+)))
+
(define-public emacs-multitran
(package
(name "emacs-multitran")
--
2.33.0