[PATCH] emacs-org-roam: Add new phase after unpack.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandr Vityazev
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alexandr Vityazev
Severity
normal
A
A
Alexandr Vityazev wrote on 30 Aug 2021 23:42
(address . guix-patches@gnu.org)
87bl5e4njg.fsf@posteo.org
* gnu/packages/emacs-xyz.scm (emacs-org-roam)[arguments]<phases>:
After the unpack phase add a move-source-files phase to include
the org-roam extensions to the package.
---
gnu/packages/emacs-xyz.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 70c4c30bc2..679636c123 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28227,6 +28227,15 @@ snippets for Emacs.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ ;; Move the extensions source files to the top level, which is included in
+ ;; the EMACSLOADPATH.
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./extensions" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f (basename f)))
+ el-files))
+ #t))
(add-after 'install 'install-image
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
--
2.33.0



--

Alexandr Vityazev
L
L
Ludovic Courtès wrote on 7 Sep 2021 15:58
(name . Alexandr Vityazev)(address . avityazev@posteo.org)(address . 50287-done@debbugs.gnu.org)
87v93c4hcx.fsf@gnu.org
Hi,

Alexandr Vityazev <avityazev@posteo.org> skribis:

Toggle quote (4 lines)
> * gnu/packages/emacs-xyz.scm (emacs-org-roam)[arguments]<phases>:
> After the unpack phase add a move-source-files phase to include
> the org-roam extensions to the package.

Applied, thanks.

However, the newly installed files aren’t getting compiled. Should we
do something about it?

Ludo’.
Closed
A
A
Alexandr Vityazev wrote on 8 Sep 2021 20:32
(address . ludo@gnu.org)(address . 50287-done@debbugs.gnu.org)
875yvazzmz.fsf@posteo.org
uld we
> do something about it?
I installed this package on 2 different machines and in both cases all
files were compiled. Perhaps I am missing something, and my knowledge is
clearly not enough to understand when this can happen, so I have no
solution.
--=20
Alexandr Vityazev



Closed
?