[PATCH] update python-certifi

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Maxim Cournoyer
  • Adam Kandur
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 30 Aug 2021 10:54
(name . Guix Patches)(address . guix-patches@gnu.org)
MiLFzXP--3-2@tuta.io
hope, this is correct...
i had problems using python libs from guix because of outdated certificates needed for https requests
From 71fa733ace1ebf2186c15b0e17798fb7f72e385e Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Sun, 29 Aug 2021 19:52:55 +0300
Subject: [PATCH] gnu: Add go-github-com-DHowett-go-plist.

* gnu/packages/golang.scm (go-github-com-DHowett-go-plist): New variable.
---
gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 72579d6..8423c95 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1009,6 +1009,34 @@ standardized in RFC 7539.")
(description "Set is the set collection for the Go language.")
(license license:expat)))
+(define-public go-github-com-DHowett-go-plist
+ (let ((commit "1454fab16a0642638feb0ae98c41f79eccb2a20a")
+ (revision "1"))
+ (package
+ (name "go-github-com-DHowett-go-plist")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DHowett/go-plist")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01c9wmhny2rxywcjipq1xa0xw4qm7yd001239grwxcja3b4n45v8"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "howett.net/plist"))
+ (inputs
+ `(("go-github.com-jessevdk-go-flags" ,go-github.com-jessevdk-go-flags)
+ ("go-github-com-kr-pretty" ,go-github-com-kr-pretty)
+ ("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)
+ ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)))
+ (home-page "https://github.com/DHowett/go-plist")
+ (synopsis "A pure Go Apple Property List transcoder")
+ (description "This list transcoder supports encoding/decoding property lists (Apple XML, Apple Binary, OpenStep and GNUStep) from/to arbitrary Go types.")
+ (license license:giftware))))
+
(define-public go-github-com-blanu-dust
(package
(name "go-github-com-blanu-dust")
--
2.32.0
M
M
Maxim Cournoyer wrote on 30 Aug 2021 20:29
(name . Adam Kandur)(address . rndd@tuta.io)(address . 50265@debbugs.gnu.org)
87czpun5ux.fsf@gmail.com
Hello,

Adam Kandur <rndd@tuta.io> writes:

Toggle quote (25 lines)
> hope, this is correct...
> i had problems using python libs from guix because of outdated certificates needed for https requests
>
>>From 71fa733ace1ebf2186c15b0e17798fb7f72e385e Mon Sep 17 00:00:00 2001
> From: Adam Kandur <rndd@tuta.io>
> Date: Sun, 29 Aug 2021 19:52:55 +0300
> Subject: [PATCH] gnu: Add go-github-com-DHowett-go-plist.
>
> * gnu/packages/golang.scm (go-github-com-DHowett-go-plist): New variable.
> ---
> gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
> 1 file changed, 28 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index 72579d6..8423c95 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -1009,6 +1009,34 @@ standardized in RFC 7539.")
> (description "Set is the set collection for the Go language.")
> (license license:expat)))
>
> +(define-public go-github-com-DHowett-go-plist
> + (let ((commit "1454fab16a0642638feb0ae98c41f79eccb2a20a")
> + (revision "1"))

^ Wrong patch? The title is about python-certifi.

If you want to close this one, you can reply to the email using
50265-done@debbugs.gnu.org in CC.

Thanks,

Maxim
L
L
Ludovic Courtès wrote on 24 Sep 2021 14:19
control message for bug #50265
(address . control@debbugs.gnu.org)
874kaanp2e.fsf@gnu.org
tags 50265 wontfix
close 50265
quit
?