[PATCH] gnu: trash-cli: Update to 0.21.7.24.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brice Waegeneire
  • Ludovic Courtès
Owner
unassigned
Submitted by
Brice Waegeneire
Severity
normal
B
B
Brice Waegeneire wrote on 28 Aug 2021 09:48
(address . guix-patches@gnu.org)
20210828074830.6325-1-brice@waegenei.re
* gnu/packages/shellutils.scm (trash-cli): Update to 0.21.7.24.
[source]: Use github repository instead of pypi.
[arguments]<python>: Use python 3.
<tests>: Enable tests.
<phases>: Add "fix-setup.py" phase.
[native-inputs]: Add python-pytest, python-mock and python-six.
[propagated-inputs]: Add python-psutil.
---
gnu/packages/shellutils.scm | 37 +++++++++++++++++++++++++++----------
1 file changed, 27 insertions(+), 10 deletions(-)

The switch from PyPi to Github is to get the "test" directory to be able to
run the tests.

Toggle diff (76 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 94b5536df7..7c153cdf25 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -38,11 +38,13 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages check)
#:use-module (gnu packages flex)
#:use-module (gnu packages golang)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
#:use-module (gnu packages ruby)
#:use-module (gnu packages shells)
@@ -203,19 +205,20 @@ between various shells or commands.")
(define-public trash-cli
(package
(name "trash-cli")
- (version "0.17.1.14")
+ (version "0.21.7.24")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "trash-cli" version))
- (sha256
- (base32
- "01q0cl04ljf214z6s3g256gsxx3pqsgaf6ac1zh0vrq5bnhnr85h"))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/andreafrancia/trash-cli")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "082mfl4mza4xkm3fdn5aka9rsbd8c149qj3cqqk62idrnszmgzg5"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2
- #:tests? #f ; no tests
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-before 'build 'patch-path-constants
(lambda* (#:key inputs #:allow-other-keys)
@@ -225,8 +228,22 @@ between various shells or commands.")
(("\"/lib/libc.so.6\".*")
(string-append "\"" libc "/lib/libc.so.6\"\n"))
(("\"df\"")
- (string-append "\"" coreutils "/bin/df\"")))))))))
+ (string-append "\"" coreutils "/bin/df\""))))))
+ (add-before 'build 'fix-setup.py
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (mkdir-p bin)
+ (substitute* "setup.py"
+ (("add_script\\('")
+ (string-append "add_script('" bin "/" )))))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-mock" ,python-mock)
+ ("python-six" ,python-six)))
(inputs `(("coreutils" ,coreutils)))
+ (propagated-inputs
+ `(("python-psutil" ,python-psutil)))
(home-page "https://github.com/andreafrancia/trash-cli")
(synopsis "Trash can management tool")
(description

base-commit: 4716d544443f25a4cd1397d9f8deb856e28bb515
--
2.32.0
L
L
Ludovic Courtès wrote on 24 Sep 2021 13:56
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 50235@debbugs.gnu.org)
87v92qnq4h.fsf@gnu.org
Hi Brice,

Brice Waegeneire <brice@waegenei.re> skribis:

Toggle quote (8 lines)
> * gnu/packages/shellutils.scm (trash-cli): Update to 0.21.7.24.
> [source]: Use github repository instead of pypi.
> [arguments]<python>: Use python 3.
> <tests>: Enable tests.
> <phases>: Add "fix-setup.py" phase.
> [native-inputs]: Add python-pytest, python-mock and python-six.
> [propagated-inputs]: Add python-psutil.

LGTM!

Ludo’.
B
B
Brice Waegeneire wrote on 18 Jan 2022 08:58
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 50235-done@debbugs.gnu.org)
87tue1scea.fsf_-_@waegenei.re
Hello Ludo’,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (12 lines)
> Brice Waegeneire <brice@waegenei.re> skribis:
>
>> * gnu/packages/shellutils.scm (trash-cli): Update to 0.21.7.24.
>> [source]: Use github repository instead of pypi.
>> [arguments]<python>: Use python 3.
>> <tests>: Enable tests.
>> <phases>: Add "fix-setup.py" phase.
>> [native-inputs]: Add python-pytest, python-mock and python-six.
>> [propagated-inputs]: Add python-psutil.
>
> LGTM!

Thank for the review!

Pushed as 39510d5a5e4e0e38cd3d3bc944d5bf6d96242493, adjusted from the initial
patch to update to 0.21.10.24 and use new inputs style.

Cheers,
- Brice
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 50235@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50235
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch