[PATCH] gnu: Add h2c.

  • Done
  • quality assurance status badge
Details
2 participants
  • Felix Gruber
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Felix Gruber
Severity
normal
F
F
Felix Gruber wrote on 25 Aug 2021 18:59
(address . guix-patches@gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20210825165932.36513-1-felgru@posteo.net
* gnu/packages/curl.scm (h2c): New variable.
---
gnu/packages/curl.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index e6f1bb0c41..c61a56256c 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
;;; Copyright © 2020 Dale Mellor <guix-devel-0brg6b@rdmp.org>
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,6 +36,7 @@
#:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (gnu packages)
@@ -334,3 +336,30 @@ user+password authentication, file transfer resume, http proxy tunneling and
more!")
(home-page "http://www.curlpp.org")
(license license:expat)))
+
+(define-public h2c
+ (package
+ (name "h2c")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/curl/h2c")
+ (commit version)))
+ (sha256
+ (base32
+ "1n8z6avzhg3yb330di2y9zymsps1qp1235p29kidcp4fkmn7fgb2"))
+ (file-name (git-file-name name version))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("./h2c" "bin/"))))
+ (inputs
+ `(("perl" ,perl)))
+ (home-page "https://curl.se/h2c/")
+ (synopsis "Convert HTTP headers to a curl command line")
+ (description
+ "Provided a set of HTTP request headers, h2c outputs how to invoke
+curl to obtain exactly that HTTP request.")
+ (license license:expat)))
--
2.30.2
M
M
Mathieu Othacehe wrote on 31 Aug 2021 15:55
(name . Felix Gruber)(address . felgru@posteo.net)(address . 50200-done@debbugs.gnu.org)
87bl5d67nr.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/curl.scm (h2c): New variable.

Pushed, thanks!

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 50200@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50200
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch