[PATCH core-updates-frozen] gnu: mesa: Update to 21.2.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Kehayias
  • Maxim Cournoyer
Owner
unassigned
Submitted by
John Kehayias
Severity
normal
J
J
John Kehayias wrote on 23 Aug 2021 07:50
(name . Guix-patches)(address . guix-patches@gnu.org)
lyT-dRra1A3lt7VRTvpG1Qj4zr0STz--KCtLv3e__Zl24xuNoKr2U3GYaE5Axget9JYGxeumrHpn5WU61MS_HnUzTn0lgJD52gH_KkiRxMw=@protonmail.com
* gnu/packages/gl.scm (mesa): Update to 21.2.1.
* gnu/packages/patches/mesa-skip-tests.patch: Modify for current version.
---
gnu/packages/gl.scm | 4 ++--
gnu/packages/patches/mesa-skip-tests.patch | 28 +++++++---------------
2 files changed, 11 insertions(+), 21 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 7a8a478953..d6e754779d 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -239,7 +239,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "21.1.6")
+ (version "21.2.1")
(source
(origin
(method url-fetch)
@@ -251,7 +251,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "0dwyk7cxlwna24ap23i8i92a2qcc6xhp16i03zzakpqiz4i03jxi"))
+ "11qpq16xbxymcgiy0wk787dk4yw2pv8fzgj8d92ng6s11dqycr9c"))
(patches
(search-patches "mesa-skip-tests.patch"))))
(build-system meson-build-system)
diff --git a/gnu/packages/patches/mesa-skip-tests.patch b/gnu/packages/patches/mesa-skip-tests.patch
index 8f587ea7ef..0813fa2a8a 100644
--- a/gnu/packages/patches/mesa-skip-tests.patch
+++ b/gnu/packages/patches/mesa-skip-tests.patch
@@ -5,25 +5,15 @@ completely with this patch:
https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091

diff --git a/src/util/meson.build b/src/util/meson.build
-index 0893f64..909b3e0 100644
+index aa5bfef5dbc..3ec845b05fa 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
-@@ -289,18 +289,6 @@ if with_tests
- suite : ['util'],
- )
+@@ -344,7 +344,7 @@ if with_tests
+ )
+ endif

-- test(
-- 'u_debug_stack',
-- executable(
-- 'u_debug_stack_test',
-- files('u_debug_stack_test.cpp'),
-- include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
-- dependencies : [idep_mesautil, idep_gtest],
-- c_args : [c_msvc_compat_args],
-- ),
-- suite : ['util'],
-- )
--
- process_test_exe = executable(
- 'process_test',
- files('process_test.c'),
+- foreach t: ['bitset', 'register_allocate', 'u_debug_stack', 'u_qsort']
++ foreach t: ['bitset', 'register_allocate', 'u_qsort']
+ test(
+ t,
+ executable(
--
2.33.0
J
J
John Kehayias wrote on 23 Aug 2021 07:58
(name . 50170@debbugs.gnu.org)(address . 50170@debbugs.gnu.org)
eAHqB-mmMmOdVHpmenWCxZW4czdQVm6AYmFFmj7QXkvbSKAzQEtrRcUh6JmzOR5Ufr4dJcIKazLPthT9JvD4SbJ5bfGsmSnHo4XYgFOK7bE=@protonmail.com
Hi everyone,

I know we're working on getting core-updates-frozen in shape to merge, but with a few more Mesa updates out recently I thought maybe I can sneak this in as an addendum to the current Mesa patches. I checked it builds on x86-64 and modified the patch which removes the troublesome (i686) test to still apply here. No other changes to the build process I could see. 21.2.0 was out earlier but was a development release; this is the first regular release for 21.2.

If I may, I would suggest seeing if this builds on the CI for other architectures without major changes, and if so would recommend this update. Mesa has been moving quickly with bug fixes and enhancing their graphics drivers, so with the extended time between core-update merges would be great to be up to date for this current merge.

And if not, this can be the start of the next core-updates Mesa update (maybe Mesa can be moved to a quicker updating process?). There is also a further bug fix release for 21.1, so we could bump to 21.1.7 from our current 21.1.6 in core-updates-frozen.

Let me know what you think and anything else we need on this front.

John
M
M
Maxim Cournoyer wrote on 15 Oct 2021 02:42
(name . John Kehayias)(address . john.kehayias@protonmail.com)(address . 50170@debbugs.gnu.org)
87tuhjnmo5.fsf@gmail.com
Hi!

John Kehayias <john.kehayias@protonmail.com> writes:

Toggle quote (72 lines)
> * gnu/packages/gl.scm (mesa): Update to 21.2.1.
> * gnu/packages/patches/mesa-skip-tests.patch: Modify for current version.
> ---
> gnu/packages/gl.scm | 4 ++--
> gnu/packages/patches/mesa-skip-tests.patch | 28 +++++++---------------
> 2 files changed, 11 insertions(+), 21 deletions(-)
>
> diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
> index 7a8a478953..d6e754779d 100644
> --- a/gnu/packages/gl.scm
> +++ b/gnu/packages/gl.scm
> @@ -239,7 +239,7 @@ also known as DXTn or DXTC) for Mesa.")
> (define-public mesa
> (package
> (name "mesa")
> - (version "21.1.6")
> + (version "21.2.1")
> (source
> (origin
> (method url-fetch)
> @@ -251,7 +251,7 @@ also known as DXTn or DXTC) for Mesa.")
> version "/mesa-" version ".tar.xz")))
> (sha256
> (base32
> - "0dwyk7cxlwna24ap23i8i92a2qcc6xhp16i03zzakpqiz4i03jxi"))
> + "11qpq16xbxymcgiy0wk787dk4yw2pv8fzgj8d92ng6s11dqycr9c"))
> (patches
> (search-patches "mesa-skip-tests.patch"))))
> (build-system meson-build-system)
> diff --git a/gnu/packages/patches/mesa-skip-tests.patch b/gnu/packages/patches/mesa-skip-tests.patch
> index 8f587ea7ef..0813fa2a8a 100644
> --- a/gnu/packages/patches/mesa-skip-tests.patch
> +++ b/gnu/packages/patches/mesa-skip-tests.patch
> @@ -5,25 +5,15 @@ completely with this patch:
> https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091
>
> diff --git a/src/util/meson.build b/src/util/meson.build
> -index 0893f64..909b3e0 100644
> +index aa5bfef5dbc..3ec845b05fa 100644
> --- a/src/util/meson.build
> +++ b/src/util/meson.build
> -@@ -289,18 +289,6 @@ if with_tests
> - suite : ['util'],
> - )
> +@@ -344,7 +344,7 @@ if with_tests
> + )
> + endif
>
> -- test(
>
> -- 'u_debug_stack',
> -- executable(
> -- 'u_debug_stack_test',
> -- files('u_debug_stack_test.cpp'),
> -- include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
> -- dependencies : [idep_mesautil, idep_gtest],
> -- c_args : [c_msvc_compat_args],
> -- ),
> -- suite : ['util'],
> -- )
> --
> - process_test_exe = executable(
> - 'process_test',
> - files('process_test.c'),
> +- foreach t: ['bitset', 'register_allocate', 'u_debug_stack', 'u_qsort']
> ++ foreach t: ['bitset', 'register_allocate', 'u_qsort']
> + test(
> + t,
> + executable(
> --
> 2.33.0

I wanted to apply this to my batched local core-updates-frozen branch,
but I get:

error: corrupt patch at line 69

Could you please resend it?

Thanks!

Maxim
J
J
John Kehayias wrote on 15 Oct 2021 04:15
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 50170@debbugs.gnu.org)
reI0oYP2jCB3nIwqE1ibji2NMv7ycvxFwrWCuveSErrFPlb9b1eGReqvdsZjlYQ6JJq2C42dRT9mJ1T40xhgwkbi-14VOESuil81ZnWhFsM=@protonmail.com
Hi Maxim!

??????? Original Message ???????

On Thursday, October 14th, 2021 at 8:42 PM, Maxim Cournoyer wrote:

Toggle quote (10 lines)
> Hi!
>
> I wanted to apply this to my batched local core-updates-frozen branch,
> but I get:
>
> error: corrupt patch at line 69
>
> Could you please resend it?
>

Looks like the patch for disabling a test (that fails on i686) needed an update. I've updated the version to 21.2.4 which literally just came out (wow Mesa is fast these days with bugfix versions) and adjusted the patch. I've tested that it applies and builds on x86_64 and with --system=i686-linux successfully.

Let me know if you run into any problem with this version!

John
From a1115434c5f67f2b4c2bfe69c0344416c45971d4 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Thu, 14 Oct 2021 22:12:41 -0400
Subject: [PATCH] * gnu/packages/gl.scm (mesa): Update to 21.2.4.

* gnu/packages/patches/mesa-skip-tests.patch: Adjust for current version.
---
gnu/packages/gl.scm | 4 ++--
gnu/packages/patches/mesa-skip-tests.patch | 28 +++++++---------------
2 files changed, 11 insertions(+), 21 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 52b7508d6b..ccb78675f4 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -238,7 +238,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "21.1.6")
+ (version "21.2.4")
(source
(origin
(method url-fetch)
@@ -250,7 +250,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "0dwyk7cxlwna24ap23i8i92a2qcc6xhp16i03zzakpqiz4i03jxi"))
+ "0i2vz3ppcgqm076546imzl11jr3rlch1iv62lffk60mcs61dwvpy"))
(patches
(search-patches "mesa-skip-tests.patch"))))
(build-system meson-build-system)
diff --git a/gnu/packages/patches/mesa-skip-tests.patch b/gnu/packages/patches/mesa-skip-tests.patch
index 8f587ea7ef..7ff571dcf5 100644
--- a/gnu/packages/patches/mesa-skip-tests.patch
+++ b/gnu/packages/patches/mesa-skip-tests.patch
@@ -5,25 +5,15 @@ completely with this patch:
https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091
diff --git a/src/util/meson.build b/src/util/meson.build
-index 0893f64..909b3e0 100644
+index 319b22d9bf7..93790c72675 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
-@@ -289,18 +289,6 @@ if with_tests
- suite : ['util'],
- )
+@@ -344,7 +344,7 @@ if with_tests
+ )
+ endif
-- test(
-- 'u_debug_stack',
-- executable(
-- 'u_debug_stack_test',
-- files('u_debug_stack_test.cpp'),
-- include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
-- dependencies : [idep_mesautil, idep_gtest],
-- c_args : [c_msvc_compat_args],
-- ),
-- suite : ['util'],
-- )
--
- process_test_exe = executable(
- 'process_test',
- files('process_test.c'),
+- foreach t: ['bitset', 'register_allocate', 'u_debug_stack', 'u_qsort']
++ foreach t: ['bitset', 'register_allocate', 'u_qsort']
+ test(
+ t,
+ executable(
--
2.33.0
M
M
Maxim Cournoyer wrote on 15 Oct 2021 04:27
(name . John Kehayias)(address . john.kehayias@protonmail.com)(address . 50170@debbugs.gnu.org)
87mtnbnhth.fsf_-_@gmail.com
Hello!

John Kehayias <john.kehayias@protonmail.com> writes:

Toggle quote (26 lines)
> Hi Maxim!
>
> ??????? Original Message ???????
>
> On Thursday, October 14th, 2021 at 8:42 PM, Maxim Cournoyer wrote:
>
>> Hi!
>>
>> I wanted to apply this to my batched local core-updates-frozen branch,
>> but I get:
>>
>> error: corrupt patch at line 69
>>
>> Could you please resend it?
>>
>
> Looks like the patch for disabling a test (that fails on i686) needed
> an update. I've updated the version to 21.2.4 which literally just
> came out (wow Mesa is fast these days with bugfix versions) and
> adjusted the patch. I've tested that it applies and builds on x86_64
> and with --system=i686-linux successfully.
>
> Let me know if you run into any problem with this version!
>
> John

Successfully applied; thanks for the prompt reply!

Maxim
M
M
Maxim Cournoyer wrote on 12 Nov 2021 07:02
(name . John Kehayias)(address . john.kehayias@protonmail.com)(address . 50170-done@debbugs.gnu.org)
87bl2pq5bv.fsf_-_@gmail.com
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (30 lines)
> Hello!
>
> John Kehayias <john.kehayias@protonmail.com> writes:
>
>> Hi Maxim!
>>
>> ??????? Original Message ???????
>>
>> On Thursday, October 14th, 2021 at 8:42 PM, Maxim Cournoyer wrote:
>>
>>> Hi!
>>>
>>> I wanted to apply this to my batched local core-updates-frozen branch,
>>> but I get:
>>>
>>> error: corrupt patch at line 69
>>>
>>> Could you please resend it?
>>>
>>
>> Looks like the patch for disabling a test (that fails on i686) needed
>> an update. I've updated the version to 21.2.4 which literally just
>> came out (wow Mesa is fast these days with bugfix versions) and
>> adjusted the patch. I've tested that it applies and builds on x86_64
>> and with --system=i686-linux successfully.
>>
>> Let me know if you run into any problem with this version!
>>
>> John

We now have 21.2.4 in core-updates-frozen since commit
3b9b685d051c44206d1b5efce920c85037ec081c.

Thank you!

Closing,

Maxim
Closed
?