(name . Guix-patches)(address . guix-patches@gnu.org)
* gnu/packages/gl.scm (mesa): Update to 21.2.1.
* gnu/packages/patches/mesa-skip-tests.patch: Modify for current version.
---
gnu/packages/gl.scm | 4 ++--
gnu/packages/patches/mesa-skip-tests.patch | 28 +++++++---------------
2 files changed, 11 insertions(+), 21 deletions(-)
Toggle diff (52 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 7a8a478953..d6e754779d 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -239,7 +239,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "21.1.6")
+ (version "21.2.1")
(source
(origin
(method url-fetch)
@@ -251,7 +251,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "0dwyk7cxlwna24ap23i8i92a2qcc6xhp16i03zzakpqiz4i03jxi"))
+ "11qpq16xbxymcgiy0wk787dk4yw2pv8fzgj8d92ng6s11dqycr9c"))
(patches
(search-patches "mesa-skip-tests.patch"))))
(build-system meson-build-system)
diff --git a/gnu/packages/patches/mesa-skip-tests.patch b/gnu/packages/patches/mesa-skip-tests.patch
index 8f587ea7ef..0813fa2a8a 100644
--- a/gnu/packages/patches/mesa-skip-tests.patch
+++ b/gnu/packages/patches/mesa-skip-tests.patch
@@ -5,25 +5,15 @@ completely with this patch:
https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091
diff --git a/src/util/meson.build b/src/util/meson.build
-index 0893f64..909b3e0 100644
+index aa5bfef5dbc..3ec845b05fa 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
-@@ -289,18 +289,6 @@ if with_tests
- suite : ['util'],
- )
+@@ -344,7 +344,7 @@ if with_tests
+ )
+ endif
-- test(
-- 'u_debug_stack',
-- executable(
-- 'u_debug_stack_test',
-- files('u_debug_stack_test.cpp'),
-- include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
-- dependencies : [idep_mesautil, idep_gtest],
-- c_args : [c_msvc_compat_args],
-- ),
-- suite : ['util'],
-- )
--
- process_test_exe = executable(
- 'process_test',
- files('process_test.c'),
+- foreach t: ['bitset', 'register_allocate', 'u_debug_stack', 'u_qsort']
++ foreach t: ['bitset', 'register_allocate', 'u_qsort']
+ test(
+ t,
+ executable(
--
2.33.0