[PATCH] gnu: texlive-texmf: Disable LuaJIT engines on powerpc64le

  • Done
  • quality assurance status badge
Details
4 participants
  • Thiago Jung Bauermann
  • Efraim Flashner
  • Maxime Devos
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Thiago Jung Bauermann
Severity
normal
T
T
Thiago Jung Bauermann wrote on 16 Aug 2021 21:46
(address . guix-patches@gnu.org)
20210816194633.7984-1-bauermann@kolabnow.com
LuaJIT isn’t ported to powerpc64le. ‘texlive-latex-base’ already disables
them, so just do the same in texlive-texmf.

Fix suggested by Mathieu Othacehe <othacehe@gnu.org>.

* gnu/packages/tex.scm (texlive-texmf)[arguments]<#:phases>{texmf-config}:
Disable LuaJIT engines when building for powerpc64le.
---

Hello,

This fixes the build of ‘texlive-texmf’ on powerpc64le. It was failing
with these errors:

fmtutil [ERROR]: not building luajittex due to missing engine: luajittex
fmtutil [ERROR]: not building luajithbtex due to missing engine: luajithbtex

Thank you very much to Mathieu for his help in making this work.

gnu/packages/tex.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 70166941d554..3c0b87352a10 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6821,9 +6821,17 @@ directly generate PDF documents instead of DVI.")
(share (string-append out "/share"))
(texmfroot (string-append share "/texmf-dist/web2c"))
(texmfcnf (string-append texmfroot "/texmf.cnf"))
+ (fmtutilcnf (string-append texmfroot "/fmtutil.cnf"))
(texlive-bin (assoc-ref inputs "texlive-bin"))
(texbin (string-append texlive-bin "/bin"))
(tlpkg (string-append texlive-bin "/share/tlpkg")))
+ ;; LuaJIT is not ported to powerpc64le* yet.
+ (if (string-prefix? "powerpc64le"
+ ,(or (%current-target-system)
+ (%current-system)))
+ (substitute* fmtutilcnf
+ (("^(luajittex|luajithbtex|mfluajit)" m)
+ (string-append "#! " m))))
;; Register SHARE as TEXMFROOT in texmf.cnf.
(substitute* texmfcnf
(("TEXMFROOT = \\$SELFAUTOPARENT")
M
M
Mathieu Othacehe wrote on 17 Aug 2021 14:42
(name . Thiago Jung Bauermann)(address . bauermann@kolabnow.com)(address . 50081@debbugs.gnu.org)
87im045jjm.fsf@gnu.org
Hello,

Toggle quote (5 lines)
> + ;; LuaJIT is not ported to powerpc64le* yet.
> + (if (string-prefix? "powerpc64le"
> + ,(or (%current-target-system)
> + (%current-system)))

Do you think we could use the "target-powerpc?" procedure from (guix
utils) here?

Mathieu
T
T
Thiago Jung Bauermann wrote on 17 Aug 2021 16:22
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 50081@debbugs.gnu.org)
1845462.gg5fxL8uEK@popigai
Hi Mathieu,

Thank you for the quick review.

Em terça-feira, 17 de agosto de 2021, às 09:42:53 -03, Mathieu Othacehe
escreveu:
Toggle quote (10 lines)
> Hello,
>
> > + ;; LuaJIT is not ported to powerpc64le* yet.
> > + (if (string-prefix? "powerpc64le"
> > + ,(or (%current-target-system)
> > + (%current-system)))
>
> Do you think we could use the "target-powerpc?" procedure from (guix
> utils) here?

‘target-powerpc?’ would also match 32-bit PowerPC. LuaJIT does support that
platform, but I couldn’t find out – and can’t test – whether the LuaJIT TeX
engines do as well.

Since ‘texlive-latex-base’ doesn’t exclude 32-bit PowerPC, I’d suggest
doing the same for ‘texlive-texmf’ as well. But I don’t have a strong
opinion about it.

If you think it improves the code, I can use
“,(and (target-powerpc?) (target-64bit?))"


NB: I forgot to mention that this patch is for core-updates-frozen.

--
Thanks,
Thiago
M
M
Maxime Devos wrote on 18 Aug 2021 00:51
Re: [bug#50081] [PATCH] gnu: texlive-texmf: Disable LuaJIT engines on powerpc64le
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
d9c091ebd6f221a23e90d402454bcfa71577525a.camel@telenet.be
Thiago Jung Bauermann via Guix-patches via schreef op ma 16-08-2021 om 16:46 [-0300]:
Toggle quote (36 lines)
> LuaJIT isn’t ported to powerpc64le. ‘texlive-latex-base’ already disables
> them, so just do the same in texlive-texmf.
>
> Fix suggested by Mathieu Othacehe <othacehe@gnu.org>.
>
> * gnu/packages/tex.scm (texlive-texmf)[arguments]<#:phases>{texmf-config}:
> Disable LuaJIT engines when building for powerpc64le.
> ---
>
> Hello,
>
> This fixes the build of ‘texlive-texmf’ on powerpc64le. It was failing
> with these errors:
>
> fmtutil [ERROR]: not building luajittex due to missing engine: luajittex
> fmtutil [ERROR]: not building luajithbtex due to missing engine: luajithbtex
>
> Thank you very much to Mathieu for his help in making this work.
>
> gnu/packages/tex.scm | 8 ++++++++
> 1 file changed, 8 insertions(+)
>
> diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
> index 70166941d554..3c0b87352a10 100644
> --- a/gnu/packages/tex.scm
> +++ b/gnu/packages/tex.scm
> @@ -6821,9 +6821,17 @@ directly generate PDF documents instead of DVI.")
> (share (string-append out "/share"))
> (texmfroot (string-append share "/texmf-dist/web2c"))
> (texmfcnf (string-append texmfroot "/texmf.cnf"))
> + (fmtutilcnf (string-append texmfroot "/fmtutil.cnf"))
> (texlive-bin (assoc-ref inputs "texlive-bin"))
> (texbin (string-append texlive-bin "/bin"))
> (tlpkg (string-append texlive-bin "/share/tlpkg")))
> + ;; LuaJIT is not ported to powerpc64le* yet.

Does that mean LuaJIT _is_ ported to powerpc64be (big endian)?

Toggle quote (4 lines)
> + (if (string-prefix? "powerpc64le"
> + ,(or (%current-target-system)
> + (%current-system)))

If not, then this should be (string-prefix? "powerpc64" ...).
Admittedly, Guix doesn't support powerpc64be ...

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYRw9ZBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7tXWAPkBXT0dtsRgPI9QyNNHskqGHN6i
ZmMPBiWgnVbtsI2v+gD9EuYZIxwu4i7GdU+p2M9L2Xn4V1vGP64UbUEzFfwaiQ4=
=sgT2
-----END PGP SIGNATURE-----


T
T
Thiago Jung Bauermann wrote on 18 Aug 2021 04:53
(name . Maxime Devos)(address . maximedevos@telenet.be)
3676827.Hb33xC9O5H@popigai
Hello Maxime,

Thanks for your review!

Em terça-feira, 17 de agosto de 2021, às 19:51:15 -03, Maxime Devos
escreveu:
Toggle quote (1 lines)
> Thiago Jung Bauermann via Guix-patches via schreef op ma 16-08-2021 om
16:46 [-0300]:
Toggle quote (23 lines)
> > diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
> > index 70166941d554..3c0b87352a10 100644
> > --- a/gnu/packages/tex.scm
> > +++ b/gnu/packages/tex.scm
> > @@ -6821,9 +6821,17 @@ directly generate PDF documents instead of
> > DVI.")
> >
> > (share (string-append out "/share"))
> > (texmfroot (string-append share
> > "/texmf-dist/web2c"))
> > (texmfcnf (string-append texmfroot "/texmf.cnf"))
> >
> > + (fmtutilcnf (string-append texmfroot
> > "/fmtutil.cnf"))>
> > (texlive-bin (assoc-ref inputs "texlive-bin"))
> > (texbin (string-append texlive-bin "/bin"))
> > (tlpkg (string-append texlive-bin
> > "/share/tlpkg")))
> >
> > + ;; LuaJIT is not ported to powerpc64le* yet.
>
> Does that mean LuaJIT _is_ ported to powerpc64be (big endian)?

No, LuaJIT is ported only to 32-bit PowerPC.

Toggle quote (6 lines)
> > + (if (string-prefix? "powerpc64le"
> > + ,(or (%current-target-system)
> > + (%current-system)))
>
> If not, then this should be (string-prefix? "powerpc64" ...).

Ok, I will send a v2 with this change.

Toggle quote (2 lines)
> Admittedly, Guix doesn't support powerpc64be ...

AFAIK powerpc64be is considered legacy nowadays.

--
Thanks,
Thiago
T
T
Thiago Jung Bauermann wrote on 18 Aug 2021 04:55
[PATCH core-updates-frozen v2] gnu: texlive-texmf: Disable LuaJIT engines on powerpc64*
(address . 50081@debbugs.gnu.org)
20210818025528.8621-1-bauermann@kolabnow.com
LuaJIT isn’t ported to 64-bit PowerPC. ‘texlive-latex-base’ already
disables the engines that rely on it, so just do the same in texlive-texmf.

Fix suggested by Mathieu Othacehe <othacehe@gnu.org>.

* gnu/packages/tex.scm (texlive-texmf)[arguments]<#:phases>{texmf-config}:
Disable LuaJIT engines when building for powerpc64le.
---

Hello,

This fixes the build of ‘texlive-texmf’ on powerpc64le. It was failing
with these errors:

fmtutil [ERROR]: not building luajittex due to missing engine: luajittex
fmtutil [ERROR]: not building luajithbtex due to missing engine: luajithbtex

Thank you very much to Mathieu for his help in making this work.

Changes since v1:
- Match target with “powerpc64” prefix rather than “powerpc64le”.

gnu/packages/tex.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 70166941d554..900438ecacd9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6821,9 +6821,17 @@ directly generate PDF documents instead of DVI.")
(share (string-append out "/share"))
(texmfroot (string-append share "/texmf-dist/web2c"))
(texmfcnf (string-append texmfroot "/texmf.cnf"))
+ (fmtutilcnf (string-append texmfroot "/fmtutil.cnf"))
(texlive-bin (assoc-ref inputs "texlive-bin"))
(texbin (string-append texlive-bin "/bin"))
(tlpkg (string-append texlive-bin "/share/tlpkg")))
+ ;; LuaJIT is not ported to powerpc64* yet.
+ (if (string-prefix? "powerpc64"
+ ,(or (%current-target-system)
+ (%current-system)))
+ (substitute* fmtutilcnf
+ (("^(luajittex|luajithbtex|mfluajit)" m)
+ (string-append "#! " m))))
;; Register SHARE as TEXMFROOT in texmf.cnf.
(substitute* texmfcnf
(("TEXMFROOT = \\$SELFAUTOPARENT")
E
E
Efraim Flashner wrote on 18 Aug 2021 12:39
(name . Thiago Jung Bauermann)(address . bauermann@kolabnow.com)
YRzjWYMHcZnN0PX3@3900XT
We now have a target-ppc64le? option which should be useful here.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmEc41kACgkQQarn3Mo9
g1HTmxAArQogqHIen4tkYDCui2NIegIVmYLfmYFnxB+HKKC4AB0lzyCfDrsnGcvZ
cuUvn2ApOw6lBOF0za19qSaK6P/1WORBnTpAHqbZ8Xuq26KyxCA3k4vYGzx0E7V8
nig9iLmL+rT2t8QXRGpoaBoJjmUwmG9rkTDVMFMoK2aWDLEIHKHgfzcMGa/+T0kk
VYDc4HWVskIGiuxfz1cR1BTXRKcBFMw/tREQHxkpTwJC0LgZy5J2MMn1eqjlHq1e
LE3FkToXd+nTT68Lm1AxmLdFuXKkaCu+U5NWqW3K6XTDSbB9ynAyHCMPm3osDT6a
zrxl+RTZJ8pABkWgJlYGXEhESDjmfwP2anHZVq6qCvXGK5/xwPFLMQ1xyZ+wuTow
VtT8WpGBcR4pLmGM4KdJKJlyp9RZt3lyhtvdbwNnLUNiJrdO9u1Zvj6ZG+ip/EkN
vD3anhjlHx/U2ue3k53+TtExsssYIF1QuMh/++qX6uai4a1im2oBp6GGo84lMbFd
KWMvR5L3AwLkSWMN7BTWshfDMQ8vDNpXIxT535Dlojee/wQxSRJ7RInsGRPF2yX3
JRxAa6QMyhNgY1wzqu2BTISiXMc/GZFUzMz8sChX/5yfvjq0Yx5RAPZpiKAotAJK
wBxp6kQ6aXBjiW/mAZrmH8LajSx8657V3a4txF+bAYYHAZq3Qno=
=JtTN
-----END PGP SIGNATURE-----


T
T
Thiago Jung Bauermann wrote on 19 Aug 2021 06:51
6444870.dUALR0brB4@popigai
Em quarta-feira, 18 de agosto de 2021, às 07:39:21 -03, Efraim Flashner
escreveu:
Toggle quote (2 lines)
> We now have a target-ppc64le? option which should be useful here.

Yes, that’s a nice code improvement. But unfortunately it’s mutually
exclusive with Maxime’s request to match against “powerpc64*”.

If people think the ‘target-ppc64le?’ alternative would be better than the
“powerpc64*” one, I can send a v3.

--
Thanks,
Thiago
E
E
Efraim Flashner wrote on 19 Aug 2021 08:52
(name . Thiago Jung Bauermann)(address . bauermann@kolabnow.com)
YR3/qqy1C6aH0jy7@3900XT
On Thu, Aug 19, 2021 at 01:51:56AM -0300, Thiago Jung Bauermann wrote:
Toggle quote (10 lines)
> Em quarta-feira, 18 de agosto de 2021, às 07:39:21 -03, Efraim Flashner
> escreveu:
> > We now have a target-ppc64le? option which should be useful here.
>
> Yes, that’s a nice code improvement. But unfortunately it’s mutually
> exclusive with Maxime’s request to match against “powerpc64*”.
>
> If people think the ‘target-ppc64le?’ alternative would be better than the
> “powerpc64*” one, I can send a v3.

IMO since powerpc64-linux isn't an actually supported architecture in
Guix we can ignore it for now and focus on powerpc64le. As far as
powerpc, as I'm the only one using it (I believe) you can pretty much
treat it like mips64el; try not to affect it unnecessarily but no
testing needed.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmEd/6IACgkQQarn3Mo9
g1H5sxAAmB5xKf0c6KSpfdFAUmU6Js2mvYbo4idOcuI25y+96+nfN9kPka3kuHLv
XyAGio/oeRViWKZweKSNTLRhyRn63toaq8/6MJuolIlmN+htFgLH/NUk60YraT19
SCnPRhygbtDYwmFLaIHBEki5Q+IxT9s2qVOlZqH6MiyyY2yMl3TB5OsumOrX4zbE
D0261+7YuqnHN9XLZZSx7BE87iRp0PruFqzffT2jarxc+aV+xqMkSY7Qma0S7mTt
wXrcj7qHVyZZbUw+iByVbgagM4B+qyEzENBVwn3iWPofUXLdhPuVJA87/GF2l9Z9
Rwgm5T3Z9nkIVMno84/PCVoc8IGMBoql1zql9zpn/7/OZsh4T/I4DpwceNOK6b3w
yIlxaJMEtddcUuHRtWQckD6dYNHZpBu9QjEuK9DagdDp6x+BDIZMo/KJfSdfoMxR
1KEcTDMKagzy2TASRBk0bpf6JZmCVfGFvG/2LfBG7nKzxQfX25pXlXXlGK73VTHR
CvXOCwb2z1vjDeQlsD/z5ZhY4238kWKgInZcFp993MMnD85Iv3PPGl6Cj3AZxZfr
exgZN9ANyHfhZeTRZb8D4AoKdMreQmhcdTZ1HiC3Gwxxt2cXKEP2qAOeSDdyYH0e
Q08N5n9e1ENQd/8Kad9XFinRRavF6Y8fv2fEWgEbuGZT6wlOGos=
=Sb2z
-----END PGP SIGNATURE-----


T
T
Thiago Jung Bauermann wrote on 20 Aug 2021 02:41
(name . Efraim Flashner)(address . efraim@flashner.co.il)
3527013.bLhiEQ94sO@popigai
Hello Efraim,

Em quinta-feira, 19 de agosto de 2021, às 03:52:26 -03, Efraim Flashner
escreveu:
Toggle quote (14 lines)
> On Thu, Aug 19, 2021 at 01:51:56AM -0300, Thiago Jung Bauermann wrote:
> > Em quarta-feira, 18 de agosto de 2021, às 07:39:21 -03, Efraim Flashner
> > escreveu:
> > > We now have a target-ppc64le? option which should be useful here.
> >
> > Yes, that’s a nice code improvement. But unfortunately it’s mutually
> > exclusive with Maxime’s request to match against “powerpc64*”.
> >
> > If people think the ‘target-ppc64le?’ alternative would be better than
> > the “powerpc64*” one, I can send a v3.
>
> IMO since powerpc64-linux isn't an actually supported architecture in
> Guix we can ignore it for now and focus on powerpc64le.

I agree with you. I’ll send a v3 then.

Toggle quote (4 lines)
> As far as powerpc, as I'm the only one using it (I believe) you can
> pretty much treat it like mips64el; try not to affect it unnecessarily
> but no testing needed.

Ok, thanks.

As an aside, I tried building a powerpc64le kernel with CONFIG_COMPAT set
to see if it would allow running 32-bit binaries but it fails during
linking. The 32-bit support feature apparently bit-rotted.

--
Thanks,
Thiago
T
T
Thiago Jung Bauermann wrote on 20 Aug 2021 02:47
[PATCH core-updates-frozen v3] gnu: texlive-texmf: Disable LuaJIT engines on powerpc64le
(address . 50081@debbugs.gnu.org)
20210820004715.21077-1-bauermann@kolabnow.com
LuaJIT isn’t ported to 64-bit PowerPC. ‘texlive-bin’ and
‘texlive-latex-base’ already disable the engines that rely on it, so just
do the same in texlive-texmf.

Fix suggested by Mathieu Othacehe <othacehe@gnu.org>.

Also, for consistency use ‘target-ppc64le’ in ‘texlive-bin’ as well.

* gnu/packages/tex.scm (texlive-bin)[arguments]<#:configure-flags>: Use
‘target-ppc64le’.
(texlive-texmf)[arguments]<#:phases>{texmf-config}:
Disable LuaJIT engines when building for powerpc64le.
---

Hello,

This fixes the build of ‘texlive-texmf’ on powerpc64le. It was failing
with these errors:

fmtutil [ERROR]: not building luajittex due to missing engine: luajittex
fmtutil [ERROR]: not building luajithbtex due to missing engine: luajithbtex

Thank you very much to Mathieu for his help in making this work.

Changes since v2:
- Use ‘target-ppc64le?’ to match target string.
- Change ‘texlive-bin’ to also use ‘target-ppc64le?’.

Changes since v1:
- Match target with “powerpc64” prefix rather than “powerpc64le”.

gnu/packages/tex.scm | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4500f1929264..9ec015482808 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -339,8 +339,7 @@ files from LOCATIONS with expected checksum HASH. CODE is not currently in use.
"--with-system-zlib"
"--with-system-zziplib"
;; LuaJIT is not ported to powerpc64le* yet.
- ,@(if (string-prefix? "powerpc64le" (or (%current-target-system)
- (%current-system)))
+ ,@(if (target-ppc64le?)
'("--disable-luajittex"
"--disable-luajithbtex"
"--disable-mfluajit")
@@ -6829,9 +6828,15 @@ directly generate PDF documents instead of DVI.")
(share (string-append out "/share"))
(texmfroot (string-append share "/texmf-dist/web2c"))
(texmfcnf (string-append texmfroot "/texmf.cnf"))
+ (fmtutilcnf (string-append texmfroot "/fmtutil.cnf"))
(texlive-bin (assoc-ref inputs "texlive-bin"))
(texbin (string-append texlive-bin "/bin"))
(tlpkg (string-append texlive-bin "/share/tlpkg")))
+ ;; LuaJIT is not ported to powerpc64* yet.
+ (if ,(target-ppc64le?)
+ (substitute* fmtutilcnf
+ (("^(luajittex|luajithbtex|mfluajit)" m)
+ (string-append "#! " m))))
;; Register SHARE as TEXMFROOT in texmf.cnf.
(substitute* texmfcnf
(("TEXMFROOT = \\$SELFAUTOPARENT")
E
E
Efraim Flashner wrote on 22 Aug 2021 13:19
(name . Thiago Jung Bauermann)(address . bauermann@kolabnow.com)
YSIy1M9fde4hMdoq@3900XT
I took out the unrelated patch to texlive-bin and pushed the part for
texlive-texmf.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmEiMtMACgkQQarn3Mo9
g1FE7g//V87PdJWJwndA8Ptugw6sIqcLHwUifommF0HpM0V08jQ+x17g+oVct++r
i0UVKbWkfEk8z1X0Za1NkDutALYApvlS1It4+iSRmmu3IALb9UEI3LzDDKH5Vk1l
4hqD8/VCs28kgY92t85fM2Pwk8zctF35Db+Dl10rR5poAFUWs9P6YaAh0SuzU/cH
ZLcw36K6bbwaiaVPFLXNzapUeisQ+/SZyWyItjtu/wLwoX/bN1i4/4VDQXV6HyIV
yoVkLskGO+vsmck9D7+zQxGa1f/Ggcx38RLT21x1kqs4mGM4TTYChY1ZAqKmLtLl
TJK1+S7OWk1WVoyPhrt+CNPd6FoQIhz3KCAmABOgmTDUIxHdzMxyy1XKntBmsqLW
RQEJWDcTcVxQqCFkcXtNFaSuzLidAIV1AT3QursRMp6XGcsRSblCy2Z0o1qRfvKx
SLDzJZQM3gcmQxgN2tfTehaNrZ+4neeFeeMrQt9hU+HIYkD2R9lZTzmuJaDB0kfk
3nn6M2l3+BxLSp7aCMC9p5nhpD93AIHtnCjgXsFa5Upw5eW/xkPNhgnY2N8mF2I8
KIe/awgsiKl/38scPC3DvKREwqQZ2AgA3XQzzUzJbalvigkJ+8h1bzov34teyVrD
sAKBDJTWNzmJddhmRVkS2DcKNHjvbTIKWWrE5YgNHWVR0Umpno0=
=Atzu
-----END PGP SIGNATURE-----


Closed
T
T
Thiago Jung Bauermann wrote on 23 Aug 2021 00:49
4181111.yRK4exay7Z@popigai
Hello Efraim,

Em domingo, 22 de agosto de 2021, às 08:19:48 -03, Efraim Flashner
escreveu:
Toggle quote (2 lines)
> I took out the unrelated patch to texlive-bin

Ok. Do you think it’s worth submitting that part separately, or is it just
unnecessary code churn?

Toggle quote (2 lines)
> and pushed the part for texlive-texmf.

Thank you!

--
Thanks,
Thiago
E
E
Efraim Flashner wrote on 23 Aug 2021 08:19
(name . Thiago Jung Bauermann)(address . bauermann@kolabnow.com)
YSM+A7GyZu7fPwkf@3900XT
On Sun, Aug 22, 2021 at 07:49:45PM -0300, Thiago Jung Bauermann wrote:
Toggle quote (14 lines)
> Hello Efraim,
>
> Em domingo, 22 de agosto de 2021, às 08:19:48 -03, Efraim Flashner
> escreveu:
> > I took out the unrelated patch to texlive-bin
>
> Ok. Do you think it’s worth submitting that part separately, or is it just
> unnecessary code churn?
>
> --
> Thanks,
> Thiago
>

I'd leave it and wait for it to get touched the next time. Its like
removing the trailing #t in core-updates, when we're already doing
something to the package is a good time to make the change.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmEjPgAACgkQQarn3Mo9
g1E7Dw//emECKDUfJy2cUwqQlCrSBIgRGAs9eugMUH9163vyxNx0WmMwMSh6YIC6
l9N9V9Z5EOrYn0pSOhrRMrR2ZhilmQ0+NMC7vPj8I6MEsCXoHiCpgxK9SXX0Fiwx
Ie2gf8jt9UPwzZ6DoRRMWPFGJkrYetIwqNczpTIVNHNlglLjmWyIoF2p9pOrc9LE
IjGVQEgDkNCqW9Q+tcF1r3tKNC3GkAFxkt/Ti6q52hIYRGyj51HPQf8k0bF/uCBy
gOIq6PxpNicx7RzVaEEvI63W1hwcNZrWj1qfPrvnHvOoLWV9vnuQf1iWM3C7lG3e
wbD7ADxDxLgQq98NqtB29vyJhnI30f+eQTCmPR8Ab3i1JxchUe6TJ7cUzePUBDxS
+jKUSuox3tPlUWwzxTckoL0+4yOq0QC8La2tuzx/KIvZjh+KtDRmciQnliX5oc36
pDrXioyiotj8y9CsUsGfoXP23l6onp62AwRRsjxrPyYnFoEpQBnm/MpOaAsGE1ji
yAkMTSeDR64mxepHtHSokyUDgU0aglg9nKZ1eEjY/FXPSqdRM4T4Re9abAc/BdDi
FO62CoeSMAOlNn7+nnJKDRBvWYvrn67D74sEMMel+tsX8lm8GVlzLcJ1wr8h2wAX
8lQyATgz9GQV1DK2UDL79SvUlFw9VrLgXca5rfjkMYHzDhstetI=
=9/Pj
-----END PGP SIGNATURE-----


Closed
?