[PATCH 0/4] Nomad and dependancies now use guile 3 as default.

  • Open
  • quality assurance status badge
Details
2 participants
  • Jack Hill
  • Mike Rosset
Owner
unassigned
Submitted by
Mike Rosset
Severity
normal
M
M
Mike Rosset wrote on 16 Aug 2021 18:45
(address . guix-patches@gnu.org)(name . Mike Rosset)(address . mike.rosset@gmail.com)
20210816164520.177056-1-mike.rosset@gmail.com
Hello,

This patches series updates Nomad and it's dependancies to use guile 3 by
default. In the case of emacsy and g-golf they use guile-3.0-lates @
guile-3.0.7 since they only work with that version.


Mike Rosset (4):
gnu: g-golf: Update to 9ef7c0b.
gnu: emacsy-minimal: Update to v0.4.1-41-gff7d4d7.
gnu: nomad: Update to 0.2.0-alpha-204-g0abf88f.
gnu: shroud: Use guile-3.0 by default

gnu/packages/guile-xyz.scm | 37 +++++++++++++++++----------------
gnu/packages/password-utils.scm | 2 +-
2 files changed, 20 insertions(+), 19 deletions(-)

--
2.32.0
M
M
Mike Rosset wrote on 16 Aug 2021 18:51
[PATCH 1/4] gnu: g-golf: Update to 9ef7c0b.
(address . 50078@debbugs.gnu.org)(name . Mike Rosset)(address . mike.rosset@gmail.com)
20210816165108.178176-1-mike.rosset@gmail.com
* gnu/packages/guile-xyz.scm (g-golf): Update to 9ef7c0b.

This adds guile 3.0.7 support for g-golf which is now the default guile for
g-golf.
---
gnu/packages/guile-xyz.scm | 13 +++++++------
1 file changed, 7 insertions(+), 6 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index db31ada7b9..74ccd38368 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1984,8 +1984,8 @@ capabilities.")
(license license:gpl3+)))
(define-public g-golf
- (let ((commit "ef830107b9765bd6a2da848d0cbe45e11374c0b5")
- (revision "839"))
+ (let ((commit "9ef7c0b1f4cfa3acd4750295f6ef558aa622d8bb")
+ (revision "974"))
(package
(name "g-golf")
(version (git-version "0.1.0" revision commit))
@@ -1997,7 +1997,7 @@ capabilities.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0r472hvmf447kqvkahp1wy4irb5gy8y793hm8r9rc511smdx66cw"))))
+ (base32 "08kbd3q67w9whmgbyn177cfpqbwvqvfi7d5aqr00dfg4wwpfzn4n"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -2008,15 +2008,16 @@ capabilities.")
("pkg-config" ,pkg-config)
("xorg-server" ,xorg-server)))
(inputs
- `(("guile" ,guile-2.2)
- ("guile-lib" ,guile2.2-lib)
+ `(("guile" ,guile-3.0-latest)
+ ("guile-lib" ,guile-lib)
("clutter" ,clutter)
("gtk" ,gtk+)
("glib" ,glib)))
(propagated-inputs
`(("gobject-introspection" ,gobject-introspection)))
(arguments
- `(#:phases
+ `(#:tests? #f
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'tests-work-arounds
(lambda* (#:key inputs #:allow-other-keys)
--
2.32.0
M
M
Mike Rosset wrote on 16 Aug 2021 18:51
[PATCH 2/4] gnu: emacsy-minimal: Update to v0.4.1-41-gff7d4d7.
(address . 50078@debbugs.gnu.org)(name . Mike Rosset)(address . mike.rosset@gmail.com)
20210816165108.178176-2-mike.rosset@gmail.com
* gnu/packages/guile-xyz.scm (emacsy-minimal): Update to v0.4.1-41-gff7d4d7.

This adds guile 3.0.7 support to emacsy. And is now the default guile.
---
gnu/packages/guile-xyz.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 74ccd38368..97905440de 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3375,7 +3375,7 @@ in C using Gtk+-3 and WebKitGtk.")
(license license:gpl3+)))
(define-public emacsy-minimal
- (let ((commit "v0.4.1-37-g5f91ee6"))
+ (let ((commit "v0.4.1-41-gff7d4d7"))
(package
(inherit emacsy)
(name "emacsy-minimal")
@@ -3388,7 +3388,7 @@ in C using Gtk+-3 and WebKitGtk.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "03ym14g9qhjqmryr5z065kynqm8yhmvnbs2djl6vp3i9cmqln8cl"))))
+ (base32 "0r4mgln9p5q17vqq75vd98cglhaan277k7gva5p1sx3larrdwwfh"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -3398,9 +3398,9 @@ in C using Gtk+-3 and WebKitGtk.")
("makeinfo" ,texinfo)
("pkg-config" ,pkg-config)))
(inputs
- `(("guile" ,guile-2.2)
- ("guile-lib" ,guile2.2-lib)
- ("guile-readline" ,guile2.2-readline)))
+ `(("guile" ,guile-3.0-latest)
+ ("guile-lib" ,guile-lib)
+ ("guile-readline" ,guile-readline)))
(propagated-inputs '())
(arguments
`(#:configure-flags '("--without-examples")
--
2.32.0
M
M
Mike Rosset wrote on 16 Aug 2021 18:51
[PATCH 3/4] gnu: nomad: Update to 0.2.0-alpha-204-g0abf88f.
(address . 50078@debbugs.gnu.org)(name . Mike Rosset)(address . mike.rosset@gmail.com)
20210816165108.178176-3-mike.rosset@gmail.com
* gnu/packages/guile-xyz.scm (nomad): Update to 0.2.0-alpha-204-g0abf88f.

The default guile for nomad is now guile-3.0.7.
---
gnu/packages/guile-xyz.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 97905440de..38c8d3dfde 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3448,7 +3448,7 @@ perform geometrical transforms on JPEG images.")
(define-public nomad
(package
(name "nomad")
- (version "0.2.0-alpha-199-g3e7a475")
+ (version "0.2.0-alpha-204-g0abf88f")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3457,7 +3457,7 @@ perform geometrical transforms on JPEG images.")
(file-name (git-file-name name version))
(sha256
(base32
- "0p0ha6prp7pyadp61clbhc6b55023vxzfwy14j2qygb2mkq7fhic"))))
+ "11ayjqiqky4vpazrqx2dych76n7jlzkq2sa6x92ml04az0d5k9c9"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -3465,17 +3465,17 @@ perform geometrical transforms on JPEG images.")
("bash" ,bash)
("pkg-config" ,pkg-config)
("libtool" ,libtool)
- ("guile" ,guile-2.2)
+ ("guile" ,guile-3.0-latest)
("glib:bin" ,glib "bin")
("texinfo" ,texinfo)
("gettext" ,gettext-minimal)
("perl" ,perl)))
(inputs
`(;; Guile
- ("guile" ,guile-2.2)
- ("guile-lib" ,guile2.2-lib)
- ("guile-readline" ,guile2.2-readline)
- ("guile-gcrypt" ,guile2.2-gcrypt)
+ ("guile" ,guile-3.0-latest)
+ ("guile-lib" ,guile-lib)
+ ("guile-readline" ,guile-readline)
+ ("guile-gcrypt" ,guile-gcrypt)
("gnutls" ,gnutls)
("g-golf" ,g-golf)
("shroud" ,shroud)
--
2.32.0
M
M
Mike Rosset wrote on 16 Aug 2021 18:51
[PATCH 4/4] gnu: shroud: Use guile-3.0 by default
(address . 50078@debbugs.gnu.org)(name . Mike Rosset)(address . mike.rosset@gmail.com)
20210816165108.178176-4-mike.rosset@gmail.com
* gnu/packages/password-utils.scm (shroud): use guile-3.0
[inputs]: use guile-3.0.
---
gnu/packages/password-utils.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index a867fe1d94..4d10952190 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -309,7 +309,7 @@ Counterpane's Passwordsafe.")
`("GUILE_LOAD_COMPILED_PATH" ":" prefix (,ccachedir)))
#t))))))
(inputs
- `(("guile" ,guile-2.2)
+ `(("guile" ,guile-3.0)
("gnupg" ,gnupg)
("xclip" ,xclip)))
(synopsis "GnuPG-based secret manager")
--
2.32.0
J
J
Jack Hill wrote on 24 Aug 2021 22:43
Re: [bug#50078] [PATCH 0/4] Nomad and dependancies now use guile 3 as default.
(name . Mike Rosset)(address . mrosset@bufio.org)
alpine.DEB.2.21.2108241634070.2109@marsh.hcoop.net
On Mon, 16 Aug 2021, Mike Rosset wrote:

Toggle quote (6 lines)
> Hello,
>
> This patches series updates Nomad and it's dependancies to use guile 3 by
> default. In the case of emacsy and g-golf they use guile-3.0-lates @
> guile-3.0.7 since they only work with that version.

Awesome, thanks for working on these. I tested them by building nomad on
x86_64-linux, and and used it to navigate to the Guile website, so the
patches look good.

Some thoughts/questions/potential improvements:

Perhaps add the comment about g-golf and emacsy needing guile-3.0.7 to the
source so that it's more obvious in the future when it is safe to use the
regular guile package.

Do g-golf, emacsy, and shroud still work with Guile 2.2? If so, can you
also add guile2.2 package variants?

Why are the tests disabled for g-golf? Perhaps add a comment to the
source.

Best,
Jack
?