[PATCH 0/1] Add python-flask-debugtoolbar.

  • Open
  • quality assurance status badge
Details
4 participants
  • Arun Isaac
  • Munyoki Kilyungi
  • jgart
  • BonfaceKilz
Owner
unassigned
Submitted by
BonfaceKilz
Severity
normal
B
B
BonfaceKilz wrote on 16 Aug 2021 11:47
(address . guix-patches@gnu.org)(name . BonfaceKilz)(address . me@bonfacemunyoki.com)
20210816094722.9883-1-me@bonfacemunyoki.com
Hi. Find attach a patch that adds python-flask-debugtoolbar to GUIX.

BonfaceKilz (1):
gnu: Add python-flask-debugtoolbar.

gnu/packages/python-web.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

--
2.31.1
B
B
BonfaceKilz wrote on 16 Aug 2021 11:50
[PATCH 1/1] gnu: Add python-flask-debugtoolbar.
(address . 50076@debbugs.gnu.org)(name . BonfaceKilz)(address . me@bonfacemunyoki.com)
20210816095059.10480-1-me@bonfacemunyoki.com
* gnu/packages/python-web.scm (python-flask-debugtoolbar): New variable.
---
gnu/packages/python-web.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 32b4aa4bf0..c8f0ab3940 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3005,6 +3005,32 @@ and Jinja2 template engine. It is called a micro framework because it does not
presume or force a developer to use a particular tool or library.")
(license license:bsd-3)))
+(define-public python-flask-debugtoolbar
+ (package
+ (name "python-flask-debugtoolbar")
+ (version "0.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Flask-DebugToolbar" version))
+ (sha256
+ (base32
+ "1d5asdnk8bmh6m46pzg3i7677cjgdm9mlm3wcpk19q7dak9pjkiw"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-blinker" ,python-blinker)
+ ("python-flask" ,python-flask)
+ ("python-itsdangerous" ,python-itsdangerous)
+ ("python-werkzeug" ,python-werkzeug)))
+ (home-page
+ "https://flask-debugtoolbar.readthedocs.io/")
+ (synopsis
+ "A toolbar overlay for debugging Flask applications.")
+ (description
+ "This extension adds a toolbar overlay to Flask applications containing
+useful information for debugging.")
+ (license license:bsd-3)))
+
(define-public python-flask-wtf
(package
(name "python-flask-wtf")
--
2.31.1
A
A
Arun Isaac wrote on 23 Aug 2021 22:53
(name . BonfaceKilz)(address . me@bonfacemunyoki.com)(address . 50076@debbugs.gnu.org)
87tujfrihc.fsf@systemreboot.net
Hi Bonface,

Thanks for contributing! :-) Some feedback follows.

1. Please add a copyright header.
2. Could you try packaging the tests? I think tests use
pytest. Currently, no tests are run during the check phase.

Toggle quote (3 lines)
> + (synopsis
> + "A toolbar overlay for debugging Flask applications.")

3. Could you remove the article "A" at the beginning, and the period at
the end? Quoting from our manual at "(guix) Synopses and Descriptions":

Toggle snippet (6 lines)
Synopses must start with a capital letter and must not end with a
period. They must not start with “a” or “the”, which usually does not
bring anything; for instance, prefer “File-frobbing tool” over “A tool
that frobs files”.

Toggle quote (4 lines)
> + (description
> + "This extension adds a toolbar overlay to Flask applications containing
> +useful information for debugging.")

4. Finally, a nitpick: It would be more consistent with the rest of Guix
if the synopsis and description started on the same line instead of on
the next. So, something like this:

Toggle snippet (4 lines)
(description "This extension adds a toolbar overlay to Flask applications
containing useful information for debugging.")

Thanks!
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmEkCq8bHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuz3jwIAJVxKLvog80YidrSuRl9
p3BJMrS+A6BquCZv/XYy4XGJigCir5QMDRLpM4xGJxbP9ebFlSeHPHTkx9olbLLj
KluMZcmR7VN+aptpVxCr1JG5YuFbUtlNKEW7+CsEUb402Ch2KorQbin48EIpmJaK
Q8uFQ7dNguqyQ3qM//23YsFtDifu+bI/Y8R862g2R/uXaZiT91FcRLOdoGZsB3W3
nSrbNOYcPk77fSc7KxI7hPeUEeaX7JarSVr8vNoiqhgRdHw9qjDiVpWfsIxhcrUM
DZHw21dVeqjpGtITN0ziWX/oLTQrSxJQUeHW5dKdxT335pUyByZnIRW0gPphHElQ
DGI=
=O0h+
-----END PGP SIGNATURE-----

B
B
Bonface Munyoki K. wrote on 27 Aug 2021 13:14
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 50076@debbugs.gnu.org)
86r1eff8cb.fsf@bonfacemunyoki.com
Arun Isaac <arunisaac@systemreboot.net> anaandika:
Toggle quote (5 lines)
> Hi Bonface,
>
> Thanks for contributing! :-) Some feedback follows.
>
> 1. Please add a copyright header.
Cool. Thanks for the gentle reminder.
Toggle quote (3 lines)
> 2. Could you try packaging the tests? I think tests use
> pytest. Currently, no tests are run during the check phase.
>
Cool. I'll try to work out how to do that.
Toggle quote (23 lines)
>> + (synopsis
>> + "A toolbar overlay for debugging Flask applications.")
>
> 3. Could you remove the article "A" at the beginning, and the period at
> the end? Quoting from our manual at "(guix) Synopses and Descriptions":
>
> Synopses must start with a capital letter and must not end with a
> period. They must not start with “a” or “the”, which usually does not
> bring anything; for instance, prefer “File-frobbing tool” over “A tool
> that frobs files”.
>
>
>> + (description
>> + "This extension adds a toolbar overlay to Flask applications containing
>> +useful information for debugging.")
>
> 4. Finally, a nitpick: It would be more consistent with the rest of Guix
> if the synopsis and description started on the same line instead of on
> the next. So, something like this:
>
> (description "This extension adds a toolbar overlay to Flask applications
> containing useful information for debugging.")
>
Much thanks for the above suggestions! I'll work
on this and submit a revised patch over the
weekend.
--
Bonface M. K. D4F09EB110177E03C28E2FE1F5BBAE1E0392253F
Free Software Activist
Humble GNU Emacs User | Bearer of scheme-y parens
Curator: https://upbookclub.com | Twitter: @BonfaceKilz
-----BEGIN PGP SIGNATURE-----

iQJKBAEBCAA0FiEE1PCesRAXfgPCji/h9buuHgOSJT8FAmEoyQYWHG1lQGJvbmZh
Y2VtdW55b2tpLmNvbQAKCRD1u64eA5IlP1F9D/9qYf7EOpYwlcNAqFtNeqSuyi8Y
ThUHU3/4NeB8uzKKTYbrtxtjynkF22dIFJ5HQKNXzVn/qp8nGusHpMhBeQ5SN5kY
732rdqZ7YoMzdy8z3kEW6dmsJOEotNsQ7BEj3LiGgLMehwXpT4XtDTZO20HqHAWV
JuQYY+PfeXB1XF/DIkYobayXxniDr4+8oA6rVJjH+YN1rZQxZHwS7BQExHviwEV+
sdApI/F/1yFa4llKEdNfMfHSenpFFhfKyErWXPT4VIrM4PTm0OyEAiSgkJa+/iwj
FkN0nh/USE41WDL81OzX9eJ78ke/SNhfAsRnAPx7TQ4S70kYvs4DuRkwksciueaX
OSNQ1fkJOK/QyJH2+QRIpW6lLM53Wjk4j/N+nV0kUNUeM5h9lqOcPPffVPxOWC8y
Ybr6xZfdPKFKA3hkI/shuTNv1Ifl74KDdq2imPMXYGHsPLrmmf1XzqqVnCHHoftF
6MpeOyGM8B5zuPrMBbp8/Xc8TXM6s+MzW9d/yQxjbTljdQ6OpD0CkYF/DChhygRx
x5FejL7UraKOofnCVrCVpQMMNenHruxNSfn9X09t9f9G2RL98GaaKyGhwbdkzUbN
XSy2CvhVCa0sjuNCyfozuBcL4FtY29XTFSHbrZXBH5WknnnS0b7HWLbyl2gpDyh6
RoyNXcqDBxOMwMq7bg==
=AY0F
-----END PGP SIGNATURE-----

J
Re: [PATCH 0/1] Add python-flask-debugtoolbar.
(name . Arun Isaac)(address . arunisaac@systemreboot.net)
3f6848b904e82e3081743ef119a3b7fb@dismail.de
Hi Bonz,

Are you still interested in picking this issue up again?

The only problem I see with this package is that it vendors 63 javascript files including dependencies like jquery.

Hi Arun, is this a non issue for upstream guix or what should we do here?

What is our current policy regarding jquery?

all best,

jgart
M
M
Munyoki Kilyungi wrote on 22 May 2023 09:28
(name . Arun Isaac)(address . arunisaac@systemreboot.net)
87mt1w7rlc.fsf@saitama.mail-host-address-is-not-set
"jgart" <jgart@dismail.de> aliandika:

Toggle quote (4 lines)
> Hi Bonz,
>
> Are you still interested in picking this issue up again?
>
Sure no problem. I'll try looking at this later
tonight (EAT). Thanks for the follow-up.

Toggle quote (10 lines)
> The only problem I see with this package is that it vendors 63 javascript files including dependencies like jquery.
>
> Hi Arun, is this a non issue for upstream guix or what should we do here?
>
> What is our current policy regarding jquery?
>
> all best,
>
> jgart

--
(Life is like a pencil that will surely run out,
but will leave the beautiful writing of life.)
(D4F09EB110177E03C28E2FE1F5BBAE1E0392253F
(hkp://keys.openpgp.org))
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCAA3FiEE1PCesRAXfgPCji/h9buuHgOSJT8FAmRrGY8ZHGJvbmZhY2Vt
dW55b2tpQGdtYWlsLmNvbQAKCRD1u64eA5IlP4n6D/90HDsuZ8rfEt7trPpl45gq
3urzurn6dfPNLyfy6ogPwjtwL9stceR1pDNL4Y6ymR6myeBYolYigCy0rtInI/tr
036Pg5ZhzQJaJm5hk5tzBYcS70IIB0qsGzPfAT/vHrGYG5Cwkli+zJbeBfLV4+4n
AppdoRNyrEpVs06yhO4UVKbT4QeSWPVItwxCX0itHmReZKldvEqS6CzvzH6vg/C6
TwreEklixQF5WZ1BOMcSZdZHerurHmstrXdeei68k9L1CBJBl1KMW3xSKZo2R14v
mixOgYOqyGOPb91qzTbDwQwGDJhOb67deAUZsHK/jljvxDVmGE6nffk8mrY8co0+
IqYOWsTZgKeUMHXu2YKtY7bW98dW5cjxFzTkX2HmMkPEMLOwc0yf5j75Gvr7ObLx
KR2qPCXdST+tjgrAz9lkf661DtLqlU15sYCsUZRAX9q6Ukzf9aVr/szAHswsyZLY
k3sU7+d5jDFIXdbVPGdLstsMFFqSE99MF1EqoPInVZMpbLBaB4p1bHgJHm1RtfMr
U6YowiMkuNYqEs62aw7m7BmqU+mQUMhM9W9ipwPh2Dql/vUMnqGJXUbkng2d9jZ4
uHJvSWWBCMYjyuo5FvJBPnodmSN/M/nFF+f6ceqg8uExW4CZyBW8L5MgtZ4Ftqi1
WbuR+joXAfp74cvzEnmidg==
=PJBe
-----END PGP SIGNATURE-----

A
A
Arun Isaac wrote on 24 May 2023 20:07
878rddzjqb.fsf@systemreboot.net
Toggle quote (6 lines)
> The only problem I see with this package is that it vendors 63
> javascript files including dependencies like jquery.
>
> Hi Arun, is this a non issue for upstream guix or what should we do
> here?

As long as these javascript files are actual source and are not minified
source, this should be fine. Minified source is considered to be a
binary. This is the precedent set in packages such as js-mathjax.
?