[leo@famulari.name: Re: 02/02: gnu: syncthing: Prepare for cross-compiling.]

  • Open
  • quality assurance status badge
Details
One participant
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 15 Aug 2021 22:44
(address . bug-guix@gnu.org)
YRl8yOId0XaxSUNP@jasmine.lan
I meant to send this to bug-guix...

----- Forwarded message from Leo Famulari <leo@famulari.name> -----

Date: Sun, 15 Aug 2021 16:42:19 -0400
From: Leo Famulari <leo@famulari.name>
To: guix-devel@gnu.org
Cc: Efraim Flashner <efraim@flashner.co.il>
Subject: Re: 02/02: gnu: syncthing: Prepare for cross-compiling.

On Mon, Apr 26, 2021 at 02:33:56PM -0400, guix-commits@gnu.org wrote:
Toggle quote (13 lines)
> efraim pushed a commit to branch master
> in repository guix.
>
> commit b33f5d7ff0627424a06fd0416761cd81c350e20a
> Author: Efraim Flashner <efraim@flashner.co.il>
> AuthorDate: Mon Apr 26 21:30:15 2021 +0300
>
> gnu: syncthing: Prepare for cross-compiling.
>
> * gnu/packages/syncthing.scm (syncthing)[arguments]: Add custom
> 'pre-build phase to not set a local GOBIN directory. Adjust custom
> 'build and 'install phases accordingly.

This commit broke splitting the package into two outputs "out" and
"utils".

When everything is working, the utils output should look like this:

------
$ tree /gnu/store/zansw6f7i61glpa2f5hsbpazwg6qfi2v-syncthing-1.15.1-utils
/gnu/store/zansw6f7i61glpa2f5hsbpazwg6qfi2v-syncthing-1.15.1-utils
??? bin
?   ??? stcompdirs
?   ??? stcrashreceiver
?   ??? stdisco
?   ??? stdiscosrv
?   ??? stevents
?   ??? stfileinfo
?   ??? stfinddevice
?   ??? stfindignored
?   ??? stgenfiles
?   ??? stindex
?   ??? strelaypoolsrv
?   ??? strelaysrv
?   ??? stsigtool
?   ??? stvanity
?   ??? stwatchfile
?   ??? uraggregate
?   ??? ursrv
??? share
??? doc
?   ??? syncthing-1.15.1
?   ??? LICENSE
??? man
??? man1
?   ??? stdiscosrv.1.gz
?   ??? strelaysrv.1.gz
??? man5
?   ??? syncthing-config.5.gz
?   ??? syncthing-stignore.5.gz
??? man7
??? syncthing-bep.7.gz
??? syncthing-device-ids.7.gz
??? syncthing-event-api.7.gz
??? syncthing-faq.7.gz
??? syncthing-globaldisco.7.gz
??? syncthing-localdisco.7.gz
??? syncthing-networking.7.gz
??? syncthing-relay.7.gz
??? syncthing-rest-api.7.gz
??? syncthing-security.7.gz
??? syncthing-versioning.7.gz

8 directories, 33 files
------

The broken state looks like this:

------
$ tree /gnu/store/b1jz5rnwjgzvl7hd99rd1r5958rwxh5x-syncthing-1.15.1-utils
/gnu/store/b1jz5rnwjgzvl7hd99rd1r5958rwxh5x-syncthing-1.15.1-utils
??? share
??? doc
?   ??? syncthing-1.15.1
?   ??? LICENSE
??? man
??? man1
?   ??? stdiscosrv.1.gz
?   ??? strelaysrv.1.gz
??? man5
?   ??? syncthing-config.5.gz
?   ??? syncthing-stignore.5.gz
??? man7
??? syncthing-bep.7.gz
??? syncthing-device-ids.7.gz
??? syncthing-event-api.7.gz
??? syncthing-faq.7.gz
??? syncthing-globaldisco.7.gz
??? syncthing-localdisco.7.gz
??? syncthing-networking.7.gz
??? syncthing-relay.7.gz
??? syncthing-rest-api.7.gz
??? syncthing-security.7.gz
??? syncthing-versioning.7.gz

7 directories, 16 files
------

----- End forwarded message -----
L
L
Leo Famulari wrote on 22 Aug 2021 20:42
Re: 02/02: gnu: syncthing: Prepare for cross-compiling.
(address . 50071@debbugs.gnu.org)
YSKao0b4lqWs4eFX@jasmine.lan
Quoting from Efraim on #guix:

"the go cross-build error I was seeing is this: go install: cannot install cross-compiled binaries when GOBIN is set"
L
L
Leo Famulari wrote on 22 Aug 2021 22:30
(address . 50071@debbugs.gnu.org)
YSKzy+aMKBqT1cZ7@jasmine.lan
On Sun, Aug 22, 2021 at 02:42:43PM -0400, Leo Famulari wrote:
Toggle quote (4 lines)
> Quoting from Efraim on #guix:
>
> "the go cross-build error I was seeing is this: go install: cannot install cross-compiled binaries when GOBIN is set"

Upstream gives instructions on how to cross-compile Syncthing:

------
`go run build.go build`

Builds just the named target, or syncthing by default, to the
current directory. Use this when cross compiling, with parameters
for what to cross compile to: go run build.go -goos linux -goarch
386 build.
------

?