* gnu/packages/web.scm (isso): New variable.
---
gnu/packages/web.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
Toggle diff (52 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 432ed3c445..cab0fa248e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5071,6 +5072,37 @@ using CSS selectors. Inspired by @command{jq}, @command{pup} aims to be a
fast and flexible way of exploring HTML from the terminal.")
(license license:expat))))
+(define-public isso
+ (package
+ (name "isso")
+ (version "0.12.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "isso" version))
+ (sha256
+ (base32 "148n8w1v5p26dbx4d3zij9qjj8bp59zsaf07r6cxmfxrpic6b9px"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:test-target "nosetests"))
+ (native-inputs
+ `(("python-flask" ,python-flask)
+ ("python-nose" ,python-nose)))
+ (inputs
+ `(("python-bleach" ,python-bleach)
+ ("python-flask-caching" ,python-flask-caching)
+ ("python-html5lib" ,python-html5lib)
+ ("python-itsdangerous" ,python-itsdangerous)
+ ("python-jinja2" ,python-jinja2)
+ ("python-misaka" ,python-misaka)
+ ("python-werkzeug" ,python-werkzeug)))
+ (home-page "https://github.com/posativ/isso/")
+ (synopsis "Lightweight commenting server")
+ (description "Isso – Ich schrei sonst – is a lightweight commenting server
+written in Python and JavaScript. It aims to be a drop-in replacement for
+Disqus.")
+ (license license:expat)))
+
(define-public uhttpmock
(package
(name "uhttpmock")
--
2.30.2