[PATCH 0/4] Add Isso.

  • Open
  • quality assurance status badge
Details
One participant
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 13 Aug 2021 01:55
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210812235530.26618-1-monego@posteo.net
Vinicius Monego (4):
gnu: python-bleach: Add dependency on python-packaging.
gnu: python-bleach: Enable tests.
gnu: Add python-flask-caching.
gnu: Add isso.

gnu/packages/python-web.scm | 31 +++++++++++++++++++++++++++++++
gnu/packages/python-xyz.scm | 13 +++++++++++--
gnu/packages/web.scm | 32 ++++++++++++++++++++++++++++++++
3 files changed, 74 insertions(+), 2 deletions(-)

--
2.30.2
V
V
Vinicius Monego wrote on 13 Aug 2021 01:58
[PATCH 1/4] gnu: python-bleach: Add dependency on python-packaging.
(address . 50033@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210812235807.26857-1-monego@posteo.net
* gnu/packages/python-xyz.scm (python-bleach)[propagated-inputs]: Add
python-packaging.
---
gnu/packages/python-xyz.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 295d158bd3..26fee98644 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11054,8 +11054,9 @@ Jupyter Notebook format and Python APIs for working with notebooks.")
(base32 "0jqa8f1ni10cyf4h7sjpf8mbqlcbkyvmsnli77qrxdcxvc7m4k1w"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-webencodings" ,python-webencodings)
- ("python-six" ,python-six)))
+ `(("python-packaging" ,python-packaging)
+ ("python-six" ,python-six)
+ ("python-webencodings" ,python-webencodings)))
(native-inputs
`(("python-datrie" ,python-datrie)
("python-genshi" ,python-genshi)
--
2.30.2
V
V
Vinicius Monego wrote on 13 Aug 2021 01:58
[PATCH 2/4] gnu: python-bleach: Enable tests.
(address . 50033@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210812235807.26857-2-monego@posteo.net
* gnu/packages/python-xyz.scm (python-bleach)[arguments]: Override 'check
phase.
---
gnu/packages/python-xyz.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 26fee98644..edfc945369 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11053,6 +11053,14 @@ Jupyter Notebook format and Python APIs for working with notebooks.")
(sha256
(base32 "0jqa8f1ni10cyf4h7sjpf8mbqlcbkyvmsnli77qrxdcxvc7m4k1w"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest")))))))
(propagated-inputs
`(("python-packaging" ,python-packaging)
("python-six" ,python-six)
--
2.30.2
V
V
Vinicius Monego wrote on 13 Aug 2021 01:58
[PATCH 3/4] gnu: Add python-flask-caching.
(address . 50033@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210812235807.26857-3-monego@posteo.net
* gnu/packages/python-web.scm (python-flask-caching): New variable.
---
gnu/packages/python-web.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5df134ddff..36e1bf7541 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1018,6 +1018,37 @@ support for Flask. This is based on the Python babel module as well as pytz -
both of which are installed automatically if you install this library.")
(license license:bsd-3)))
+(define-public python-flask-caching
+ (package
+ (name "python-flask-caching")
+ (version "1.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Flask-Caching" version))
+ (sha256
+ (base32 "000wl24ig22yzvx3dkl3yv5z0lzd6asmaz5fwh1vmhpbzhibf6fg"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest" "-k"
+ "not test_init_nullcache")))))))
+ (native-inputs
+ `(("python-flask" ,python-flask)
+ ("python-memcached" ,python-memcached)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (home-page "https://github.com/sh4nks/flask-caching")
+ (synopsis "Caching extension for Flask")
+ (description "This package adds caching support to Flask. It is a fork of
+the Flask-Cache extension.")
+ (license license:bsd-3)))
+
(define-public python-flask-cors
(package
(name "python-flask-cors")
--
2.30.2
V
V
Vinicius Monego wrote on 13 Aug 2021 01:58
[PATCH 4/4] gnu: Add isso.
(address . 50033@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210812235807.26857-4-monego@posteo.net
* gnu/packages/web.scm (isso): New variable.
---
gnu/packages/web.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 432ed3c445..cab0fa248e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5071,6 +5072,37 @@ using CSS selectors. Inspired by @command{jq}, @command{pup} aims to be a
fast and flexible way of exploring HTML from the terminal.")
(license license:expat))))
+(define-public isso
+ (package
+ (name "isso")
+ (version "0.12.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "isso" version))
+ (sha256
+ (base32 "148n8w1v5p26dbx4d3zij9qjj8bp59zsaf07r6cxmfxrpic6b9px"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:test-target "nosetests"))
+ (native-inputs
+ `(("python-flask" ,python-flask)
+ ("python-nose" ,python-nose)))
+ (inputs
+ `(("python-bleach" ,python-bleach)
+ ("python-flask-caching" ,python-flask-caching)
+ ("python-html5lib" ,python-html5lib)
+ ("python-itsdangerous" ,python-itsdangerous)
+ ("python-jinja2" ,python-jinja2)
+ ("python-misaka" ,python-misaka)
+ ("python-werkzeug" ,python-werkzeug)))
+ (home-page "https://github.com/posativ/isso/")
+ (synopsis "Lightweight commenting server")
+ (description "Isso – Ich schrei sonst – is a lightweight commenting server
+written in Python and JavaScript. It aims to be a drop-in replacement for
+Disqus.")
+ (license license:expat)))
+
(define-public uhttpmock
(package
(name "uhttpmock")
--
2.30.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 50033@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50033
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch