(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
* gnu/packages/terminals.scm (shell-color-scripts): New variable.
Toggle diff (57 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 9377e5622b..c2028956fd 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,6 +46,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system cargo)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system go)
@@ -766,6 +768,36 @@ It's a terminal emulator with few dependencies, so you don't need a full GNOME
desktop installed to have a decent terminal emulator.")
(license license:gpl2)))
+(define-public shell-color-scripts
+ (package
+ (name "colorscript")
+ (version "3dbdfac24bb629238fdc3e1c8909e2c8577f8735") ; no tags
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/dwt1/shell-color-scripts")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0lkiz6fkrqryr1vh0lh067q7hp8ba8887pkk8caipqphjswp2z16"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("colorscript.sh" "bin/colorscript.sh")
+ ("colorscripts" "colorscripts"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-colorscipts-location
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "colorscript.sh"
+ (("/opt/shell-color-scripts/colorscripts")
+ (string-append (assoc-ref outputs "out") "/colorscripts"))))))))
+ (inputs `(("ncurses" ,ncurses)))
+ (synopsis "Collection of terminal color scripts")
+ (description "Collection of terminal color scripts")
+ (home-page "https://gitlab.com/dwt1/shell-color-scripts")
+ (license license:expat))) ; MIT
+
(define-public go-github.com-nsf-termbox-go
(let ((commit "288510b9734e30e7966ec2f22b87c5f8e67345e3")
(revision "1"))
--
2.32.0