(address . guix-patches@gnu.org)
---
gnu/packages/networking.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
Toggle diff (53 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 05fd092b23..0ea07f0f15 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -44,6 +44,7 @@
;;; Copyright � 2021 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright � 2021 Justin Veilleux <terramorpha@cock.li>
;;; Copyright � 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright � 2021 cage <cage-dev@twistfold.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4177,3 +4178,38 @@ public key authentication and Kerberos single-sign-on. It also includes
command-line @acronym{SFTP} and @acronym{SCP} implementations.")
(home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
(license license:expat)))
+
+(define-public gmid
+ (package
+ (name "gmid")
+ (version "1.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/omar-polo/gmid/releases/download/"
+ version "/gmid-" version ".tar.gz"))
+ (sha256
+ (base32 "0ag5zcwnr5vmy13bc9c36hnv9pflks68b0k6w0ng97inrm37klis"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ ;; The configure script is hand-written, not from GNU autotools.
+ (lambda* (#:key configure-flags inputs outputs #:allow-other-keys)
+ (let ((prefix (string-append "PREFIX=" (assoc-ref outputs "out"))))
+ (setenv "CC" ,(cc-for-target))
+ (apply invoke "./configure" (list prefix))
+ #t))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("bison" ,bison)
+ ("flex" ,flex)))
+ (inputs
+ `(("libevent" ,libevent)
+ ("libressl" ,libressl)))
+ (home-page "https://git.omarpolo.com/gmid/about/")
+ (synopsis "Simple and secure Gemini server")
+ (description "Gmid is a fast Gemini server written with security in mind.")
+ (license license:x11)))
--
2.32.0