(address . guix-patches@gnu.org)
Hi,
this patchset adds AMD’s ROCm OpenCL runtime for their GPU’s. It works
fine with Linux’ standard kernel module (no need to package ROCk), but
only if firmware has been loaded. The userspace software itself is
completely free though.
The final patch adjusts one consumer of ROCm OpenCL, darktable, so both
actually work together. Try it yourself with (obviously needs an AMD
GPU):
guix environment --ad-hoc darktable ocl-icd rocm-opencl-runtime -- darktable-cltest
Lars-Dominik Braun (11):
gnu: Add rocm-cmake.
gnu: Add llvm-for-rocm.
gnu: Add rocm-device-libs.
gnu: Add rocm-comgr.
gnu: Add roct-thunk-interface.
gnu: Add rocr-runtime.
gnu: Add rocclr.
gnu: Add rocm-opencl-runtime.
gnu: Add rocminfo.
gnu: Add rocm-bandwidth-test.
gnu: darktable: Add compatibility for ROCm.
gnu/local.mk | 8 +
.../llvm-roc-3.0.0-add_libraries.patch | 22 ++
...roc-4.0.0-remove-isystem-usr-include.patch | 29 ++
.../patches/llvm-roc-4.2.0-add_Object.patch | 13 +
.../rocm-comgr-3.1.0-dependencies.patch | 52 +++
....10.0-add-rocclr-include-directories.patch | 14 +
.../rocm-opencl-runtime-4.3-noclinfo.patch | 28 ++
.../rocm-opencl-runtime-4.3-nocltrace.patch | 25 ++
.../rocm-opencl-runtime-4.3-noopencl.patch | 63 ++++
gnu/packages/photo.scm | 24 +-
gnu/packages/rocm.scm | 355 ++++++++++++++++++
11 files changed, 628 insertions(+), 5 deletions(-)
create mode 100644 gnu/packages/patches/llvm-roc-3.0.0-add_libraries.patch
create mode 100644 gnu/packages/patches/llvm-roc-4.0.0-remove-isystem-usr-include.patch
create mode 100644 gnu/packages/patches/llvm-roc-4.2.0-add_Object.patch
create mode 100644 gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch
create mode 100644 gnu/packages/patches/rocm-opencl-runtime-3.10.0-add-rocclr-include-directories.patch
create mode 100644 gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch
create mode 100644 gnu/packages/patches/rocm-opencl-runtime-4.3-nocltrace.patch
create mode 100644 gnu/packages/patches/rocm-opencl-runtime-4.3-noopencl.patch
create mode 100644 gnu/packages/rocm.scm
--
2.31.1