[PATCH] gnu: wine: Update to 6.14.

  • Done
  • quality assurance status badge
Details
One participant
  • Leo Prikler
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 4 years ago
(address . guix-patches@gnu.org)
20210805191005.20997-1-leo.prikler@student.tugraz.at
* gnu/packages/wine.scm (wine): Update to 6.14.
[#:phases]: Patch Makefile to correctly locate ntdll.so.
(wine64)[#:phases]: Likewise.
---
gnu/packages/wine.scm | 24 +++++++++++++++++++++---
1 file changed, 21 insertions(+), 3 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 5c6d02eec5..fccdc186d2 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -75,7 +75,7 @@
(define-public wine
(package
(name "wine")
- (version "6.8")
+ (version "6.14")
(source
(origin
(method url-fetch)
@@ -87,7 +87,7 @@
(string-append "https://dl.winehq.org/wine/source/" dir
"wine-" version ".tar.xz")))
(sha256
- (base32 "1n7bd6kkhfgi23bz981qml3lajgvbs3ibqrc2mqjhhfqczg2shjv"))))
+ (base32 "00jjqbl0xzsp2swzxgx3a2b16p26qbxvcz82a7ihig23k69p3d34"))))
(build-system gnu-build-system)
(native-inputs
`(("bison" ,bison)
@@ -194,7 +194,16 @@
(substitute* "include/config.h"
(("(#define SONAME_.* )\"(.*)\"" _ defso soname)
(format #f "~a\"~a\"" defso (find-so soname))))
- #t))))))
+ #t)))
+ (add-after 'patch-generated-file-shebangs 'patch-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "make" "Makefile") ; Makefile is first regenerated
+ (substitute* "Makefile"
+ (("-lntdll" id)
+ (string-append id
+ " -Wl,-rpath=" (assoc-ref outputs "out")
+ "/lib/wine32/wine/$(ARCH)-unix")))
+ #t)))))
(home-page "https://www.winehq.org/")
(synopsis "Implementation of the Windows API (32-bit only)")
(description
@@ -254,6 +263,15 @@ integrate Windows applications into your desktop.")
#t)))))
(_
`()))
+ (add-after 'patch-generated-file-shebangs 'patch-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "make" "Makefile") ; Makefile is first regenerated
+ (substitute* "Makefile"
+ (("-lntdll" id)
+ (string-append id
+ " -Wl,-rpath=" (assoc-ref outputs "out")
+ "/lib/wine64/wine/$(ARCH)-unix")))
+ #t))
(add-after 'install 'copy-wine32-binaries
(lambda* (#:key outputs #:allow-other-keys)
(let* ((wine32 (assoc-ref %build-inputs "wine"))
--
2.32.0
Leo Prikler wrote 4 years ago
(address . 49900-done@debbugs.gnu.org)
856d5b47d3624ad8ada79f3a423f6dc58eb3f28b.camel@student.tugraz.at
Done and updated to 6.16.

If you received this twice, pardon the resend.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49900@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49900
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help