[PATCH] gnu: Add chicken-matchable.

  • Open
  • quality assurance status badge
Details
One participant
  • Xinglu Chen
Owner
unassigned
Submitted by
Xinglu Chen
Severity
normal
X
X
Xinglu Chen wrote on 5 Aug 2021 17:16
(address . guix-patches@gnu.org)
b5548b77a6ad6e0b70f3924037ec3d9e7dd78de9.1628176534.git.public@yoctocell.xyz
* gnu/packages/chicken.scm (chicken-matchable): New variable.
---
gnu/packages/chicken.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index 866ba8a062..b652eb9723 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2020 Evan Hanson <evhan@foldling.org>
;;; Copyright © 2020 raingloom <raingloom@riseup.net>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -281,3 +282,25 @@ with integers.")
"This package provides a simple testing utility for CHICKEN Scheme.")
(license license:bsd-3)))
+
+(define-public chicken-matchable
+ (package
+ (name "chicken-matchable")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://code.call-cc.org/egg-tarballs/5/matchable/matchable-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0bizkac4a926lbk0v2m05ysq359mzhfsqh973m72jc4gcj4azr5p"))))
+ (build-system chicken-build-system)
+ (arguments `(#:egg-name "matchable"))
+ (native-inputs `(("chicken-test" ,chicken-test)))
+ (home-page "https://wiki.call-cc.org/egg/matchable")
+ (synopsis "Hygienic MATCH replacement")
+ (description "This package implements Andrew Wright's pattern matching
+macros in CHICKEN.")
+ (license license:public-domain)))

base-commit: ead6cc03c66ed31f0ab7300fab11cef3a1e459f0
--
2.32.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 49892@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49892
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch