(address . guix-patches@gnu.org)(name . Thiago Jung Bauermann)(address . bauermann@kolabnow.com)
The current GMP version is incompatible with MPFR 2.4 (which was released
in 2009) and causes the build of ‘mpfr-boot’ to fail.
Fix the problem by using ‘gmp-boot’, which is from early 2010.
* gnu/packages/commencement.scm (mpfr-boot)[propagated-inputs]: Add
gmp-boot.
---
Hello,
This is a problem affecting both master and core-updates-frozen, so
I suggest committing this patch to master. It applies cleanly on both
branches.
It also affects at least the i686-linux, x86_64-linux and powerpc64-linux
architectures.
For reference, there’s a ton of error messages during build but these
are the first ones:
In file included from mpfr-impl.h:81:0,
from add1.c:23:
mpfr.h:141:9: error: unknown type name ‘__gmp_const’
typedef __gmp_const __mpfr_struct *mpfr_srcptr;
^~~~~~~~~~~
In file included from mpfr-impl.h:81:0,
from add.c:23:
mpfr.h:141:9: error: unknown type name ‘__gmp_const’
typedef __gmp_const __mpfr_struct *mpfr_srcptr;
^~~~~~~~~~~
mpfr.h:141:35: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’
before ‘*’ token
typedef __gmp_const __mpfr_struct *mpfr_srcptr;
^
mpfr.h:204:29: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’
before ‘char’
__MPFR_DECLSPEC __gmp_const char * mpfr_get_version _MPFR_PROTO
((void));
^~~~
mpfr.h:205:29: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’
before ‘char’
__MPFR_DECLSPEC __gmp_const char * mpfr_get_patches _MPFR_PROTO
((void));
^~~~
Thanks,
Thiago
gnu/packages/commencement.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Toggle diff (14 lines)
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 16eb46d44d77..f8973392262f 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1869,7 +1869,8 @@ ac_cv_c_float_format='IEEE (little-endian)'
(uri (string-append "mirror://gnu/mpfr/mpfr-" version
".tar.gz"))
(sha256 (base32
- "0dxn4904dra50xa22hi047lj8kkpr41d6vb9sd4grca880c7wv94"))))))
+ "0dxn4904dra50xa22hi047lj8kkpr41d6vb9sd4grca880c7wv94"))))
+ (propagated-inputs `(("gmp" ,gmp-boot))))) ; <mpfr.h> refers to <gmp.h>
(define mpc-boot
(package