[PATCH] gnu: graphviz-2.38: Fix build failure.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxime Devos
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Maxime Devos
Severity
normal
M
M
Maxime Devos wrote on 28 Jul 2021 23:32
(address . guix-patches@gnu.org)(name . Maxime Devos)(address . maximedevos@telenet.be)
20210728213223.31250-1-maximedevos@telenet.be
* gnu/packages/graphviz.scm
(graphviz-2.38)[arguments]<#:phases>: Make this a G-exp.
---
gnu/packages/graphviz.scm | 24 ++++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 43eaecace4..eaddfb29c4 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -150,19 +150,19 @@ interfaces for other technical domains.")
(arguments
(substitute-keyword-arguments (package-arguments graphviz)
((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'prepare-bootstrap
- (lambda _
- (substitute* "autogen.sh"
- (("/bin/sh") (which "sh"))
- (("\\$GRAPHVIZ_VERSION_DATE") "0"))
- (setenv "CONFIG_SHELL" (which "sh"))
- (setenv "SHELL" (which "sh"))
+ #~(modify-phases #$phases
+ (add-after 'unpack 'prepare-bootstrap
+ (lambda _
+ (substitute* "autogen.sh"
+ (("/bin/sh") (which "sh"))
+ (("\\$GRAPHVIZ_VERSION_DATE") "0"))
+ (setenv "CONFIG_SHELL" (which "sh"))
+ (setenv "SHELL" (which "sh"))
- (map make-file-writable (find-files "." ".*"))
- #t))
- (replace 'bootstrap
- (lambda _ (invoke (which "sh") "autogen.sh" "NOCONFIG") #t))))))
+ (map make-file-writable (find-files "." ".*"))
+ #t))
+ (replace 'bootstrap
+ (lambda _ (invoke (which "sh") "autogen.sh" "NOCONFIG") #t))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
--
2.32.0
M
M
Maxime Devos wrote on 28 Jul 2021 23:36
(address . 49762@debbugs.gnu.org)
6d62558438bd5775178cbbb202138026db4e74c0.camel@telenet.be
Maxime Devos schreef op wo 28-07-2021 om 23:32 [+0200]:
Toggle quote (3 lines)
> * gnu/packages/graphviz.scm
> (graphviz-2.38)[arguments]<#:phases>: Make this a G-exp.

I forgot to mention this is for core-updates(-frozen?).
The subject should have been
[PATCH core-updates] gnu: graphviz-2.38: Fix build failure.
(or [PATCH core-updates-frozen] gnu: graphviz-2.38: Fix build failure.?).

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYQHNyRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7v39AQCrPm3smLgp4pAnC2PXKgXk+hWe
12pKYnOEs8cRwra64AEAoj3tK/+x551tR/kO6v4cL9fS8AonGnFObcSlNZgWigE=
=E/nE
-----END PGP SIGNATURE-----


M
M
Mathieu Othacehe wrote on 29 Jul 2021 09:34
Re: bug#49762: [PATCH] gnu: graphviz-2.38: Fix build failure.
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 49762-done@debbugs.gnu.org)
87tukdinds.fsf@gnu.org
Hey,

Toggle quote (3 lines)
> * gnu/packages/graphviz.scm
> (graphviz-2.38)[arguments]<#:phases>: Make this a G-exp.

Pushed to core-updates & core-updates-frozen.

Thanks,

Mathieu
Closed
?