[PATCH v2] gnu: Add python-date2name.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sarah Morgensen
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
Merged with
P
P
phodina wrote on 25 Jul 2021 21:04
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
pw3tQ87hFYJv5UWNM2V5SgNGIOgh_roBAodSt0ekDj-YJwvlQBDAQ7FbsZyAiIy8ZMyd1iNo2UtOws-Oeweo4pbvQmPvUSjb7lAbrKAsbTk=@protonmail.com
* gnu/packages/python-check.scm (date2name): New variable.
---
Toggle diff (53 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 2a4f50ad46..c5b50da774 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -905,6 +906,40 @@ for the @code{pytest} framework.")
rounds that are calibrated to the chosen timer.")
(license license:bsd-2)))

+
+(define-public python-date2name
+(package
+ (name "pyton-date2name")
+ (version "6c8f37277e8ec82aa50f90b8921422be30c4e798") ; no tags
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/novoid/date2name")
+ (commit version)))
+ (sha256
+ (base32
+ "1vq96b7n16d932nyfhnzwdwxff0zrqanidmwr4cxj2p67ad9y3w7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((bindir (string-append (assoc-ref outputs "out") "/bin"))
+ (binary (string-append bindir "/date2name")))
+ (mkdir-p bindir)
+ (copy-file "date2name/__init__.py" binary)
+ (chmod binary #o555)))))))
+ (synopsis "Handling time-stamps and date-stamps in file names")
+ (description "Per default, date2name gets the modification time of matching
+files and directories and adds a datestamp in standard ISO 8601+ format
+YYYY-MM-DD (http://datestamps.org/index.shtml) at the beginning of the file-
+or directoryname.")
+ (home-page "https://github.com/novoid/date2name")
+ (license license:gpl3)))
+
(define-public python-pytest-xvfb
(package
(name "python-pytest-xvfb")
--
2.31.1
S
S
Sarah Morgensen wrote on 25 Jul 2021 22:42
control message for bug #49575
(address . control@debbugs.gnu.org)
E1m7kwr-0006kV-1J@debbugs.gnu.org
merge 49575 49735
quit
?