[PATCH] gnu: Add gmic-qt-gimp.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ivan Gankevich
  • Leo Famulari
  • Vinicius Monego
Owner
unassigned
Submitted by
Ivan Gankevich
Severity
normal
I
I
Ivan Gankevich wrote on 24 Jul 2021 10:51
(address . guix-patches@gnu.org)(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)
20210724085155.21417-1-i.gankevich@spbu.ru
* gnu/packages/image-processing.scm (gmic-qt-gimp): New variable.
---
gnu/packages/image-processing.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index df77bef192..399ee55c87 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
+;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -56,6 +57,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages geo)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages gimp)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -801,6 +803,25 @@ including 2D color images.")
(assoc-ref %build-inputs "gmic") "/lib")))))
(synopsis "Krita plugin for the G'MIC image processing framework")))
+(define-public gmic-qt-gimp
+ (package
+ (inherit gmic-qt)
+ (name "gmic-qt-gimp")
+ (inputs
+ ;; GIMP and its dependencies.
+ `(("gimp" ,gimp)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("cairo" ,cairo)
+ ("gegl" ,gegl)
+ ,@(package-inputs gmic-qt)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments gmic-qt)
+ ((#:configure-flags flags)
+ '(list "-DGMIC_QT_HOST=gimp" "-DENABLE_DYNAMIC_LINKING=ON"
+ (string-append "-DGMIC_LIB_PATH="
+ (assoc-ref %build-inputs "gmic") "/lib")))))
+ (synopsis "GIMP plugin for the G'MIC image processing framework")))
+
(define-public nip2
(package
(name "nip2")
--
2.32.0
V
V
Vinicius Monego wrote on 22 Oct 2021 16:14
(address . 49715@debbugs.gnu.org)(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)
50ae7ea8f8252e1b9b57c7bf31ab4cd78718f1af.camel@posteo.net
Hi,

Toggle quote (2 lines)
> * gnu/packages/image-processing.scm (gmic-qt-gimp): New variable.

I built and tested this patch and can confirm it works. A few nitpicks
that I have:

Toggle quote (8 lines)
> + (inputs
> + ;; GIMP and its dependencies.
> + `(("gimp" ,gimp)
> + ("gdk-pixbuf" ,gdk-pixbuf)
> + ("cairo" ,cairo)
> + ("gegl" ,gegl)
> + ,@(package-inputs gmic-qt)))

Should be one space below inputs. Also the labeled inputs should be
sorted alphabetically. See the gmic-qt package for instance.

Toggle quote (8 lines)
> + (arguments
> + (substitute-keyword-arguments (package-arguments gmic-qt)
> + ((#:configure-flags flags)
> + '(list "-DGMIC_QT_HOST=gimp" "-DENABLE_DYNAMIC_LINKING=ON"
> + (string-append "-DGMIC_LIB_PATH="
> + (assoc-ref %build-inputs "gmic")
> "/lib")))))

Should be one space below arguments (see gmic-qt-krita for instance).

If you're using Emacs, the indentation should be fixed automatically
with M-x indent-sexp or indent-region.

Vinicius
L
L
Leo Famulari wrote on 22 Oct 2021 22:32
(name . Vinicius Monego)(address . monego@posteo.net)
YXMfzdrHNKiKGpSK@jasmine.lan
On Fri, Oct 22, 2021 at 02:14:15PM +0000, Vinicius Monego wrote:
Toggle quote (31 lines)
> Hi,
>
> > * gnu/packages/image-processing.scm (gmic-qt-gimp): New variable.
>
> I built and tested this patch and can confirm it works. A few nitpicks
> that I have:
>
> > + (inputs
> > + ;; GIMP and its dependencies.
> > + `(("gimp" ,gimp)
> > + ("gdk-pixbuf" ,gdk-pixbuf)
> > + ("cairo" ,cairo)
> > + ("gegl" ,gegl)
> > + ,@(package-inputs gmic-qt)))
>
> Should be one space below inputs. Also the labeled inputs should be
> sorted alphabetically. See the gmic-qt package for instance.
>
> > + (arguments
> > + (substitute-keyword-arguments (package-arguments gmic-qt)
> > + ((#:configure-flags flags)
> > + '(list "-DGMIC_QT_HOST=gimp" "-DENABLE_DYNAMIC_LINKING=ON"
> > + (string-append "-DGMIC_LIB_PATH="
> > + (assoc-ref %build-inputs "gmic")
> > "/lib")))))
>
> Should be one space below arguments (see gmic-qt-krita for instance).
>
> If you're using Emacs, the indentation should be fixed automatically
> with M-x indent-sexp or indent-region.

Thanks for the patch and the review, everybody!

I made the requested changes and pushed as
41492639e0223dc8fc1a357e1f9537577c055db7
Closed
?