[PATCH] gnu: Add rust-rot8

  • Open
  • quality assurance status badge
Details
2 participants
  • phodina
  • Xinglu Chen
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 23 Jul 2021 05:27
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
JXhdJVbh6eBC7z3b4DRh2h2DMYc_8Jhksy1n9ewZoQhvAWXb7cadH5kzmIYMfdF0uIXzrEDYXS7xD-u2DcDNIfZ9B6nmdy0wYqhx2jDgsgw=@protonmail.com
---
Toggle diff (48 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a6a383156d..07b1de05df 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Antero Mejr <antero@kodmin.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37525,6 +37526,35 @@ text-buffer for applications such as text editors. Ropey is fast, robust, and
can handle huge texts and memory-incoherent edits with ease.")
(license license:expat)))

+(define-public rust-rot8-0.1
+ (package
+ (name "rust-rot8")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rot8" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15mhszk9qy2q49dpab4p0d9d4aph61yshaxjf02mhdx07n9qpnmh"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-clap" ,rust-clap-2)
+ ("rust-glob" ,rust-glob-0.3)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1))))
+ (home-page "https://github.com/efernau/rot8")
+ (synopsis
+ "A screen rotation daemon")
+ (description
+ "Automatic rotation for modern Linux screen and input device. Compatible
+with wayland and X11. Uses built-in accelerometer with configurable threshold.")
+ (license license:expat)))
+
(define-public rust-route-recognizer-0.2
(package
(name "rust-route-recognizer")
--
2.31.1
X
X
Xinglu Chen wrote on 24 Jul 2021 15:19
87k0lf3l3c.fsf@yoctocell.xyz
On Fri, Jul 23 2021, phodina via Guix-patches via wrote:

Toggle quote (2 lines)
> ---

Please write a proper commit message in the GNU ChangeLog format; you
can see the commit log for examples, or read the manual.


Toggle quote (25 lines)
> +(define-public rust-rot8-0.1
> + (package
> + (name "rust-rot8")
> + (version "0.1.3")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (crate-uri "rot8" version))
> + (file-name
> + (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "15mhszk9qy2q49dpab4p0d9d4aph61yshaxjf02mhdx07n9qpnmh"))))
> + (build-system cargo-build-system)
> + (arguments
> + `(#:cargo-inputs
> + (("rust-clap" ,rust-clap-2)
> + ("rust-glob" ,rust-glob-0.3)
> + ("rust-regex" ,rust-regex-1)
> + ("rust-serde" ,rust-serde-1)
> + ("rust-serde-json" ,rust-serde-json-1))))
> + (home-page "https://github.com/efernau/rot8")
> + (synopsis
> + "A screen rotation daemon")

Avoid articles like “A” or “An” in the synopsis.

Toggle quote (3 lines)
> + (description
> + "Automatic rotation for modern Linux screen and input device. Compatible

The description should consist of full sentences, and there should be
two spaces after periods. See the “16.4.4 Synopses and Descriptions” in
the manual for more details. Make sure to run ‘guix lint’ to catch
common mistakes like these. :)

Otherwise, LGTM.
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmD8E3cVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x56lMP/jFchh7m3OyPc2ERin0bYO69zn62
d7AjnWusM0t78rHIlZlYo/fAlHTDspoDzpSY/XjUaqT0yC8Eju+C602a1pQwvxCO
ie9CvkcXm0SELmT3NZ4ZGwAQ+kDBeasA5yn8ndGO7iuMfgIgTXiXyDTLBrQ38uZz
5uL00UlqPvb09hQuRuYGjPODIIugrr+cRtDK+Qip163G30gb+E6xRcVCj7IwsVMT
w7md4lBwOMvL6J6O24BkEBkTLrwCWQPFQg51OISCO6Tt6ACNtEb4fOxfR3f93UfG
lQZuEH8TOIG2+SoU9SSJ2qZVAgVSRzO1gn5dOkYDEHzafZvpDlPKWjVou9DJ25nw
XIx/I0o113ZLLwqgvgf5AlRdCS9Ris8xzZiGlOeM1XBuxMoHguNT0wc96JZxjbae
05Pxo1cVjGu+xrvjKJpdb/10ksFEFYEKes11G+Tb+1m/oGb/NyeeHWp4d3JuUDKV
o88Q+g3/abBb+Y+qMJCdEpm6CDo7sa+49rdbUavdrprkDKajBiIdJ8XD1EB0jApP
5g/qgWrHgC1Gh+HoQ/gWe1UQ1WEwlslhtqCLLl6y+87BsGCFuUDgCaeh3L/3evuR
qWq1eHel9E2s6HHRrd4PQoHGi8cDrBMRnqvNgzqbNDD9wEf3HWAGKu6P2AQspumM
7MCqcgghl+DKzjxp
=vId5
-----END PGP SIGNATURE-----

P
P
phodina wrote on 25 Jul 2021 20:44
Re: [bug#49703][PATCH v2] gnu: Add rust-rot8-0.1.
(address . 49703@debbugs.gnu.org)(name . Xinglu Chen)(address . public@yoctocell.xyz)
Ir9JtPABWU0XRM45Q-qtf4bVKPK8v6rRihWDYdCz4twyFxRMsTeItk5YYpOpVhMrG0OfX91RYpIIel-aab_mh0cd8FIZF0kspKnwPZ9ncZQ=@protonmail.com
* gnu/packages/crates-io.scm (rust-rot8-0.1): New variable.
---

Toggle diff (48 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a6a383156d..8a2e0e9e84 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Antero Mejr <antero@kodmin.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37525,6 +37526,35 @@ text-buffer for applications such as text editors. Ropey is fast, robust, and
can handle huge texts and memory-incoherent edits with ease.")
(license license:expat)))

+(define-public rust-rot8-0.1
+ (package
+ (name "rust-rot8")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rot8" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15mhszk9qy2q49dpab4p0d9d4aph61yshaxjf02mhdx07n9qpnmh"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-clap" ,rust-clap-2)
+ ("rust-glob" ,rust-glob-0.3)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1))))
+ (home-page "https://github.com/efernau/rot8")
+ (synopsis
+ "Screen rotation daemon")
+ (description
+ "Automatic rotation for modern Linux screen and input device. Compatible
+with wayland and X11. Uses built-in accelerometer with configurable threshold.")
+ (license license:expat)))
+
(define-public rust-route-recognizer-0.2
(package
(name "rust-route-recognizer")
--
2.31.1
P
P
phodina wrote on 18 Sep 2021 10:02
(address . 49703@debbugs.gnu.org)(name . Xinglu Chen)(address . public@yoctocell.xyz)
D-W8ZL_MP0FSfu5SnOk4qULwmSnwUTY1ayA_lZvRtUTogGhmLlNBRE1F60kxDVF0iipoP0fnsZFprGlK1f_vAT3paxAoV8cx7pSQ3T0d9Is=@protonmail.com
Hi Xinglu,

anything else to be fixed to upstream this patch?

Petr
X
X
Xinglu Chen wrote on 20 Sep 2021 14:03
875yuvh2t0.fsf@yoctocell.xyz
On Sat, Sep 18 2021, phodina wrote:

Toggle quote (4 lines)
> Hi Xinglu,
>
> anything else to be fixed to upstream this patch?

Sorry for taking so long to reply! The patch looks good, except that
the description should consist of full sentences (the first sentence
doesn’t have a subject), something like:

This Rust library implements automatic rotation for modern Linux
screen and input device. Compatible with wayland and X11. Uses
built-in accelerometer with configurable threshold.

The person who commits the patch (I don’t have commit access) can
probably adjust the description for you, so you don’t have to send a
reroll just for this small change. :-)
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmFIeIsVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5h8kQAIn3tVRSkFPmeH4G0vxLGnbasru3
tjTy0wZYkXR7p7QFzhroN3TE2okjiAkeCQ6cn1i3POMi4vo3wkX8XJaVrLepbTJ5
15d7u21rHYNdykhbAcSlUkE3QURHj3ELBfHH5DzS4XK2XTkHiW7n5z9XeWpisijH
Sc2UkaniiBRGs8Qv9UfSDHbBk7KLlSsA3N7fkgZXaQqoFkDq6DLes9PbX/1bqSZn
8ZdYKI+0wwPgYhBSyr1y7WmnO+GB6o/zF5Ps+L1I6KedGR4uLC31fukFL6YDPJLP
C6BNfhY8BN1mYVq/eolniNEyJnC7pP+qNnD/49UPolPkE07Z8jQm8BoT2xjzd8RI
Ir04iZm2xsK6cd2uFN9BtiW2i0NBCPNzNUzYU+kPUFVZyV5/Hso/23Yu6gOxm/Sc
mvNjNyJ3fterhVlNAJCtTY8Y3WrkmmD3maEtJBeWhy1sO48lajuqr11sNQsNjuzV
znK5k3BrJQBS2tbJDevztyn2Ok7ar42S9SHV3O0yaFsjBmsYIQxOmQXkcLIRrAKv
h7Yd79DEJ9nZWFrKsTlYpNxqXxOTHPawFZJxOZJRPuyCKfLGv0W5UfrcrmwqKZc5
dvpMApLrsxZ8Gu8df7mM5T00Mho4ZlIykVTtu9NQnXTRu4iCbfjr9XIO3r0n7GS+
ST0CGsAq5t0P3Emp
=e8vB
-----END PGP SIGNATURE-----

P
P
phodina wrote on 20 Sep 2021 17:20
(name . Xinglu Chen)(address . public@yoctocell.xyz)(address . 49703@debbugs.gnu.org)
jAaO0JPhtVmB5vkD49QX9D-a7aPYvP1e1elxPJEZZM9ydLhGOVd0d3RcoPrHnNqxjuw3bYxORwn-4kqdJRRclBALXTsXu_pPqdCAYJR59EQ=@protonmail.com
On Monday, September 20th, 2021 at 2:03 PM, Xinglu Chen <public@yoctocell.xyz> wrote:

Toggle quote (24 lines)
> On Sat, Sep 18 2021, phodina wrote:
>
> > Hi Xinglu,
> >
> > anything else to be fixed to upstream this patch?
>
> Sorry for taking so long to reply! The patch looks good, except that
>
> the description should consist of full sentences (the first sentence
>
> doesn’t have a subject), something like:
>
> This Rust library implements automatic rotation for modern Linux
>
> screen and input device. Compatible with wayland and X11. Uses
>
> built-in accelerometer with configurable threshold.
>
> The person who commits the patch (I don’t have commit access) can
>
> probably adjust the description for you, so you don’t have to send a
>
> reroll just for this small change. :-)

Thanks! I've looked into the [1] so I hope to write better synopses and description according to the guidelines.

Thanks for your patience and help!

Regards
Petr

?