Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
From: Morgan Smith <Morgan.J.Smith@outlook.com>
Move the dictionary directory to be next to the lisp files, where it is
expected to be.
* gnu/packages/emacs-xyz.scm (emacs-typit)[arguments]
<#:phases>: Remove install-dictionaries phase.
<#:include>: Include dictionaries.
---
gnu/packages/emacs-xyz.scm | 12 +-----------
1 file changed, 1 insertion(+), 11 deletions(-)
Toggle diff (25 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5fe1c20976..f611277be2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1217,17 +1217,7 @@ handful of functions that are not resource-specific.")
(base32 "1savrxs7xl92ifyxpxkkzv2didr7lb405h0dwz1bs1wldr5fb53f"))))
(build-system emacs-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-dictionaries
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (site-lisp
- (string-append
- out "/share/emacs/site-lisp/dict")))
- (mkdir-p site-lisp)
- (copy-recursively "dict" site-lisp)
- #t))))))
+ '(#:include (cons "^dict/" %default-include)))
(propagated-inputs
`(("emacs-f" ,emacs-f)
("emacs-mmt" ,emacs-mmt)))
--
2.32.0