[PATCH] z80asm and z80dasm

  • Open
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Thomas Albers
Owner
unassigned
Submitted by
Thomas Albers
Severity
normal

Debbugs page

Thomas Albers wrote 4 years ago
(address . guix-patches@gnu.org)
87v956mrzv.fsf@thomaslabs.org
Toggle diff (63 lines)
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 51c0572674..5bf1a1c98a 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
+;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -533,3 +534,50 @@ family of command line utility wrappers in the default output. Each of the cli
tools is named like @code{xed*}. Documentation for the cli tools is sparse, so
this is a case where ``the code is the documentation.''")
(license license:asl2.0)))
+
+(define-public z80asm
+ (package
+ (name "z80asm")
+ (version "1.8")
+ (source (origin
+ (uri "http://download.savannah.nongnu.org/releases/z80asm/z80asm-1.8.tar.gz")
+ (sha256
+ (base32 "0r2za4qb7b0n13xksj6vwddixn2jzcc5h8qk06kxzkc20naakyv7"))
+ (method url-fetch)))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out")
+ "/bin")))
+ (install-file "z80asm" bin)
+ #t))))))
+ (synopsis "Assembler for the Z80 microprcessor")
+ (description "Assembler for the Z80 microprcessor. The assembler
+aims to be portable and complete. It assembles all official
+mnemonics, but it also aims to assemble the unofficial mnemonics.")
+ (home-page "http://savannah.nongnu.org/projects/z80asm")
+ (license license:gpl3)))
+
+(define-public z80dasm
+ (package
+ (name "z80dasm")
+ (version "1.1.6")
+ (source (origin
+ (uri "https://www.tablix.org/~avian/z80dasm/z80dasm-1.1.6.tar.gz")
+ (sha256
+ (base32 "0q6k1dy34p1mncq5cp5a3yakka9a9j4llw6vqjh81wr8n1xrdlvn"))
+ (method url-fetch)))
+ (build-system gnu-build-system)
+ (synopsis "Disassembler for the Zilog Z80 microprocessor and compatibles")
+ (description "z80dasm is a disassembler for the Zilog Z80
+microprocessor and compatibles. It can be used to reverse engineer
+programs and operating systems for 1980's microcomputers using this
+processor architecture (for example Sinclair ZX81, Spectrum and many
+others).")
+ (home-page "https://www.tablix.org/~avian/blog/articles/z80dasm/")
+ (license license:gpl2)))
Ludovic Courtès wrote 4 years ago
(name . Thomas Albers)(address . thomas@thomaslabs.org)(address . 49643@debbugs.gnu.org)
87h7fwkqkv.fsf@gnu.org
Hi Thomas,

Sorry for the long delay replying. Overall the patch LGTM, though there
are minor issues that ‘guix lint’ should report and others related to
the guidelines:


In particular, could you send one patch per package (ideally with proper
commit log, preferably with ‘git send-email’), with
synopses/descriptions tweaked according to the guidelines?

You can send revised patches to 49643@debbugs.gnu.org.

Thanks in advance,
Ludo’.
Thomas Albers wrote 4 years ago
[PATCH] gnu: Add z80asm
(address . 49643@debbugs.gnu.org)
87lf57hmhy.fsf@thomaslabs.org
---
gnu/packages/assembly.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 51c0572674..a60370ad8d 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -533,3 +533,31 @@ family of command line utility wrappers in the default output. Each of the cli
tools is named like @code{xed*}. Documentation for the cli tools is sparse, so
this is a case where ``the code is the documentation.''")
(license license:asl2.0)))
+
+(define-public z80asm
+ (package
+ (name "z80asm")
+ (version "1.8")
+ (source
+ (origin
+ (uri "http://download.savannah.nongnu.org/releases/z80asm/z80asm-1.8.tar.gz")
+ (sha256
+ (base32 "0r2za4qb7b0n13xksj6vwddixn2jzcc5h8qk06kxzkc20naakyv7"))
+ (method url-fetch)))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out")
+ "/bin")))
+ (install-file "z80asm" bin)
+ #t))))))
+ (synopsis "Assembler for the Z80 microprocessor")
+ (description "Assembler for the Z80 microprocessor which supports all
+official mnemonics together with many unofficial ones.")
+ (home-page "http://savannah.nongnu.org/projects/z80asm")
+ (license license:gpl3)))
--
Thomas Albers wrote 4 years ago
[PATCH 1/2] gnu: Add z80asm
(address . 49643@debbugs.gnu.org)(name . Thomas Albers)(address . tgalbers2000@gmail.com)
20210813143156.16449-1-thomas@thomaslabs.org
From: Thomas Albers <tgalbers2000@gmail.com>

---
gnu/packages/assembly.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 51c0572674..a60370ad8d 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -533,3 +533,31 @@ family of command line utility wrappers in the default output. Each of the cli
tools is named like @code{xed*}. Documentation for the cli tools is sparse, so
this is a case where ``the code is the documentation.''")
(license license:asl2.0)))
+
+(define-public z80asm
+ (package
+ (name "z80asm")
+ (version "1.8")
+ (source
+ (origin
+ (uri "http://download.savannah.nongnu.org/releases/z80asm/z80asm-1.8.tar.gz")
+ (sha256
+ (base32 "0r2za4qb7b0n13xksj6vwddixn2jzcc5h8qk06kxzkc20naakyv7"))
+ (method url-fetch)))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out")
+ "/bin")))
+ (install-file "z80asm" bin)
+ #t))))))
+ (synopsis "Assembler for the Z80 microprocessor")
+ (description "Assembler for the Z80 microprocessor which supports all
+official mnemonics together with many unofficial ones.")
+ (home-page "http://savannah.nongnu.org/projects/z80asm")
+ (license license:gpl3)))
--
2.32.0
Thomas Albers wrote 4 years ago
[PATCH 2/2] gnu: Add z80dasm
(address . 49643@debbugs.gnu.org)(name . Thomas Albers)(address . tgalbers2000@gmail.com)
20210813143156.16449-2-thomas@thomaslabs.org
From: Thomas Albers <tgalbers2000@gmail.com>

---
gnu/packages/assembly.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index a60370ad8d..4746e209dc 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -561,3 +561,21 @@ this is a case where ``the code is the documentation.''")
official mnemonics together with many unofficial ones.")
(home-page "http://savannah.nongnu.org/projects/z80asm")
(license license:gpl3)))
+
+(define-public z80dasm
+ (package
+ (name "z80dasm")
+ (version "1.1.6")
+ (source (origin
+ (uri "https://www.tablix.org/~avian/z80dasm/z80dasm-1.1.6.tar.gz")
+ (sha256
+ (base32 "0q6k1dy34p1mncq5cp5a3yakka9a9j4llw6vqjh81wr8n1xrdlvn"))
+ (method url-fetch)))
+ (build-system gnu-build-system)
+ (synopsis "Disassembler for the Zilog Z80 microprocessor and compatibles")
+ (description "Disassembler for the Zilog Z80 microprocessor and
+compatibles. It can be used to reverse engineer programs and operating systems
+for 1980's microcomputers using this processor architecture (for example
+Sinclair ZX81, Spectrum and many others).")
+ (home-page "https://www.tablix.org/~avian/blog/articles/z80dasm/")
+ (license license:gpl2)))
--
2.32.0
Thomas Albers wrote 4 years ago
Re: bug#49643: [PATCH] z80asm and z80dasm
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 49643@debbugs.gnu.org)
87eeax9zdi.fsf@thomaslabs.org
Hello Ludo,

don't worry for the delay.

I've tried to fix the issues you mentioned and sent 2 patches. In
reality they are 3. The first of them was actually a mistake, I didn't
have any experience with git-send-mail and made the mistake of using my
email client.

I apologize for sending unnecessary mails, it is not my intention to
fill the mailing list with spam, but I needed practice given that this
is the first time I attempt to collaborate in a Free Software project.

Closely related to this last topic. If there are any further mistakes
with my patches, could you please point out exactly which ones they are?
I had read the guidelines, but simply failed to implement them.

Thank you for your answer,
Thomas
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 49643@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49643
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help