(address . guix-patches@gnu.org)
* gnu/packages/golang.scm (go-1.16)[arguments]<#:phases>{build}: Honor
parallel-build?
---
Does what it says on the tin. (Looks like I missed in the original go-1.16
submission.)
gnu/packages/golang.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
Toggle diff (31 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a830afa022..7bbd62f3cd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1513,10 +1513,12 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(substitute* "time/zoneinfo_unix.go"
(("/usr/share/zoneinfo/") tzdata-path)))))
(replace 'build
- (lambda* (#:key inputs outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs (parallel-build? #t)
+ #:allow-other-keys)
;; FIXME: Some of the .a files are not bit-reproducible.
;; (Is this still true?)
- (let* ((output (assoc-ref outputs "out"))
+ (let* ((njobs (if parallel-build? (parallel-job-count) 1))
+ (output (assoc-ref outputs "out"))
(loader (string-append (assoc-ref inputs "libc")
,(glibc-dynamic-linker))))
(setenv "CC" (which "gcc"))
@@ -1525,6 +1527,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(setenv "GOROOT" (dirname (getcwd)))
(setenv "GOROOT_FINAL" output)
(setenv "GOCACHE" "/tmp/go-cache")
+ (setenv "GOMAXPROCS" (number->string njobs))
(invoke "sh" "make.bash" "--no-banner"))))
(replace 'check
(lambda* (#:key target (tests? (not target)) (parallel-tests? #t)
base-commit: 9cb35c02164d929fcb8929e7f454df215df8cf25
--
2.31.1