[PATCH] gnu: Add ghc-8.10.

  • Done
  • quality assurance status badge
Details
4 participants
  • Sarah Morgensen
  • John Kehayias
  • Lars-Dominik Braun
  • Xinglu Chen
Owner
unassigned
Submitted by
Xinglu Chen
Severity
normal
X
X
Xinglu Chen wrote on 17 Jul 2021 17:34
(address . guix-patches@gnu.org)
039023c844a5fa57c050bab868677dabd08b1bb0.1626535972.git.public@yoctocell.xyz
* gnu/packages/haskell.scm (ghc-8.10): New variable.
---
Two tests are failing, I am not sure why, but I have already spent too much
time on this.

gnu/packages/haskell.scm | 52 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 09732fc594..4e31867bfd 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -657,6 +657,58 @@ interactive environment for the functional language Haskell.")
(file-pattern ".*\\.conf\\.d$")
(file-type 'directory))))))
+(define-public ghc-8.10
+ (package
+ (inherit ghc-8.8)
+ (name "ghc")
+ (version "8.10.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.haskell.org/ghc/dist/"
+ version "/ghc-" version "-src.tar.xz"))
+ (sha256
+ (base32 "0vq7wch0wfvy2b5dbi308lq5225vf691n95m19c9igagdvql22gi"))))
+ (native-inputs
+ `(("ghc-bootstrap" ,ghc-8.8)
+ ("ghc-testsuite"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.haskell.org/ghc/dist/"
+ version "/ghc-" version "-testsuite.tar.xz"))
+ (patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
+ (sha256
+ (base32
+ "0vcq774rfb6q8vsnh7p5clxp2qaz8ip6d2bm2ghbq53n8jl296d6"))))
+ ("git" ,git-minimal) ; invoked during tests
+ ,@(filter (match-lambda
+ (("ghc-bootstrap" . _) #f)
+ (("ghc-testsuite" . _) #f)
+ (_ #t))
+ (package-native-inputs ghc-8.8))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments ghc-8.8)
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'fix-cc-name
+ (lambda _
+ (substitute* "utils/hsc2hs/Common.hs"
+ (("\"cc\"") "\"gcc\""))))
+ (add-after 'skip-more-tests 'skip-even-more-tests
+ (lambda _
+ ;; Not sure why these tests fail
+ (substitute* '("testsuite/tests/driver/T8602/T8602.T"
+ "testsuite/tests/driver/T16521/all.T")
+ (("^.*" all)
+ (string-append "# guix skipped: " all)))))))))
+ (native-search-paths (list (search-path-specification
+ (variable "GHC_PACKAGE_PATH")
+ (files (list
+ (string-append "lib/ghc-" version)))
+ (file-pattern ".*\\.conf\\.d$")
+ (file-type 'directory))))))
+
(define-public ghc-8 ghc-8.6)
(define-public ghc ghc-8)

base-commit: 9cb35c02164d929fcb8929e7f454df215df8cf25
--
2.32.0
S
S
Sarah Morgensen wrote on 17 Jul 2021 21:24
(name . Xinglu Chen)(address . public@yoctocell.xyz)(address . 49606@debbugs.gnu.org)
86y2a4ivzo.fsf@mgsn.dev
Hi!

Xinglu Chen <public@yoctocell.xyz> writes:

Toggle quote (10 lines)
> * gnu/packages/haskell.scm (ghc-8.10): New variable.
> ---
> Two tests are failing, I am not sure why, but I have already spent too much
> time on this.
> [...]
> + (add-after 'skip-more-tests 'skip-even-more-tests
> + (lambda _
> + ;; Not sure why these tests fail
> + (substitute* '("testsuite/tests/driver/T8602/T8602.T"

This test looks like it's failing because it has a "#! /bin/sh" shebang
in 'T8602.script'.

Toggle quote (2 lines)
> + "testsuite/tests/driver/T16521/all.T")

This test looks like it's the only one which uses '-include-cpp-deps',
and it looks like it's the only test which includes a file in the
libraries directory. Perhaps a search path issue?

Hope that helps,
Sarah
X
X
Xinglu Chen wrote on 23 Jul 2021 22:48
Re: [bug#49606] [PATCH] gnu: Add ghc-8.10.
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)(address . 49606@debbugs.gnu.org)
87pmv83gel.fsf@yoctocell.xyz
On Sat, Jul 17 2021, Sarah Morgensen via Guix-patches via wrote:

Toggle quote (17 lines)
> Hi!
>
> Xinglu Chen <public@yoctocell.xyz> writes:
>
>> * gnu/packages/haskell.scm (ghc-8.10): New variable.
>> ---
>> Two tests are failing, I am not sure why, but I have already spent too much
>> time on this.
>> [...]
>> + (add-after 'skip-more-tests 'skip-even-more-tests
>> + (lambda _
>> + ;; Not sure why these tests fail
>> + (substitute* '("testsuite/tests/driver/T8602/T8602.T"
>
> This test looks like it's failing because it has a "#! /bin/sh" shebang
> in 'T8602.script'.

Ah, good catch!

Toggle quote (6 lines)
>> + "testsuite/tests/driver/T16521/all.T")
>
> This test looks like it's the only one which uses '-include-cpp-deps',
> and it looks like it's the only test which includes a file in the
> libraries directory. Perhaps a search path issue?

I am not familiar with CPP stuff, but I will see what I can do about it.

Thank you for the pointers! I will try to find some time to work on
this during the weekend.
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmD7KzIVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5j14QALcE4iEiVnUYYxm33hj6optsCL84
0cRbZUiDBkmYYIUUSOOMvuC0sZSzJGV0dbl6tWbUReBqSD+JRwPwyBMjd3gLR2dE
qridKeImWtauNd3BCnWrIy7CMQuZwPjB5KqJHV/nwpsZMaft25VJfa+wo48ZVgxo
dVSVdZxoYiRO0QCx7sNP/Ue8wwzg0tPygKMopz4nXYQ7T2Q4zAWAbeQ3v90zIdha
tkrAonVP8CcKv1kImf4puFWLLRnSO0WTag9KI/aXqJ9sZJgbEiCumMLjJuI9kbj/
R7iBynec36GsSdF3N8zz0KssmGT0Un3WRd0K9IvjOsZq+xOvuJoVwDqujaiGMg3e
ItqhJ76+doeq0Nis0eo73i4u69bSM2uJaTPaZp4TAGr1O0yRqKJMDDC+v796LF7G
jpBEKy1z4lEAYDO6fa+rSDbivNBIOryRYNFZ8O6IoExOp4goj1Y9zVDUurVLexU0
pJoqsSH1+byLovRS2B4aq/57AYJa4oCZ9DS0tHnaCVnUd6fO7mbeY/cAgZsAL6qz
ebRpn6QJ/Dmo4fOf/epzvvkXWAIYrCwOkQiXLNgnWnAlQi4Mz4hzrXaWOiZpsY3T
V3DWj3MIkfTw45AKjfFV1xbbfQkQl0Sed+HGcCOkbntKEfugIjo/SEB6LfCzJJ1O
pGdPc/WzdtZIEGve
=DY8X
-----END PGP SIGNATURE-----

X
X
Xinglu Chen wrote on 31 Jul 2021 00:12
[PATCH wip-haskell v2] gnu: Add ghc-8.10.
(address . 49606@debbugs.gnu.org)
50732186fb1a7b17d2d44d172957ba145607debf.1627682631.git.public@yoctocell.xyz
* gnu/packages/haskell.scm (ghc-8.10): New variable.
---
Changes since v1:

* Fix /bin/sh path in one of the tests.

Unfortunately, I haven’t been able to fix the T16521 test; I tried
setting the C_INCLUDE_PATH variable to ‘libraries/process/include’, but
it’s still not able to find ’processFlags.h’. Not sure if there is
anything else I could try. Would it be OK to merge this despite the
failing test?

Also, this patch should go to the ‘wip-haskell’ branch; once/if it gets
merged it would be a good idea to update the Stackage LTS release and
update all the Haskell packages.

gnu/packages/haskell.scm | 59 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (81 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 09732fc594..089ea7ceb0 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -657,6 +658,64 @@ interactive environment for the functional language Haskell.")
(file-pattern ".*\\.conf\\.d$")
(file-type 'directory))))))
+(define-public ghc-8.10
+ (package
+ (inherit ghc-8.8)
+ (name "ghc")
+ (version "8.10.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.haskell.org/ghc/dist/"
+ version "/ghc-" version "-src.tar.xz"))
+ (sha256
+ (base32 "0vq7wch0wfvy2b5dbi308lq5225vf691n95m19c9igagdvql22gi"))))
+ (native-inputs
+ `(("ghc-bootstrap" ,ghc-8.8)
+ ("ghc-testsuite"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.haskell.org/ghc/dist/"
+ version "/ghc-" version "-testsuite.tar.xz"))
+ (patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
+ (sha256
+ (base32
+ "0vcq774rfb6q8vsnh7p5clxp2qaz8ip6d2bm2ghbq53n8jl296d6"))))
+ ("git" ,git-minimal) ; invoked during tests
+ ,@(filter (match-lambda
+ (("ghc-bootstrap" . _) #f)
+ (("ghc-testsuite" . _) #f)
+ (_ #t))
+ (package-native-inputs ghc-8.8))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments ghc-8.8)
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'fix-cc-name
+ (lambda _
+ (substitute* "utils/hsc2hs/Common.hs"
+ (("\"cc\"") "\"gcc\""))))
+ (add-after 'unpack-testsuite 'patch-more-shebangs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((bash (assoc-ref inputs "bash")))
+ (substitute* '("testsuite/tests/driver/T8602/T8602.script")
+ (("/bin/sh")
+ (string-append bash "/bin/sh"))))))
+ (add-after 'skip-more-tests 'skip-even-more-tests
+ (lambda _
+ ;; FIXME: It is unable to find some C header files;
+ ;; setting C_INCLUDE_PATH doesn't help either.
+ (substitute* '("testsuite/tests/driver/T16521/all.T")
+ (("^.*" all)
+ (string-append "# guix skipped: " all)))))))))
+ (native-search-paths (list (search-path-specification
+ (variable "GHC_PACKAGE_PATH")
+ (files (list
+ (string-append "lib/ghc-" version)))
+ (file-pattern ".*\\.conf\\.d$")
+ (file-type 'directory))))))
+
(define-public ghc-8 ghc-8.6)
(define-public ghc ghc-8)

base-commit: f2470e9a4bcd47d526e14721bbd2693fb979d306
--
2.32.0
X
X
Xinglu Chen wrote on 12 Aug 2021 12:18
(address . 49606@debbugs.gnu.org)
875ywbhspt.fsf@yoctocell.xyz
On Sat, Jul 31 2021, Xinglu Chen wrote:

Toggle quote (16 lines)
> * gnu/packages/haskell.scm (ghc-8.10): New variable.
> ---
> Changes since v1:
>
> * Fix /bin/sh path in one of the tests.
>
> Unfortunately, I haven’t been able to fix the T16521 test; I tried
> setting the C_INCLUDE_PATH variable to ‘libraries/process/include’, but
> it’s still not able to find ’processFlags.h’. Not sure if there is
> anything else I could try. Would it be OK to merge this despite the
> failing test?
>
> Also, this patch should go to the ‘wip-haskell’ branch; once/if it gets
> merged it would be a good idea to update the Stackage LTS release and
> update all the Haskell packages.

Any comments/thoughts on this, anyone?
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmEU9V4VHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5UkEQAIe+szF5S/0LwzyqG/TRSqJFmUAr
BMUdEUcsJrojjw+Nogx16GoYTfq5NR51odkz+RuO8hBP+/KX671mpwDohe1JI76J
zDPPliyeo6Q0yTItoz19Mm/tpqJ27fKGIwXj+dK7RfbIJa2xwqdHWlhc0wSzRLmk
uOjRHURPuqSoEy6FD8ywHY+LVqikxXU8buo1ptfApQoPSBS6Qvg33ONJ01foMN9s
cpj4Ruf5pUqj6hhpFwbBCl/jY6n+BWkg9dbelgANAuJ/zaXvqcb+MGUnU8lZU6bH
rGqxSHyIPxkmc312AgcwTjOqipmImnUqU/M2cd+5lY3Rr4fm/kRTQAQ/2qzc/5Yz
OalCBJKh1Op8U65xytp+JGb+7adV3GoDb+pL6Awxiak1iIAlZ6MjmI+V8nXODOFr
X6v1neUJhwJkGHE/FKfIB+GI914D6tvXSDKkv7sIGAb1vIpcrhaPkcoavnDUyFbQ
nYBGmmxQeTpEg1keQDxwv420DfHVKpr3mQMAUC+X29zjwJ0dDg8EndlEv+0+YQiV
W6xaSFP0gbJ3Mq2M1mzOx7wVp32UE+8CuyQqgfMAX4LEhf5+45Wwxw822KIig4KN
2oole+YG/WQnwuFHq1AIe3A8VUZ2sdXR3OmORqyH/cxgbrUuDMhrMO9tIPiYe2Al
sTc6GQKDzTWKcHpi
=MF/p
-----END PGP SIGNATURE-----

L
L
Lars-Dominik Braun wrote on 13 Sep 2021 16:24
(name . Xinglu Chen)(address . public@yoctocell.xyz)
YT9fJdTVyHUOtSPR@noor.fritz.box
Hi,

Toggle quote (1 lines)
> Any comments/thoughts on this, anyone?
I looked at the patch and would like to propose minor modifications. In
particular I

- removed the 'fix-cc-name phase, which is inherited from ghc-8.8 anyway
- converted the failing test (which I can’t get to pass either) into
an expected failure instead of nulling it out and
- renamed the package to ghc-next, which should avoid
https://issues.guix.gnu.org/47335– if we also rename GHC 8.8 in a
different patch.

I think we can merge this patch to master, since it only adds a new GHC
version and has no further implications. Thoughts?

Cheers,
Lars
Toggle diff (73 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3d10bdc946..ca0498e6d9 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -21,6 +21,7 @@
;;; Copyright � 2019 Jacob MacDonald <jaccarmac@gmail.com>
;;; Copyright � 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright � 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright � 2021 Xinglu Chen <public@yoctocell.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -663,6 +664,60 @@ interactive environment for the functional language Haskell.")
(file-pattern ".*\\.conf\\.d$")
(file-type 'directory))))))
+(define-public ghc-8.10
+ (package
+ (inherit ghc-8.8)
+ (name "ghc-next")
+ (version "8.10.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.haskell.org/ghc/dist/"
+ version "/ghc-" version "-src.tar.xz"))
+ (sha256
+ (base32 "179ws2q0dinl1a39wm9j37xzwm84zfz3c5543vz8v479khigdvp3"))))
+ (native-inputs
+ `(("ghc-bootstrap" ,ghc-8.8)
+ ("ghc-testsuite"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.haskell.org/ghc/dist/"
+ version "/ghc-" version "-testsuite.tar.xz"))
+ (patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
+ (sha256
+ (base32
+ "1zl25gg6bpx5601k8h3cqnns1xfc0nqgwnh8jvn2s65ra3f2g1nz"))))
+ ("git" ,git-minimal) ; invoked during tests
+ ,@(filter (match-lambda
+ (("ghc-bootstrap" . _) #f)
+ (("ghc-testsuite" . _) #f)
+ (_ #t))
+ (package-native-inputs ghc-8.8))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments ghc-8.8)
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (add-after 'unpack-testsuite 'patch-more-shebangs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((bash (assoc-ref inputs "bash")))
+ (substitute* '("testsuite/tests/driver/T8602/T8602.script")
+ (("/bin/sh")
+ (string-append bash "/bin/sh"))))))
+ ;; Mark failing tests as broken. Reason for failure is unknown.
+ (add-after 'skip-more-tests 'skip-even-more-tests
+ (lambda _
+ (substitute* '("testsuite/tests/driver/T16521/all.T")
+ (("extra_files" all) (string-append "[" all))
+ (("\\]\\), " all)
+ (string-append all "expect_broken(0)], ")))))))))
+ (native-search-paths (list (search-path-specification
+ (variable "GHC_PACKAGE_PATH")
+ (files (list
+ (string-append "lib/ghc-" version)))
+ (file-pattern ".*\\.conf\\.d$")
+ (file-type 'directory))))))
+
(define-public ghc-8 ghc-8.6)
(define-public ghc ghc-8)
X
X
Xinglu Chen wrote on 13 Sep 2021 18:07
(name . Lars-Dominik Braun)(address . lars@6xq.net)
8735q8v4qp.fsf@yoctocell.xyz
On Mon, Sep 13 2021, Lars-Dominik Braun wrote:

Toggle quote (8 lines)
> Hi,
>
>> Any comments/thoughts on this, anyone?
> I looked at the patch and would like to propose minor modifications. In
> particular I
>
> - removed the 'fix-cc-name phase, which is inherited from ghc-8.8 anyway

Aye, the patch has bitrotted a bit.

Toggle quote (3 lines)
> - converted the failing test (which I can’t get to pass either) into
> an expected failure instead of nulling it out and

Either way works for me. :-)

Toggle quote (4 lines)
> - renamed the package to ghc-next, which should avoid
> https://issues.guix.gnu.org/47335 – if we also rename GHC 8.8 in a
> different patch.

AFAIK, ‘-next’ packages are usually unstable versions of the regular
version, e.g., ‘emacs-next’ and ‘guile-next’. ‘ghc-8.10’ is a stable
release, so I am not sure if the ‘-next’ prefix is appropriate.

Also, I would imagine that other language ecosystems also have to
problem of the default compiler not being the latest version, e.g., the
‘rust’ package points to rust-1.45, but rust-1.52 is the latest
available version.

Toggle quote (3 lines)
> I think we can merge this patch to master, since it only adds a new GHC
> version and has no further implications. Thoughts?

Originally, the plan was to apply this patch to the ‘wip-haskell’
branch, which contained a patch that results in rebuilding all Haskell
pacakges, and then update our Stackage LTS version (which hasn’t been
updated for ~2 years)[1]. But seeing as there isn’t much interest in a
Haskell update, applying to ‘master’ seems like a better idea.

[1]:

Toggle quote (71 lines)
> diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
> index 3d10bdc946..ca0498e6d9 100644
> --- a/gnu/packages/haskell.scm
> +++ b/gnu/packages/haskell.scm
> @@ -21,6 +21,7 @@
> ;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
> ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
> ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
> +;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -663,6 +664,60 @@ interactive environment for the functional language Haskell.")
> (file-pattern ".*\\.conf\\.d$")
> (file-type 'directory))))))
>
> +(define-public ghc-8.10
> + (package
> + (inherit ghc-8.8)
> + (name "ghc-next")
> + (version "8.10.7")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://www.haskell.org/ghc/dist/"
> + version "/ghc-" version "-src.tar.xz"))
> + (sha256
> + (base32 "179ws2q0dinl1a39wm9j37xzwm84zfz3c5543vz8v479khigdvp3"))))
> + (native-inputs
> + `(("ghc-bootstrap" ,ghc-8.8)
> + ("ghc-testsuite"
> + ,(origin
> + (method url-fetch)
> + (uri (string-append
> + "https://www.haskell.org/ghc/dist/"
> + version "/ghc-" version "-testsuite.tar.xz"))
> + (patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
> + (sha256
> + (base32
> + "1zl25gg6bpx5601k8h3cqnns1xfc0nqgwnh8jvn2s65ra3f2g1nz"))))
> + ("git" ,git-minimal) ; invoked during tests
> + ,@(filter (match-lambda
> + (("ghc-bootstrap" . _) #f)
> + (("ghc-testsuite" . _) #f)
> + (_ #t))
> + (package-native-inputs ghc-8.8))))
> + (arguments
> + (substitute-keyword-arguments (package-arguments ghc-8.8)
> + ((#:phases phases '%standard-phases)
> + `(modify-phases ,phases
> + (add-after 'unpack-testsuite 'patch-more-shebangs
> + (lambda* (#:key inputs #:allow-other-keys)
> + (let ((bash (assoc-ref inputs "bash")))
> + (substitute* '("testsuite/tests/driver/T8602/T8602.script")
> + (("/bin/sh")
> + (string-append bash "/bin/sh"))))))
> + ;; Mark failing tests as broken. Reason for failure is unknown.
> + (add-after 'skip-more-tests 'skip-even-more-tests
> + (lambda _
> + (substitute* '("testsuite/tests/driver/T16521/all.T")
> + (("extra_files" all) (string-append "[" all))
> + (("\\]\\), " all)
> + (string-append all "expect_broken(0)], ")))))))))
> + (native-search-paths (list (search-path-specification
> + (variable "GHC_PACKAGE_PATH")
> + (files (list
> + (string-append "lib/ghc-" version)))
> + (file-pattern ".*\\.conf\\.d$")
> + (file-type 'directory))))))
> +

The updated patch LGTM, and great that you updated it to 8.10.7!
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmE/dz4VHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x57wsP/jZEH9nnDOvC5nOU/rtQiLS0OTdh
UpIlFyELfrZaKr3kKyuTIgu8tEbKOG8iSqBiDIMKadyqMP82EtAVE2UFX9GlJUsJ
PmnkfwWFa2jJrw5FWwGk6lcVpXMfFcLDsVNL3v3f5yDuErOMasK2upco7O2FxukF
1z3G2fDnQCtbFHJp8n/vesHq1itL4SDWg1so1clUI0X74EH6fAYqzWcM8BClYJR1
ePGKrLETcoVduqtlnCGFp84o6C3CVIhnSOUkdFnoyJye2cn9qWO5BTpZAL3lCA4F
Yxlx4E3V+hWK2KMehcKfUpcCq+FYMfrzzxSea01e1H3+hDCdOIP1+onJXrT7WXa4
x3eZcXhOoHUZ9ziYg+FdTU/wG1Xqtb0HAvNuWifMKuHyxwbqiD3Ia4ER9RlCB3LR
+DoIXybUmfad9tNhWPXEgOW4kjhBVoznzLPNR1DsTj94W8nKRtTW92mRIHZ4iZnc
tdzYpw7DkuUQP1TkRY9OlBgnc+qsmuufC/Iu37Rc94Y9he4SyhgG2uw3mslWNwPg
mj5+kPoY6vxF2ljncDdKNyvUgufec2x0WcOx787M/9NbiX1lX3d4pGpiMfECPFMs
nJ7mkMWojbWYVnuq4z2R3zoGSAZqlHD97ZyGareENVTE0P3ar+N5f7tkioUgemOQ
/TZW69/BsrxwU12x
=hU7w
-----END PGP SIGNATURE-----

J
J
John Kehayias wrote on 13 Sep 2021 18:55
(name . Xinglu Chen)(address . public@yoctocell.xyz)
swnb3_feNkkGT1REekN_1uFwr5NK-IVhVvk9Fmskg1kb-f119_qV08ds54333dOY1D56a6CYZ7_opSCCY4XGhyQXSWM6wzuWFMAGdeHk_tg=@protonmail.com
A patch to master would probably be more helpful to get people to try to build their favorite packages with 8.10 to find any issues. Although I guess we'd want to do that in wip-haskell for everything anyway.

And then yes, we'll need to do a Stackage update for whatever release is the latest that uses 8.10. Hopefully we can get a big chunk of that through guix refresh. 8.10 will have to come first.
L
L
Lars-Dominik Braun wrote on 14 Sep 2021 15:02
(name . Xinglu Chen)(address . public@yoctocell.xyz)
YUCdcbnf7izodWtN@noor.fritz.box
Hi,

Toggle quote (3 lines)
> AFAIK, ‘-next’ packages are usually unstable versions of the regular
> version, e.g., ‘emacs-next’ and ‘guile-next’. ‘ghc-8.10’ is a stable
> release, so I am not sure if the ‘-next’ prefix is appropriate.
that is true, but I don’t see any other way to make

guix environment --pure --ad-hoc ghc ghc-aeson -- ghci
> import Data.Aeson

do “the right thing” by default. We could also argue that from
Guix’s point of view GHC 8.8/8.10 is (right now) unstable, because our
entire set of Haskell packages is built with GHC 8.6 (and thus untested
with higher versions of base). We also have python-next@3.9.2 on master
with (I think) exactly the same purpose. So, unless there’s any strong
objections I’ll be bold and rename GHC>8.6 to ghc-next, explaining
the situation in a comment.

Toggle quote (2 lines)
> But seeing as there isn’t much interest in a
> Haskell update, applying to ‘master’ seems like a better idea.
I’m counting three people (John, you and me) interested in getting
Haskell back into shape, so let’s just do it :)

Cheers,
Lars
X
X
Xinglu Chen wrote on 14 Sep 2021 17:21
(name . Lars-Dominik Braun)(address . lars@6xq.net)
87pmtbtc7r.fsf@yoctocell.xyz
On Tue, Sep 14 2021, Lars-Dominik Braun wrote:

Toggle quote (18 lines)
> Hi,
>
>> AFAIK, ‘-next’ packages are usually unstable versions of the regular
>> version, e.g., ‘emacs-next’ and ‘guile-next’. ‘ghc-8.10’ is a stable
>> release, so I am not sure if the ‘-next’ prefix is appropriate.
> that is true, but I don’t see any other way to make
>
> guix environment --pure --ad-hoc ghc ghc-aeson -- ghci
> > import Data.Aeson
>
> do “the right thing” by default. We could also argue that from
> Guix’s point of view GHC 8.8/8.10 is (right now) unstable, because our
> entire set of Haskell packages is built with GHC 8.6 (and thus untested
> with higher versions of base). We also have python-next@3.9.2 on master
> with (I think) exactly the same purpose. So, unless there’s any strong
> objections I’ll be bold and rename GHC>8.6 to ghc-next, explaining
> the situation in a comment.

Ah, from Guix’s perspective GHC>8.6 would be unstable I guess. Feel
free to push! :-)

Toggle quote (5 lines)
>> But seeing as there isn’t much interest in a
>> Haskell update, applying to ‘master’ seems like a better idea.
> I’m counting three people (John, you and me) interested in getting
> Haskell back into shape, so let’s just do it :)

That would be great! :-)
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmFAvegVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5nTAP/2D4LczcrNxk/FfAP7gABkJmYAJj
yjwEsMQDYHp0qMqr8pLbwEgdno6N9zAI203l4sjafBsYMvYYZrFjwueqKFLhc0Dx
WW5u2qPhRpsRzx4TWDqo+OLEw6GuODl8Mz2gMbMr/laUl4rx8ZQHmhVIQJXR63xY
lavbyByk1zwtWyPQWfbmylPIEXec5JkiipYw7vAhj5sGpwr5gAvKLKZ6NAmbCrhW
sYs5P72Y1c1ZrYzIMP52ewja9Kwx4rd9hK+S8BtIWHKojWIAfPe7O1mbEbPsYV4A
+jS47Gjyn2EAUsKWjpnQmRN+IRtRLM7bue2Xtzd0JHuiY0+kg8QDl1dfPmggPsLk
yTdjISQ2+ACUF1AscfmM1fZZqfF3v1aIu6Yhelo3ykfQsPlu1HBoaSvyBB4T1IYx
3bRcDdvX3UaadnBT05e/sZgKKPy5z3HopTedng7nfcVOQtwTtwbhcVk75rrYNWuj
NgAoviG9SZrdDEgTHaRhxO4AIoIRfNKpMd5TZsgEBnpR7YBORXZ0YohipHCQJcsH
z6fkVM5RmLgxpzSlC/oGUHhgCr8vCzu3IKwlPrrTG2QuN1W91YkQGHVSg+afZp8W
OjmCrudzx7ITZe2OBo1S3mh6n/r9p9zO5pGijXLlQq97Fh3Muxdb3hVJzuiO2FQ2
DYxknaT5TWDUONG6
=Wgqn
-----END PGP SIGNATURE-----

L
L
Lars-Dominik Braun wrote on 15 Sep 2021 09:46
(name . Xinglu Chen)(address . public@yoctocell.xyz)
YUGkusaeZCt9tE2C@noor.fritz.box
Hi,

merged to master as 69f7a8f476da4cca5d146e3b232a9919693eb2eb.

Thank you very much,
Lars
Closed
J
J
John Kehayias wrote on 15 Sep 2021 21:31
(name . Lars-Dominik Braun)(address . lars@6xq.net)
OxWXQe-vRKyc4DgqXl2iT9wX-ElzFX3tPV3xTVXWXol0CgQEbH3MPMNVEHhIGMPrJLKk239qqLLwFvjXNih1ydcnYwLtq1BbflHSlkxFZrg=@protonmail.com
Great, thank you all for the work on ghc-8.10! Now to start the process of package updates on wip-haskell...
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49606@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49606
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch