[PATCH] gnu: Add emacs-autocrypt.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Arun Isaac
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB4023DEF2ED07D61EC8C2AFA4C5129@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-autocrypt): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9f9f9909b3..0f941b7f9d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12212,6 +12212,32 @@ a visual interface, reduce overhead of completion by using statistic method,
extensibility.")
(license license:gpl3+)))
+(define-public emacs-autocrypt
+ (let ((revision "0")
+ (commit "5b55f8d37545e9c441788627c17e350d7edf4055"))
+ (package
+ (name "emacs-autocrypt")
+ (version (git-version "0.4.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~zge/autocrypt")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0b06xnjkgwjpxl96mdi674pmvdaiwncifi1a30wxhl1dwr7kr084"))))
+ (build-system emacs-build-system)
+ (home-page "https://git.sr.ht/~zge/autocrypt")
+ (synopsis "Autocrypt implementation")
+ (description "Implementation of Autocrypt (@url{https://autocrypt.org/}) for
+various Emacs MUAs.
+
+Run @code{M-x autocrypt-create-account} to initialize an autocrypt key, and
+add @code{autocrypt-mode} to your MUA's hooks (@code{gnus-mode-hook},
+@code{message-mode-hook}, ...) to activate it's usage.")
+ (license license:cc0))))
+
(define-public emacs-nginx-mode
(package
(name "emacs-nginx-mode")
--
2.32.0
Arun Isaac wrote 4 years ago
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)(address . 49586-done@debbugs.gnu.org)
87wnp59vmm.fsf@systemreboot.net
Hi Morgan,

I have applied your patch to master with a few changes to the synopsis
and description. Thanks for contributing to Guix!

Regards,
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmEGmKEbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzIlgH/2g4QbFaK+wftuDAmmAX
71/YbY6zy5GBdkkZjw2xbknPrtVJHxuwKnY8SjpxM80BWvzKpVeLmqQNzGxuIlhV
pu1Qhp1A1ZD+D2Cm8HirQVVVoj4hsvlK364q88jAC7yQfiegrKFROTkKVs0IEJno
PwYjRN3HIbe1Y3aGXMVzU5bYjEUBLkqlYA5rYa7rjmJlTCkCIuyulLh4iU8mMUK3
5r3jp9jIhWzto7qghAjRPiY97KbkVdtJlfWMpY9DXXyolmemvNul/1ByJP0my76L
m2thoxPOrAm/LSAF8NLOpXRvyyOICKIAWk18HgLZKiTdXZ7QWLib2og04cqj2Spf
U1A=
=Q3OP
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49586@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49586
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help