[PATCH] gnu: Add emacs-worf.

  • Done
  • quality assurance status badge
Details
3 participants
  • Morgan.J.Smith
  • Morgan Smith
  • Olivier Rojon
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB40233CB7AFDB9C767A50DC02C5129@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-worf): New variable.
---
gnu/packages/emacs-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9f9f9909b3..6cf8f36432 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19422,6 +19422,44 @@ It replaces the standard completions buffer with Ido prompt.")
using user-provided rules.")
(license license:gpl3+)))
+(define-public emacs-worf
+ ;; Last release was in 2016
+ (let ((revision "0")
+ (commit "28d381e2603a79340a94a410acbbb8a6b3e237d8"))
+ (package
+ (name "emacs-worf")
+ (version (git-version "0.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abo-abo/worf")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15567bns5kag47d58xapr4z0gfj5py3a8lwfpjlhmzccmarjr7x8"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'delete-elpa.el
+ (lambda _
+ (delete-file "elpa.el")))
+ (add-after 'unpack 'require-hydra
+ (lambda _
+ (substitute* "worf.el"
+ ((";;; Code:") ";;; Code:\n(require 'hydra)")))))))
+ (propagated-inputs
+ `(("ace-link" ,emacs-ace-link)
+ ("hydra" ,emacs-hydra)
+ ("swiper" ,emacs-swiper)
+ ("zoutline" ,emacs-zoutline)))
+ (home-page "https://github.com/abo-abo/worf")
+ (synopsis "Minor mode that provides vi-like bindings for org-mode")
+ (description "Minor mode that provides vi-like bindings for org-mode")
+ (license license:gpl3+))))
+
(define-public emacs-on-screen
(package
(name "emacs-on-screen")
--
2.32.0
Olivier Rojon wrote 3 weeks ago
(address . Morgan.J.Smith@outlook.com)(address . 49585@debbugs.gnu.org)
87v7taj4tv.fsf@posteo.net
Morgan.J.Smith@outlook.com writes:

Hi,

considering that this issue is already very old and that there is alternative packages
such as emacs-evil-org already packaged, is this still relevant? If it is, I can try to
review it (sorry to see it lying around for so long!)

Provided I don't hear anything for an extended period of time (two weeks, say), I will
close this issue in an attempt to clean house.

Have a nice day :)
Olivier

Toggle quote (56 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-worf): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++++
> 1 file changed, 38 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 9f9f9909b3..6cf8f36432 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -19422,6 +19422,44 @@ It replaces the standard completions buffer with Ido prompt.")
> using user-provided rules.")
> (license license:gpl3+)))
>
> +(define-public emacs-worf
> + ;; Last release was in 2016
> + (let ((revision "0")
> + (commit "28d381e2603a79340a94a410acbbb8a6b3e237d8"))
> + (package
> + (name "emacs-worf")
> + (version (git-version "0.1.0" revision commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/abo-abo/worf")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "15567bns5kag47d58xapr4z0gfj5py3a8lwfpjlhmzccmarjr7x8"))))
> + (build-system emacs-build-system)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'delete-elpa.el
> + (lambda _
> + (delete-file "elpa.el")))
> + (add-after 'unpack 'require-hydra
> + (lambda _
> + (substitute* "worf.el"
> + ((";;; Code:") ";;; Code:\n(require 'hydra)")))))))
> + (propagated-inputs
> + `(("ace-link" ,emacs-ace-link)
> + ("hydra" ,emacs-hydra)
> + ("swiper" ,emacs-swiper)
> + ("zoutline" ,emacs-zoutline)))
> + (home-page "https://github.com/abo-abo/worf")
> + (synopsis "Minor mode that provides vi-like bindings for org-mode")
> + (description "Minor mode that provides vi-like bindings for org-mode")
> + (license license:gpl3+))))
> +
> (define-public emacs-on-screen
> (package
> (name "emacs-on-screen")
Olivier Rojon wrote 3 weeks ago
control message for bug #49585
(address . control@debbugs.gnu.org)
87tt8uj4m1.fsf@posteo.net
tags 49585 + moreinfo
quit
Morgan Smith wrote 3 weeks ago
Re: [bug#49585] [PATCH] gnu: Add emacs-worf.
(name . Olivier Rojon)(address . o.rojon@posteo.net)(address . 49585@debbugs.gnu.org)
CH3PR84MB34244440177027CBC91A6CF3C5F92@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
Hi Olivier,

Olivier Rojon <o.rojon@posteo.net> writes:

Toggle quote (15 lines)
> Morgan.J.Smith@outlook.com writes:
>
> Hi,
>
> considering that this issue is already very old and that there is alternative packages
> such as emacs-evil-org already packaged, is this still relevant? If it is, I can try to
> review it (sorry to see it lying around for so long!)
>
> Provided I don't hear anything for an extended period of time (two weeks, say), I will
> close this issue in an attempt to clean house.
>
> Have a nice day :)
> Olivier
>

Feel free to close. I forget exactly why I wanted this packaged. I
believe it was a dependency of something else I was trying to use but I
forget what it was.

Morgan
Olivier Rojon wrote 3 weeks ago
(name . Morgan Smith)(address . morgan.j.smith@outlook.com)(address . 49585@debbugs.gnu.org)
87tt8u5ph7.fsf@posteo.net
Morgan Smith <morgan.j.smith@outlook.com> writes:

Toggle quote (3 lines)
> Hi Olivier,
>

Hi Morgan,

Toggle quote (23 lines)
> Olivier Rojon <o.rojon@posteo.net> writes:
>
>> Morgan.J.Smith@outlook.com writes:
>>
>> Hi,
>>
>> considering that this issue is already very old and that there is alternative packages
>> such as emacs-evil-org already packaged, is this still relevant? If it is, I can try to
>> review it (sorry to see it lying around for so long!)
>>
>> Provided I don't hear anything for an extended period of time (two weeks, say), I will
>> close this issue in an attempt to clean house.
>>
>> Have a nice day :)
>> Olivier
>>
>
> Feel free to close. I forget exactly why I wanted this packaged. I
> believe it was a dependency of something else I was trying to use but I
> forget what it was.
>
> Morgan

Alright, thanks for the quick reply!

Have a good day :)
Olivier
Olivier Rojon wrote 3 weeks ago
control message for bug #49585
(address . control@debbugs.gnu.org)
87seoe5pgs.fsf@posteo.net
close 49585
quit
Olivier Rojon wrote 3 weeks ago
(address . control@debbugs.gnu.org)
87r03y5pe9.fsf@posteo.net
reopen 49585
tags 49585 - fixed patch
quit
Olivier Rojon wrote 3 weeks ago
(address . control@debbugs.gnu.org)
87plji5pe0.fsf@posteo.net
close 49585
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 49585@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49585
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help