[PATCH] gnu: Add powercap.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Efraim Flashner
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB4023AAEDE6FBAE1A05A47711C5129@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/linux.scm (powercap): New variable.
---
gnu/packages/linux.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 41902e7785..295e456488 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1651,6 +1651,34 @@ at login. Local and dynamic reconfiguration are its key features.")
;;; Miscellaneous.
;;;
+(define-public powercap
+ (package
+ (name "powercap")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/powercap/powercap")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hp2i1d195v0n4jgvgaymkxlpgyhn07ic273gkda95lz65cdfcgm"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=On" "-DCMAKE_BUILD_TYPE=Release")))
+ (home-page "https://github.com/powercap/powercap")
+ (synopsis "C interface to the Linux power capping framework
+(sysfs interface)")
+ (description "C interface to the Linux power capping framework (sysfs
+interface). It includes an implementation for working with Intel Running
+Average Power Limit (RAPL).
+
+It provides the commands powercap-info and powercap-set.")
+ (license license:bsd-3)))
+
(define-public powerstat
(package
(name "powerstat")
--
2.32.0
Efraim Flashner wrote 4 years ago
(address . Morgan.J.Smith@outlook.com)(address . 49584-done@debbugs.gnu.org)
YPV+Rabw2+vjpUAa@3900XT
After reading the synopsis and description and then seeing it again on
their repo's README I went and borrowed the ones from Debian, which I
found clearer.

Patch pushed!

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmD1fkUACgkQQarn3Mo9
g1FtkxAAmlBq3JAhebcIGkfSolpb6B+6vuyPZf+c/flwlzA5pBxPqTLUtHjBNZk+
gNEavhdsst6ZMREkP7fbpUfXzFgUW7a7mnD0eh1aIHAoUuLT/rUAdZqE+SbCWKd3
tF12wF/3Eiet0oa4XcgPWSWBjDOVTp2qKiSY4TMa3YQ0UUKotFNBhzjnt5cj1NyN
i675FKKgPNson1z6XsZHAgwuMKzKozEFBhk0CI4UE3LXSzQ3jwryxqxkALLo4Kqw
Y9fTCX9BJv5OSPm60OOaMk/K3f1q1zvfgXEI3EV7EBBP11mu/+fJ51qpT5DQtxyW
bc80K/MGvEssi2/xv0+wnSlyGTZ4qJFzyiEVSthPcHgPYb/llIpQ0jfgEHUM3C9k
HvO5ZlAKxvXgeVikozXvCBADpoSVvkuvb2PUsHMoie+L1Okhl1w65+/KpqtDfIIf
m/vL4DHfohZIV+j5/uTizkGnceqPRoY6mmAbjotfcCc3XW4y/1413L61i65JLRul
d+FFL7qe5FYaRiUZUSRBHr/l1rTlVYXztzSG8ExSgt3YiQORjaHvOXlDMi92rnKn
1EgjVW8Afqvgnuf1OeWV2nDVEz4liG3INXeRLkRiEeX52UUST4jDDlBpJtqOmfK+
A3ALO2BDpIGspKfy8e7S2/j/NrzJE+W16BONAj+Ytp6XIhxipmE=
=8O0E
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49584@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49584
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help