[PATH] gnu: Add transmission-remote-gtk.

  • Done
  • quality assurance status badge
Details
2 participants
  • Justin Veilleux
  • Leo Famulari
Owner
unassigned
Submitted by
Justin Veilleux
Severity
normal
J
J
Justin Veilleux wrote on 15 Jul 2021 20:31
(address . bug-guix@gnu.org)
CAJppLC8koSAh4kQGwPcGc-QbAqnjH+tmicVvUYVxgGw_CSu7yg@mail.gmail.com

Attachment: file
From 426aa9bd6b758628249df7c0925179ce39054f29 Mon Sep 17 00:00:00 2001
From: terramorpha <terramorpha@cock.li>
Date: Thu, 15 Jul 2021 14:27:35 -0400
Subject: [PATCH] gnu: Add transmission-remote-gtk.

* gnu/packages/bittorrent.scm (transmission-remote-gtk): New variable.
---
gnu/packages/bittorrent.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 0ca60d607c..90dabb40ed 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages adns)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -45,6 +47,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
@@ -138,6 +141,39 @@ DHT, µTP, PEX and Magnet Links.")
;; A few files files carry an MIT/X11 license header.
(license (list l:gpl2 l:gpl3))))
+(define-public transmission-remote-gtk
+ (package
+ (name "transmission-remote-gtk")
+ (version "1.4.1")
+ (source
+ (origin
+ (uri
+ (string-append
+ "https://github.com/transmission-remote-gtk/"
+ "transmission-remote-gtk/releases/download/"
+ version "/transmission-remote-gtk-" version ".tar.xz"))
+ (method url-fetch)
+ (sha256
+ (base32 "1aqjl5rgamgcgqvcldd1gzyfh2xci0m7070924d6vz2qln0q75sr"))))
+ (build-system gnu-build-system)
+ (synopsis "a gtk frontend to the transmission daemon")
+ (description "transmission-remote-gtk is a GTK client for remote management
+of the Transmission BitTorrent client, using its HTTP RPC protocol.")
+ (license license:gpl2)
+ (home-page
+ "https://github.com/transmission-remote-gtk/transmission-remote-gtk")
+ (arguments
+ `(#:tests? #f ; the tests fail
+ ))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gettext" ,gnu-gettext)
+ ("json-glib" ,json-glib)
+ ("curl" ,curl)
+ ("gtk+" ,gtk+)
+ ("appstream-glib" ,appstream-glib)))))
+
(define-public libtorrent
(package
(name "libtorrent")
--
2.32.0
L
L
Leo Famulari wrote on 15 Jul 2021 22:56
(name . Justin Veilleux)(address . justun1011@gmail.com)(address . 49583@debbugs.gnu.org)
YPCg+6xaZ7xeNPgD@jasmine.lan
On Thu, Jul 15, 2021 at 02:31:08PM -0400, Justin Veilleux wrote:
Toggle quote (7 lines)
> From 426aa9bd6b758628249df7c0925179ce39054f29 Mon Sep 17 00:00:00 2001
> From: terramorpha <terramorpha@cock.li>
> Date: Thu, 15 Jul 2021 14:27:35 -0400
> Subject: [PATCH] gnu: Add transmission-remote-gtk.
>
> * gnu/packages/bittorrent.scm (transmission-remote-gtk): New variable.

Thanks! Overall looks good.

I ran `guix lint` on it and got these warnings which should be addressed:

/home/leo/work/guix/gnu/packages/bittorrent.scm:165:5: transmission-remote-gtk@1.4.1: 'gettext' should probably be a native input
/home/leo/work/guix/gnu/packages/bittorrent.scm:161:0: transmission-remote-gtk@1.4.1: parentheses feel lonely, move to the previous or next line
/home/leo/work/guix/gnu/packages/bittorrent.scm:170:14: transmission-remote-gtk@1.4.1: synopsis should start with an upper-case letter or digit
/home/leo/work/guix/gnu/packages/bittorrent.scm:170:14: transmission-remote-gtk@1.4.1: no article allowed at the beginning of the synopsis

Toggle quote (4 lines)
> + (arguments
> + `(#:tests? #f ; the tests fail
> + ))

We need more of an explanation for why the tests should be disabled. Did
you look into the failure and try to determine if it represents some
real problems?
J
J
Justin Veilleux wrote on 16 Jul 2021 18:01
[PATCH v2]
(address . 49583@debbugs.gnu.org)(address . leo@famulari.name)
CAJppLC8qzQ5UBZYLDtER4G_xp=YyJghx66SKEHkeFHELoUY=iA@mail.gmail.com
I addressed the problems the previous patch had.

About the tests, the reason they fail is because (IIUC) an age rating tag
in some manifest.xml file is missing.
Attachment: file
From e007667ecd2ba45c3b4862694f9609a7437be3c0 Mon Sep 17 00:00:00 2001
From: terramorpha <terramorpha@cock.li>
Date: Fri, 16 Jul 2021 11:57:29 -0400
Subject: [PATCH] gnu: Add transmission-remote-gtk.

* gnu/packages/bittorrent.scm (transmission-remote-gtk): New variable.
---
gnu/packages/bittorrent.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 0ca60d607c..52f1e39f66 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages adns)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -45,6 +47,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
@@ -138,6 +141,40 @@ DHT, µTP, PEX and Magnet Links.")
;; A few files files carry an MIT/X11 license header.
(license (list l:gpl2 l:gpl3))))
+(define-public transmission-remote-gtk
+ (package
+ (name "transmission-remote-gtk")
+ (version "1.4.1")
+ (source
+ (origin
+ (uri
+ (string-append
+ "https://github.com/transmission-remote-gtk/"
+ "transmission-remote-gtk/releases/download/"
+ version "/transmission-remote-gtk-" version ".tar.xz"))
+ (method url-fetch)
+ (sha256
+ (base32 "1aqjl5rgamgcgqvcldd1gzyfh2xci0m7070924d6vz2qln0q75sr"))))
+ (build-system gnu-build-system)
+ (synopsis "Gtk frontend to the transmission daemon")
+ (description "transmission-remote-gtk is a GTK client for remote management
+of the Transmission BitTorrent client, using its HTTP RPC protocol.")
+ (license license:gpl2)
+ (home-page
+ "https://github.com/transmission-remote-gtk/transmission-remote-gtk")
+ (arguments
+ ;; the tests fail because of an age rating tag that is not present in the
+ ;; metadata
+ `(#:tests? #t))
+ (native-inputs
+ `(("gettext" ,gnu-gettext)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("appstream-glib" ,appstream-glib)
+ ("curl" ,curl)
+ ("gtk+" ,gtk+)
+ ("json-glib" ,json-glib)))))
+
(define-public libtorrent
(package
(name "libtorrent")
--
2.32.0
L
L
Leo Famulari wrote on 17 Jul 2021 05:55
(name . Justin Veilleux)(address . justun1011@gmail.com)(address . 49583-done@debbugs.gnu.org)
YPJUmhVQyt0ZcJEQ@jasmine.lan
On Fri, Jul 16, 2021 at 12:01:41PM -0400, Justin Veilleux wrote:
Toggle quote (2 lines)
> I addressed the problems the previous patch had.

Thanks!

Toggle quote (3 lines)
> About the tests, the reason they fail is because (IIUC) an age rating tag
> in some manifest.xml file is missing.

Okay. I found the upstream bug report:


I cherry-picked the bug fix, added it to your patch, and pushed as
9cb35c02164d929fcb8929e7f454df215df8cf25 after making some cosmetic
changes to the package definition. Also, I changed the license to "GPL 2
or later" since the primary source files include the "or later" clause
in their license headers.

Thanks again!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49583@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49583
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch