[PATCH] gnu: ghc-8.8: Update to 8.8.4.

  • Done
  • quality assurance status badge
Details
2 participants
  • Matthew James Kraai
  • Ludovic Courtès
Owner
unassigned
Submitted by
Matthew James Kraai
Severity
normal

Debbugs page

Matthew James Kraai wrote 4 years ago
(address . guix-patches@gnu.org)(name . Matthew James Kraai)(address . kraai@ftbfs.org)
20210713120937.14216-1-kraai@ftbfs.org
* gnu/packages/haskell.scm (ghc-8.8): Update to 8.8.4.
[arguments]: Add 'fix-cc-reference phase.
---
gnu/packages/haskell.scm | 12 +++++++++---
1 file changed, 9 insertions(+), 3 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 09732fc594..3d10bdc946 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -613,14 +614,14 @@ interactive environment for the functional language Haskell.")
(define-public ghc-8.8
(package (inherit ghc-8.6)
(name "ghc")
- (version "8.8.3")
+ (version "8.8.4")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.haskell.org/ghc/dist/"
version "/ghc-" version "-src.tar.xz"))
(sha256
- (base32 "128g932i3wix6ic03v04nh5755vyjiidzri9iybwad72yfmc1p70"))))
+ (base32 "0bgwbxxvdn56l91bp9p5d083gzcfdi6z8l8b17qzjpr3n8w5wl7h"))))
(native-inputs
`(("ghc-bootstrap" ,ghc-8.6)
("ghc-testsuite"
@@ -632,7 +633,7 @@ interactive environment for the functional language Haskell.")
(patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
(sha256
(base32
- "1l32mp94ll72skfsq1g2fqax4bkiw8b85gr3wd0bbqsqyi9a9jpr"))))
+ "0c55pj2820q26rikhpf636sn4mjgqsxjrl94vsywrh79dxp3k14z"))))
("git" ,git) ; invoked during tests
,@(filter (match-lambda
(("ghc-bootstrap" . _) #f)
@@ -643,6 +644,11 @@ interactive environment for the functional language Haskell.")
(substitute-keyword-arguments (package-arguments ghc-8.6)
((#:phases phases '%standard-phases)
`(modify-phases ,phases
+ (add-after 'fix-references 'fix-cc-reference
+ (lambda _
+ (substitute* "utils/hsc2hs/Common.hs"
+ (("\"cc\"") "\"gcc\""))
+ #t))
(add-after 'unpack-testsuite 'skip-more-tests
(lambda _
;; XXX: This test fails because our ld-wrapper script
--
2.32.0
Ludovic Courtès wrote 4 years ago
(name . Matthew James Kraai)(address . kraai@ftbfs.org)(address . 49542-done@debbugs.gnu.org)
87mtq96kj7.fsf@gnu.org
Hi,

Matthew James Kraai <kraai@ftbfs.org> skribis:

Toggle quote (3 lines)
> * gnu/packages/haskell.scm (ghc-8.8): Update to 8.8.4.
> [arguments]: Add 'fix-cc-reference phase.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49542@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49542
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help