(address . guix-patches@gnu.org)
This is a package definition for the terms of service;didn't read
initiative. It is useful to easily
know the privacy issues with whatever website the user is using.
Toggle diff (52 lines)
diff --git a/gnu/packages/browser-extensions.scm
b/gnu/packages/browser-extensions.scm
index a6120baf96..6cbe77b9c3 100644
--- a/gnu/packages/browser-extensions.scm
+++ b/gnu/packages/browser-extensions.scm
@@ -121,3 +121,41 @@ ungoogled-chromium.")
(define-public ublock-origin/chromium
(make-chromium-extension ublock-origin "chromium"))
+
+(define tosdr
+ (package
+ (name "tosdr")
+ (version "4.1.1")
+ (source (origin
+ (uri
+ (git-reference (url
"https://github.com/tosdr/browser-extensions.git")
+ (commit version)))
+ (sha256 (base32
"0wz31f9rz087yw1a7cdhdgqvgnhbk569jywv846n122m4bpk3yw0"))
+ (method git-fetch)))
+ (inputs `(("bash" ,bash)
+ ("coreutils" ,coreutils)
+ ("node" ,node)
+ ("zip" ,zip)
+ ("unzip" ,unzip)))
+ (arguments
+ `(#:builder
+ (begin
+ (use-modules (guix build utils))
+ (set-path-environment-variable "PATH"
+ '("bin")
+ (map cdr %build-inputs))
+ (copy-recursively (assoc-ref %build-inputs "source") ".")
+ (invoke "sh" "./build.sh")
+ (invoke "unzip" "dist/chrome.zip" "-d" %output)
+ #t)
+ #:modules ((guix build utils))))
+ (build-system trivial-build-system)
+ (synopsis "extension for the Terms of Service; Didn't Read
initiative")
+ (description "This extension informs you instantly of your rights
online by
+showing an unintrusive icon in the toolbar. You can click on this icon
to get
+summaries from the Terms of Service; Didn't Read initiative.")
+ (license license:agpl3)
+ (home-page "https://tosdr.org/")))
+
+(define-public tosdr-chromium
+ (make-chromium-extension tosdr))