[PATCH] gnu: add libgpiod

  • Done
  • quality assurance status badge
Details
2 participants
  • Ivan Gankevich
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ivan Gankevich
Severity
normal

Debbugs page

Ivan Gankevich wrote 4 years ago
(address . guix-patches@gnu.org)(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)
20210707075638.18941-1-i.gankevich@spbu.ru
---
gnu/packages/linux.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index da3c8755f6..9c83f1969d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8248,3 +8248,39 @@ Availability and Serviceability} reports from Linux kernel trace events.
These trace events are logged in @file{/sys/kernel/debug/tracing} and reported
through standard log mechanisms like syslog.")
(license license:gpl2)))
+
+(define-public libgpiod
+ (package
+ (name "libgpiod")
+ (version "1.6.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "0rv8a11hx3pc6sdw6nfc6k35hkp2clb3v53n1381cvip8fzhbsad"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ '("--enable-tools=yes"
+ "--enable-bindings-cxx"
+ "--enable-bindings-python")))
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("libtool" ,libtool)
+ ("autoconf-archive" ,autoconf-archive)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-3)))
+ (synopsis "C library and tools for interacting with the linux GPIO character device")
+ (description "C library with C++/Python bindings and command line tools
+for interacting with GPIO devices that avoids the usage of older system-wide
+/sys interface.")
+ (home-page "https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/")
+ (license (list license:lgpl2.1+ ;; libgpiod
+ license:gpl2+ ;; gpio-tools
+ license:lgpl3+ ;; C++ bindings
+ ))))
--
2.32.0
Ludovic Courtès wrote 4 years ago
(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)(address . 49455-done@debbugs.gnu.org)
87wnpkka1c.fsf@gnu.org
Hi,

Ivan Gankevich <i.gankevich@spbu.ru> skribis:

Toggle quote (5 lines)
> +(define-public libgpiod
> + (package
> + (name "libgpiod")
> + (version "1.6.3")

I tweaked the synopsis and description, added a copyright line for you,
adjusted the commit log as per our conventions, and committed.

Thanks!

Ludo’.
Closed
Ivan Gankevich wrote 4 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 49455-done@debbugs.gnu.org)
YPfwHSNKBERoDQ8D@surge
Toggle quote (3 lines)
>I tweaked the synopsis and description, added a copyright line for you,
>adjusted the commit log as per our conventions, and committed.

Thank you, Ludo.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49455@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49455
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help