[PATCH] gnu: add libgpiod

  • Done
  • quality assurance status badge
Details
2 participants
  • Ivan Gankevich
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ivan Gankevich
Severity
normal
I
I
Ivan Gankevich wrote on 7 Jul 2021 09:56
(address . guix-patches@gnu.org)(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)
20210707075638.18941-1-i.gankevich@spbu.ru
---
gnu/packages/linux.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index da3c8755f6..9c83f1969d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8248,3 +8248,39 @@ Availability and Serviceability} reports from Linux kernel trace events.
These trace events are logged in @file{/sys/kernel/debug/tracing} and reported
through standard log mechanisms like syslog.")
(license license:gpl2)))
+
+(define-public libgpiod
+ (package
+ (name "libgpiod")
+ (version "1.6.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "0rv8a11hx3pc6sdw6nfc6k35hkp2clb3v53n1381cvip8fzhbsad"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ '("--enable-tools=yes"
+ "--enable-bindings-cxx"
+ "--enable-bindings-python")))
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("libtool" ,libtool)
+ ("autoconf-archive" ,autoconf-archive)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-3)))
+ (synopsis "C library and tools for interacting with the linux GPIO character device")
+ (description "C library with C++/Python bindings and command line tools
+for interacting with GPIO devices that avoids the usage of older system-wide
+/sys interface.")
+ (home-page "https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/")
+ (license (list license:lgpl2.1+ ;; libgpiod
+ license:gpl2+ ;; gpio-tools
+ license:lgpl3+ ;; C++ bindings
+ ))))
--
2.32.0
L
L
Ludovic Courtès wrote on 20 Jul 2021 22:25
(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)(address . 49455-done@debbugs.gnu.org)
87wnpkka1c.fsf@gnu.org
Hi,

Ivan Gankevich <i.gankevich@spbu.ru> skribis:

Toggle quote (5 lines)
> +(define-public libgpiod
> + (package
> + (name "libgpiod")
> + (version "1.6.3")

I tweaked the synopsis and description, added a copyright line for you,
adjusted the commit log as per our conventions, and committed.

Thanks!

Ludo’.
Closed
I
I
Ivan Gankevich wrote on 21 Jul 2021 11:59
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 49455-done@debbugs.gnu.org)
YPfwHSNKBERoDQ8D@surge
Toggle quote (3 lines)
>I tweaked the synopsis and description, added a copyright line for you,
>adjusted the commit log as per our conventions, and committed.

Thank you, Ludo.
Closed
?