[PATCH] gnu: add bibtool

  • Done
  • quality assurance status badge
Details
2 participants
  • Ivan Gankevich
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Ivan Gankevich
Severity
normal

Debbugs page

Ivan Gankevich wrote 4 years ago
(address . guix-patches@gnu.org)(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)
20210707072550.29298-1-i.gankevich@spbu.ru
---
gnu/packages/tex.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 086d6190dd..752965a0a3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8629,3 +8629,29 @@ constructs TeX accepts as arguments to its @code{\\number} primitive
are valid as arguments for the macros. The package may be used under
LaTeX and plain TeX.")
(license (license:fsf-free "file:/binhex.dtx"))))
+
+(define-public bibtool
+ (package
+ (name "bibtool")
+ (version "2.68")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ge-ne/bibtool")
+ (commit (string-append
+ "BibTool_"
+ (string-map
+ (lambda (c) (if (char=? c #\.) #\_ c))
+ version)))))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "0grnmqj8w5018nd7r6drnq2yvfhf22gj9i3rj8ilhzm7zmz3zn0g"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"))
+ (native-inputs
+ `(("perl" ,perl)))
+ (synopsis "Tool for manipulating BibTeX data bases")
+ (description "Pretty print, sort, merge, select entries from BibTeX files.")
+ (home-page "http://www.gerd-neugebauer.de/software/TeX/BibTool/en/")
+ (license license:gpl2+)))
--
2.32.0
Nicolas Goaziou wrote 4 years ago
(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)(address . 49454-done@debbugs.gnu.org)
87h7h4la0s.fsf@nicolasgoaziou.fr
Hello,

Ivan Gankevich <i.gankevich@spbu.ru> writes:

Toggle quote (2 lines)
> +(define-public bibtool

Thank you! I provided a proper commit message, and expounded
description. Nitpick: I also moved home-page before the synopsis, as it
is usually located there in our packages.

I eventually added a copyright line for you at the top of the "tex.scm"
file.

Regards,
--
Nicolas Goaziou
Closed
Ivan Gankevich wrote 4 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 49454-done@debbugs.gnu.org)(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)
YOfqn1w8/VKp96L2@surge
Toggle quote (7 lines)
>Thank you! I provided a proper commit message, and expounded
>description. Nitpick: I also moved home-page before the synopsis, as it
>is usually located there in our packages.
>
>I eventually added a copyright line for you at the top of the "tex.scm"
>file.

Thank you, Nicolas!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49454@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49454
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help