* gnu/packages/video.scm (mlt): Rename to mlt-6.
[build-system]: Use cmake-build-system.
[arguments]: Remove #:make-flags. Adjust 'override-LDFLAGS phase.
{#:configure-flags}: Remove --enable-gpl3 and --enable-gpl. Set
"GTK2_GDKCONFIG_INCLUDE_DIR" and "GTK2_GLIBCONFIG_INCLUDE_DIR".
(shotcut): Use mlt-6.
* gnu/packages/animation.scm (synfig): Use mlt-6.
* gnu/packages/kde.scm (kdenlive): Use mlt-6.
This change is to add MLT 7 which will be done in the next commit.
---
gpl and gpl3 configure flags are ON by default in CMakeLists.txt.
gnu/packages/animation.scm | 2 +-
gnu/packages/kde.scm | 2 +-
gnu/packages/video.scm | 31 +++++++++++++++----------------
3 files changed, 17 insertions(+), 18 deletions(-)
Toggle diff (89 lines)
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index bf44f3b8a9..653f37f1a7 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -178,7 +178,7 @@ C++ @dfn{Standard Template Library} (STL).")
("imagemagick" ,imagemagick)
("libxml++" ,libxml++)
("libsigc++" ,libsigc++)
- ("mlt" ,mlt)
+ ("mlt" ,mlt-6)
("openexr" ,openexr)
("pango" ,pango)))
(native-inputs
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index ebbae237f8..e81abc3abe 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -242,7 +242,7 @@ browser for easy news reading.")
("frei0r-plugins" ,frei0r-plugins)
("ffmpeg" ,ffmpeg)
("rttr" ,rttr)
- ("mlt" ,mlt)
+ ("mlt" ,mlt-6)
("qtbase" ,qtbase-5)
("qtscript" ,qtscript)
("qtsvg" ,qtsvg)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 74c8d3b253..59f532addd 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2986,7 +2986,7 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
"This package provides a command-line interface for Twitch.tv")
(license license:gpl3+))))
-(define-public mlt
+(define-public mlt-6
(package
(name "mlt")
(version "6.26.1")
@@ -2999,25 +2999,24 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(sha256
(base32
"1gz79xvs5jrzqhwhfk0dqdd3xiavnjp4q957h7nb02rij32byb39"))))
- (build-system gnu-build-system)
+ (build-system cmake-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:make-flags '(,(string-append "CC=" (cc-for-target))
- ,(string-append "CXX=" (cxx-for-target)))
+ `(#:tests? #f ;no tests
#:configure-flags
- (list "--enable-gpl3"
- "--enable-gpl")
+ (list (string-append "-DGTK2_GDKCONFIG_INCLUDE_DIR="
+ (assoc-ref %build-inputs "gtk+")
+ "/lib/gtk-2.0/include")
+ (string-append "-DGTK2_GLIBCONFIG_INCLUDE_DIR="
+ (assoc-ref %build-inputs "glib")
+ "/lib/glib-2.0/include"))
#:phases
(modify-phases %standard-phases
- (add-after
- 'configure 'override-LDFLAGS
+ (add-before 'configure 'override-LDFLAGS
(lambda* (#:key outputs #:allow-other-keys)
- (substitute* "config.mak"
- (("LDFLAGS\\+=")
- (string-append "LDFLAGS+=-Wl,-rpath="
- (assoc-ref outputs "out")
- "/lib ")))
- #t)))))
+ (setenv "LDFLAGS"
+ (string-append
+ "-Wl,-rpath="
+ (assoc-ref outputs "out") "/lib")))))))
(inputs
`(("alsa-lib" ,alsa-lib)
("alsa-plugins" ,alsa-plugins "pulseaudio")
@@ -4677,7 +4676,7 @@ transitions, and effects and then export your film to many common formats.")
("lame" ,lame)
("libvpx" ,libvpx)
("libx264" ,libx264)
- ("mlt" ,mlt)
+ ("mlt" ,mlt-6)
("pulseaudio" ,pulseaudio)
("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
--
2.32.0