[PATCH 0/4] Add MLT 7 and update Shotcut.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal

Debbugs page

Vinicius Monego wrote 4 years ago
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210706183240.134397-1-monego@posteo.net
Vinicius Monego (4):
gnu: rtaudio: Fix include path.
gnu: mlt: Rename to mlt-6.
gnu: Add MLT 7.
gnu: shotcut: Update to 21.06.29.

gnu/packages/animation.scm | 2 +-
gnu/packages/audio.scm | 14 ++++++-
gnu/packages/kde.scm | 2 +-
gnu/packages/music.scm | 7 +---
gnu/packages/video.scm | 78 +++++++++++++++++++++++---------------
5 files changed, 64 insertions(+), 39 deletions(-)

--
2.32.0
Vinicius Monego wrote 4 years ago
[PATCH 1/4] gnu: rtaudio: Fix include path.
(address . 49446@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210706183627.134904-1-monego@posteo.net
* gnu/packages/audio.scm (rtaudio)[arguments]: Add phase 'fix-inc-path to move
the header to where pkg-config expects it.
* gnu/packages/music.scm (muse-sequencer)[arguments]{#:phases}: Remove
'fix-include. Don't return #t.
---
gnu/packages/audio.scm | 14 +++++++++++++-
gnu/packages/music.scm | 7 +------
2 files changed, 14 insertions(+), 7 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 791e821738..83e6cf860e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -32,7 +32,7 @@
;;; Copyright © 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Jonathan Frederickson <jonathan@terracrypt.net>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
-;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
@@ -2345,6 +2345,18 @@ implementation of the Open Sound Control (@dfn{OSC}) protocol.")
(sha256
(base32 "156c2dgh6jrsyfn1y89nslvaxm4yifmxridsb708yvkaym02w2l8"))))
(build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; The header that pkg-config expects is include/rtaudio/RtAudio.h,
+ ;; but this package installs it as include/RtAudio.h by default.
+ (add-after 'install 'fix-inc-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (inc (string-append out "/include")))
+ (mkdir-p (string-append inc "/rtaudio"))
+ (rename-file (string-append inc "/RtAudio.h")
+ (string-append inc "/rtaudio/RtAudio.h"))))))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5100ec8abe..28661c5667 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4841,12 +4841,7 @@ sample library.")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'chdir
- (lambda _ (chdir "src") #t))
- (add-after 'chdir 'fix-include
- (lambda _
- (substitute* "muse/driver/rtaudio.h"
- (("rtaudio/RtAudio.h") "RtAudio.h"))
- #t)))))
+ (lambda _ (chdir "src"))))))
(inputs
`(("alsa-lib" ,alsa-lib)
("dssi" ,dssi)
--
2.32.0
Vinicius Monego wrote 4 years ago
[PATCH 2/4] gnu: mlt: Rename to mlt-6.
(address . 49446@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210706183627.134904-2-monego@posteo.net
* gnu/packages/video.scm (mlt): Rename to mlt-6.
[build-system]: Use cmake-build-system.
[arguments]: Remove #:make-flags. Adjust 'override-LDFLAGS phase.
{#:configure-flags}: Remove --enable-gpl3 and --enable-gpl. Set
"GTK2_GDKCONFIG_INCLUDE_DIR" and "GTK2_GLIBCONFIG_INCLUDE_DIR".
(shotcut): Use mlt-6.
* gnu/packages/animation.scm (synfig): Use mlt-6.
* gnu/packages/kde.scm (kdenlive): Use mlt-6.

This change is to add MLT 7 which will be done in the next commit.
---
gpl and gpl3 configure flags are ON by default in CMakeLists.txt.

gnu/packages/animation.scm | 2 +-
gnu/packages/kde.scm | 2 +-
gnu/packages/video.scm | 31 +++++++++++++++----------------
3 files changed, 17 insertions(+), 18 deletions(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index bf44f3b8a9..653f37f1a7 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -178,7 +178,7 @@ C++ @dfn{Standard Template Library} (STL).")
("imagemagick" ,imagemagick)
("libxml++" ,libxml++)
("libsigc++" ,libsigc++)
- ("mlt" ,mlt)
+ ("mlt" ,mlt-6)
("openexr" ,openexr)
("pango" ,pango)))
(native-inputs
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index ebbae237f8..e81abc3abe 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -242,7 +242,7 @@ browser for easy news reading.")
("frei0r-plugins" ,frei0r-plugins)
("ffmpeg" ,ffmpeg)
("rttr" ,rttr)
- ("mlt" ,mlt)
+ ("mlt" ,mlt-6)
("qtbase" ,qtbase-5)
("qtscript" ,qtscript)
("qtsvg" ,qtsvg)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 74c8d3b253..59f532addd 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2986,7 +2986,7 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
"This package provides a command-line interface for Twitch.tv")
(license license:gpl3+))))
-(define-public mlt
+(define-public mlt-6
(package
(name "mlt")
(version "6.26.1")
@@ -2999,25 +2999,24 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(sha256
(base32
"1gz79xvs5jrzqhwhfk0dqdd3xiavnjp4q957h7nb02rij32byb39"))))
- (build-system gnu-build-system)
+ (build-system cmake-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:make-flags '(,(string-append "CC=" (cc-for-target))
- ,(string-append "CXX=" (cxx-for-target)))
+ `(#:tests? #f ;no tests
#:configure-flags
- (list "--enable-gpl3"
- "--enable-gpl")
+ (list (string-append "-DGTK2_GDKCONFIG_INCLUDE_DIR="
+ (assoc-ref %build-inputs "gtk+")
+ "/lib/gtk-2.0/include")
+ (string-append "-DGTK2_GLIBCONFIG_INCLUDE_DIR="
+ (assoc-ref %build-inputs "glib")
+ "/lib/glib-2.0/include"))
#:phases
(modify-phases %standard-phases
- (add-after
- 'configure 'override-LDFLAGS
+ (add-before 'configure 'override-LDFLAGS
(lambda* (#:key outputs #:allow-other-keys)
- (substitute* "config.mak"
- (("LDFLAGS\\+=")
- (string-append "LDFLAGS+=-Wl,-rpath="
- (assoc-ref outputs "out")
- "/lib ")))
- #t)))))
+ (setenv "LDFLAGS"
+ (string-append
+ "-Wl,-rpath="
+ (assoc-ref outputs "out") "/lib")))))))
(inputs
`(("alsa-lib" ,alsa-lib)
("alsa-plugins" ,alsa-plugins "pulseaudio")
@@ -4677,7 +4676,7 @@ transitions, and effects and then export your film to many common formats.")
("lame" ,lame)
("libvpx" ,libvpx)
("libx264" ,libx264)
- ("mlt" ,mlt)
+ ("mlt" ,mlt-6)
("pulseaudio" ,pulseaudio)
("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
--
2.32.0
Vinicius Monego wrote 4 years ago
[PATCH 3/4] gnu: Add MLT 7.
(address . 49446@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210706183627.134904-3-monego@posteo.net
* gnu/packages/video.scm (mlt): New variable.
(mlt-6): Inherit from above.
---
gnu/packages/video.scm | 60 ++++++++++++++++++++++++++++--------------
1 file changed, 40 insertions(+), 20 deletions(-)

Toggle diff (91 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 59f532addd..ebe1847050 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2986,29 +2986,22 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
"This package provides a command-line interface for Twitch.tv")
(license license:gpl3+))))
-(define-public mlt-6
+(define-public mlt
(package
(name "mlt")
- (version "6.26.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mltframework/mlt")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1gz79xvs5jrzqhwhfk0dqdd3xiavnjp4q957h7nb02rij32byb39"))))
+ (version "7.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mltframework/mlt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13c5miph9jjbz69dhy0zvbkk5zbb05dr3vraaci0d5fdbrlhyscf"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ;no tests
- #:configure-flags
- (list (string-append "-DGTK2_GDKCONFIG_INCLUDE_DIR="
- (assoc-ref %build-inputs "gtk+")
- "/lib/gtk-2.0/include")
- (string-append "-DGTK2_GLIBCONFIG_INCLUDE_DIR="
- (assoc-ref %build-inputs "glib")
- "/lib/glib-2.0/include"))
+ `(#:tests? #f ;requires "Kwalify"
#:phases
(modify-phases %standard-phases
(add-before 'configure 'override-LDFLAGS
@@ -3024,7 +3017,7 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
("fftw" ,fftw)
("frei0r-plugins" ,frei0r-plugins)
("gdk-pixbuf" ,gdk-pixbuf)
- ("gtk+" ,gtk+-2)
+ ("gtk+" ,gtk+)
("libxml2" ,libxml2)
("jack" ,jack-1)
("ladspa" ,ladspa)
@@ -3053,6 +3046,33 @@ functionality of the system is provided via an assortment of ready to use
tools, XML authoring components, and an extensible plug-in based API.")
(license license:lgpl2.1+)))
+(define-public mlt-6
+ (package
+ (inherit mlt)
+ (name "mlt")
+ (version "6.26.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mltframework/mlt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gz79xvs5jrzqhwhfk0dqdd3xiavnjp4q957h7nb02rij32byb39"))))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-DGTK2_GDKCONFIG_INCLUDE_DIR="
+ (assoc-ref %build-inputs "gtk+")
+ "/lib/gtk-2.0/include")
+ (string-append "-DGTK2_GLIBCONFIG_INCLUDE_DIR="
+ (assoc-ref %build-inputs "glib")
+ "/lib/glib-2.0/include"))
+ ,@(package-arguments mlt)))
+ (inputs
+ `(("gtk+", gtk+-2)
+ ,@(alist-delete "gtk+" (package-inputs mlt))))))
+
(define-public v4l-utils
(package
(name "v4l-utils")
--
2.32.0
Vinicius Monego wrote 4 years ago
[PATCH 4/4] gnu: shotcut: Update to 21.06.29.
(address . 49446@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210706183627.134904-4-monego@posteo.net
* gnu/packages/video.scm (shotcut): Update to 21.06.29.
[arguments]{#:phases}: Don't return #t.
[inputs]: Use MLT 7.
---
gnu/packages/video.scm | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ebe1847050..02bfc6c0b0 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4644,7 +4644,7 @@ transitions, and effects and then export your film to many common formats.")
(define-public shotcut
(package
(name "shotcut")
- (version "21.03.21")
+ (version "21.06.29")
(source
(origin
(method git-fetch)
@@ -4653,7 +4653,7 @@ transitions, and effects and then export your film to many common formats.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0jb488vynn0vmq22z51bg4hb4617732nva9rg52lzl89v5n8gmsi"))))
+ (base32 "0384iv2129mpalia39x8mn5xlbgx9ip994700jzjjxdqfq23a9qm"))))
(build-system qt-build-system)
(arguments
`(#:tests? #f ;there are no tests
@@ -4682,8 +4682,7 @@ transitions, and effects and then export your film to many common formats.")
`("FREI0R_PATH" ":" =
(,(string-append frei0r "/lib/frei0r-1/")))
`("MLT_PREFIX" ":" =
- (,(assoc-ref inputs "mlt")))))
- #t)))))
+ (,(assoc-ref inputs "mlt"))))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("python" ,python-wrapper)
@@ -4696,7 +4695,7 @@ transitions, and effects and then export your film to many common formats.")
("lame" ,lame)
("libvpx" ,libvpx)
("libx264" ,libx264)
- ("mlt" ,mlt-6)
+ ("mlt" ,mlt)
("pulseaudio" ,pulseaudio)
("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
--
2.32.0
Leo Famulari wrote 4 years ago
Re: [bug#49446] [PATCH 0/4] Add MLT 7 and update Shotcut.
(name . Vinicius Monego)(address . monego@posteo.net)(address . 49446-done@debbugs.gnu.org)
YOTkHKLu0DbaQYnF@jasmine.lan
On Tue, Jul 06, 2021 at 06:32:40PM +0000, Vinicius Monego wrote:
Toggle quote (6 lines)
> Vinicius Monego (4):
> gnu: rtaudio: Fix include path.
> gnu: mlt: Rename to mlt-6.
> gnu: Add MLT 7.
> gnu: shotcut: Update to 21.06.29.

Great work on these patches.

Pushed as 2252abce0525a5ce0921e5feb0872d982515f77c
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmDk5BwACgkQJkb6MLrK
fwhOEg//YY9U8bjvy8QAMQp9AawaP8KEen1qBLho2953bLGVJ/9w99Erq3BQtE5D
ej8pp2mqaghMJejjJRcdDrX0BOPUOcxJs+lsILN3pMuVJ68KgDdF6bi0QreESGXr
rdMUiRJFHBp0idDvYuiW6B0kOS/gDGqsMhU8mt+o9wFv3XrohQkfjX4ArXx2BEsa
sYQ6GwaRbSHGXYwsey0/H8c9sHUQ7rOlLSaoK5/99l68HAnH10I0qRVXYnf931YF
Bl0vJWVsZIk6SViKV6AwXxNzM7u1JH4JL6zPOqahGjc8fv1tGGlW85CZDWq4jOem
+i0I6q2ABz5YlXCbvHKUbX7iCYxdHBOQTQV9SYgzFGPud8y8G6hZCcAJt2JBBPH9
QP17JfFsD6+Ng8A7qF8hY8JR3QAXyu0JVAZ3CLEpdy40CiZcLcIomq31qtgj9tJY
/zmy1Okc6JBICDjMHXQzFQXZQFk77eBjWQ2P5pbBXKkfom+7o73lYhoQMruS4rM6
mtusoEARkGI/4bpsT1a0PEwRgQdgYKdCjFP1P6s5GigDSYEXE7Sq0jm28IbaolLz
kw28MivDXfId5x6bCINKFinOVx1ehbi8ghplygN4Im+Rg7lUDkvqw5spdYZkNlxM
kSmHVMDc6e3RAWWCcW5+3LhnX4eZKq+vWB3XqwS609TU13X2M84=
=j0w1
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49446@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49446
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help