Ivan Gankevich wrote 4 years ago
(address . guix-patches@gnu.org)(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)
---
gnu/packages/ocaml.scm | 66 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 66 insertions(+)
Toggle diff (76 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index cec6eb4f89..b01088f46a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7175,3 +7175,69 @@ libraries.")
It makes it possible to run pure OCaml programs in JavaScript environment like
browsers and Node.js.")
(license license:lgpl2.1+)))
+
+(define-public ocaml-hevea
+ (package
+ (name "ocaml-hevea")
+ (version "2.35")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/maranget/hevea")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "1ziai2pl1k2qi4v3wc4xjvh8qdk2prfsg8k64bh8vi1ichnp7mqw"))))
+ (build-system ocaml-build-system)
+ (arguments
+ `(#:tests? #f ;; no tests
+ #:make-flags
+ (list
+ "TARGET=opt"
+ (string-append "LIBDIR=" (assoc-ref %outputs "out") "/lib")
+ (string-append "BINDIR=" (assoc-ref %outputs "out") "/bin")
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'patch-/bin/sh
+ (lambda _
+ (substitute* "_tags"
+ (("/bin/sh") (which "bash"))))))))
+ (native-inputs
+ `(("ocamlbuild" ,ocamlbuild)
+ ("which" ,which)))
+ (home-page "http://hevea.inria.fr/")
+ (synopsis "Quite complete and fast LATEX to HTML translator")
+ (description "HEVEA is fast and efficient translator that is able to
+convert large LATEX documents into HTML.")
+ (license (list license:qpl license:gpl2))))
+
+(define-public ocaml-bibtex2html
+ (package
+ (name "ocaml-bibtex2html")
+ (version "1.99-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "https://www.lri.fr/~filliatr/ftp/bibtex2html/bibtex2html-1.99.tar.gz")
+ (sha256 (base32 "07gzrs4lfrkvbn48cgn2gn6c7cx3jsanakkrb2irj0gmjzfxl96j"))))
+ (build-system ocaml-build-system)
+ (arguments
+ `(#:tests? #f ;; tests require bibtex binary from texlive-bin package
+ ;; that pulls a lot of dependencies
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-/bin/sh
+ (lambda _
+ (substitute* "configure" (("/bin/sh") (which "bash")))
+ #t)))))
+ (native-inputs
+ `(("which" ,which)))
+ (propagated-inputs
+ `(("ocaml-hevea" ,ocaml-hevea)))
+ (home-page "https://www.lri.fr/~filliatr/bibtex2html/")
+ (synopsis "BibTeX to HTML translator")
+ (description "Allows to produce, from a set of bibliography files
+in BibTeX format, a bibliography in HTML format.")
+ (license license:gpl2)))
--
2.32.0