Ivan Gankevich wrote 4 years ago
(address . guix-patches@gnu.org)(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)
---
gnu/packages/maths.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)
Toggle diff (47 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 93b8ee2ad4..12d758c4c4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6408,3 +6408,40 @@ to source-code analysis of C software. The Frama-C analyzers assist you in
various source-code-related activities, from the navigation through unfamiliar
projects up to the certification of critical software.")
(license license:lgpl2.1+)))
+
+(define-public blitz
+ (package
+ (name "blitz")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/blitzpp/blitz") (commit version)))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "0c88gc72j3zggyk4yrrip6i0v7xkx97l140vpy3xhxs2i7xy1461"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--enable-shared" "--disable-fortran")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-configure
+ (lambda _
+ ;; remove non-working configure script
+ (if (file-exists? "configure") (delete-file "configure"))
+ ;; remove broken symlinks
+ (for-each
+ (lambda (file)
+ (if (eq? (stat:type (lstat file)) 'symlink)
+ (delete-file file)))
+ (find-files "m4" "\\.m4$"))
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("python2" ,python-2)))
+ (synopsis "C++ template class library for multidimensional arrays")
+ (description
+ "High-performance multidimensional array containers for scientific computing.")
+ (home-page "https://github.com/blitzpp/blitz")
+ (license (list license:artistic2.0 license:bsd-3 license:lgpl3+))))
--
2.32.0