On Fri, Jul 09, 2021 at 09:15:04AM +0200, pelzflorian (Florian Pelz) wrote:
Toggle quote (56 lines)
> From: Florian Pelz <pelzflorian@pelzflorian.de>
> > (guix.gnu.org-redirects-for-each-language): New procedure. Add
> > new video redirections. […]
> > +(define (guix.gnu.org-redirects-for-each-language)
> > + ;; These old URL request paths existed in many forms; without /LANG
> > + ;; in front and with /LANG in front for each language. Redirect
> > + ;; each of them.
> > + (define redirections
> > + (list
> > + (cons "/videos/everyday-use-of-gnu-guix,-part-one" "/videos/2020/everyday-use-of-gnu-guix-part-one/")
> > + (cons "/videos/everyday-use-of-gnu-guix,-part-two" "/videos/2020/everyday-use-of-gnu-guix-part-two/")
> > + (cons "/videos/system-graphical-installer" "/videos/2020/system-graphical-installer/")
> > + (cons "/videos/asking-for-help" "/videos/2020/asking-for-help/")
> > + (cons "/videos/installation-from-script" "/videos/2020/installation-from-script/")
> > + (cons "/videos/packaging,-part-one" "/videos/2020/packaging-part-one/")
> > + (cons "/videos/packaging,-part-two" "/videos/2020/packaging-part-two/")
> > + (cons "/videos/packaging,-part-three" "/videos/2020/packaging-part-three/")))
> > +
> > + (define (redirect-directory old new)
> > + ;; Match nginx' behavior that request URLs with suffix "", "/"
> > + ;; "/index.html" lead to the same file. The suffix "/" is not taken
> > + ;; care of here because it already gets normalized by nginx location
> > + ;; handling. The URLs in 'guix.gnu.org-redirect-locations' do not
> > + ;; need this treatment, because they get an /index.html suffix
> > + ;; through rewriting.
> > + (let ((old-with-slashes-trimmed (string-trim-right old #\/)))
> > + (list
> > + (redirect old-with-slashes-trimmed new)
> > + (redirect (string-append old-with-slashes-trimmed "/index.html") new))))
> > +
> > + (define (guix.gnu.org-redirect-locations-for-lang lang)
> > + (define (redirect-lang old new)
> > + (redirect-directory (string-append "/" lang old)
> > + (string-append "/" lang new)))
> > + (append-map redirect-lang (map car redirections) (map cdr redirections)))
> > +
> > + (append
> > + ;; Now all needed redirections are:
> > + ;;
> > + ;; 1) those without /LANG/ in front get redirected to /$lang/
> > + (append-map redirect-directory
> > + (map car redirections) ;old URLs without /LANG
> > + ;; new URLs with /$lang prepended:
> > + (map (compose (lambda (new-without-lang)
> > + (string-append "/$lang" new-without-lang))
> > + cdr)
> > + redirections))
> > + ;; 2) those with /LANG/ in front get redirected to the same /LANG/
> > + (append-map guix.gnu.org-redirect-locations-for-lang
> > + (map car languages-to-accept))))
> Do I need to add a copyright header? I hereby license/declare my
> patch CC0 <https://creativecommons.org/publicdomain/zero/1.0/>.
> […]
> Shall I push and then wait until someone guix system reconfigures
> berlin?
Sorry for again asking such general questions. A better question
might be, should 'guix.gnu.org-redirects-for-each-language' go to a
separate Guile module with a copyright header (if yes, what could it
be named?), or remain in hydra/nginx/berlin.scm despite more complex
code, without licensing information?
Regards,
Florian