grpc build failure

  • Done
  • quality assurance status badge
Details
2 participants
  • Sarah Morgensen
  • Andy Tai
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 4 years ago
(address . bug-guix@gnu.org)
CAJsg1E9GR3t+H1trH3iKmpy1Ekg-E=A6yV0XKcCkE_wYwCK4-A@mail.gmail.com
on an x86-64 virtual machine (kvm-qemu) running the current Guix,


guix package -u

fails at gprc. The build log of grpc shows failure:

/gnu/store/rn75fm7adgx3pw5j8pg3bczfqq1y17lk-gcc-7.5.0/bin/c++
-DPB_FIELD_16BIT -Dgrpc___cronet_EXPORTS
-I/tmp/guix-build-grpc-1.16.1.drv-0/source/include
-I/tmp/guix-build-grpc-1.16.1.drv-0/source
-I/tmp/guix-build-grpc-1.16.1.drv-0/source/third_party/address_sorting/include
-I/tmp/guix-build-grpc-1.16.1.drv-0/source/third_party/nanopb
-I/tmp/guix-build-grpc-1.16.1.drv-0/build-shared/gens -std=c++11
-fPIC -o CMakeFiles/grpc++_cronet.dir/src/core/lib/iomgr/gethostname_sysconf.cc.o
-c /tmp/guix-build-grpc-1.16.1.drv-0/source/src/core/lib/iomgr/gethostname_sysconf.cc
/tmp/guix-build-grpc-1.16.1.drv-0/source/src/cpp/server/channelz/channelz_service.cc:
In member function ‘virtual grpc::Status
grpc::ChannelzService::GetTopChannels(grpc::ServerContext*, const
grpc::channelz::v1::GetTopChannelsRequest*,
grpc::channelz::v1::GetTopChannelsResponse*)’:
/tmp/guix-build-grpc-1.16.1.drv-0/source/src/cpp/server/channelz/channelz_service.cc:41:44:
error: ‘OK’ is not a member of
‘google::protobuf::util::status_internal::Status’
if (s != google::protobuf::util::Status::OK) {
^~
/tmp/guix-build-grpc-1.16.1.drv-0/source/src/cpp/server/channelz/channelz_service.cc:
In member function ‘virtual grpc::Status
grpc::ChannelzService::GetServers(grpc::ServerContext*, const
grpc::channelz::v1::GetServersRequest*,
grpc::channelz::v1::GetServersResponse*)’:
/tmp/guix-build-grpc-1.16.1.drv-0/source/src/cpp/server/channelz/channelz_service.cc:57:44:
error: ‘OK’ is not a member of
‘google::protobuf::util::status_internal::Status’
if (s != google::protobuf::util::Status::OK) {
^~
/tmp/guix-build-grpc-1.16.1.drv-0/source/src/cpp/server/channelz/channelz_service.cc:
In member function ‘virtual grpc::Status
grpc::ChannelzService::GetChannel(grpc::ServerContext*, const
grpc::channelz::v1::GetChannelRequest*,
grpc::channelz::v1::GetChannelResponse*)’:
/tmp/guix-build-grpc-1.16.1.drv-0/source/src/cpp/server/channelz/channelz_service.cc:73:44:
error: ‘OK’ is not a member of
‘google::protobuf::util::status_internal::Status’
if (s != google::protobuf::util::Status::OK) {
^~
/tmp/guix-build-grpc-1.16.1.drv-0/source/src/cpp/server/channelz/channelz_service.cc:
In member function ‘virtual grpc::Status
grpc::ChannelzService::GetSubchannel(grpc::ServerContext*, const
grpc::channelz::v1::GetSubchannelRequest*,
grpc::channelz::v1::GetSubchannelResponse*)’:
/tmp/guix-build-grpc-1.16.1.drv-0/source/src/cpp/server/channelz/channelz_service.cc:89:44:
error: ‘OK’ is not a member of
‘google::protobuf::util::status_internal::Status’
if (s != google::protobuf::util::Status::OK) {
^~
/tmp/guix-build-grpc-1.16.1.drv-0/source/src/cpp/server/channelz/channelz_service.cc:
In member function ‘virtual grpc::Status
grpc::ChannelzService::GetSocket(grpc::ServerContext*, const
grpc::channelz::v1::GetSocketRequest*,
grpc::channelz::v1::GetSocketResponse*)’:
/tmp/guix-build-grpc-1.16.1.drv-0/source/src/cpp/server/channelz/channelz_service.cc:106:44:
error: ‘OK’ is not a member of
‘google::protobuf::util::status_internal::Status’
if (s != google::protobuf::util::Status::OK) {
Andy Tai wrote 4 years ago
Re: bug#49427: Acknowledgement (grpc build failure)
(address . 49427@debbugs.gnu.org)
CAJsg1E83ROqhzGRZUdxHutXfmafkjmHCeJ7ypvvnvWcr3BOmpw@mail.gmail.com
guix --version
guix (GNU Guix) f7e14782025bf87aaef694a21f34010b1a95f7f6

On Mon, Jul 5, 2021 at 5:25 PM GNU bug Tracking System
<help-debbugs@gnu.org> wrote:
Toggle quote (22 lines)
>
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> bug-guix@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 49427@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 49427: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=49427
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
Andy Tai wrote 4 years ago
(address . 49427@debbugs.gnu.org)
CAJsg1E8JPJbBk_Gs-LtVXv6=Rc+75RJe6GhJx9-qnniOF3xVwg@mail.gmail.com
Never mind; after a new

guix pull


this no longer happens. Please close this bug

On Mon, Jul 5, 2021 at 5:26 PM Andy Tai <lichengtai@gmail.com> wrote:
Toggle quote (28 lines)
>
> guix --version
> guix (GNU Guix) f7e14782025bf87aaef694a21f34010b1a95f7f6
>
> On Mon, Jul 5, 2021 at 5:25 PM GNU bug Tracking System
> <help-debbugs@gnu.org> wrote:
> >
> > Thank you for filing a new bug report with debbugs.gnu.org.
> >
> > This is an automatically generated reply to let you know your message
> > has been received.
> >
> > Your message is being forwarded to the package maintainers and other
> > interested parties for their attention; they will reply in due course.
> >
> > Your message has been sent to the package maintainer(s):
> > bug-guix@gnu.org
> >
> > If you wish to submit further information on this problem, please
> > send it to 49427@debbugs.gnu.org.
> >
> > Please do not send mail to help-debbugs@gnu.org unless you wish
> > to report a problem with the Bug-tracking system.
> >
> > --
> > 49427: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=49427
> > GNU Bug Tracking System
> > Contact help-debbugs@gnu.org with problems
Sarah Morgensen wrote 4 years ago
Re: bug#49427: grpc build failure
(name . Andy Tai)(address . lichengtai@gmail.com)(address . 49427-done@debbugs.gnu.org)
86mtqzkgiz.fsf_-_@mgsn.dev
Hello,

Thanks for taking the time to file a report! (Even if it turned out to be
a non-issue)

Andy Tai <lichengtai@gmail.com> writes:

Toggle quote (7 lines)
> Never mind; after a new
>
> guix pull
>
>
> this no longer happens. Please close this bug

For future reference, to close a bug you can address your mail to
nnn-done@debbugs.gnu.org, where nnn is the bug number in your
confirmation, as I have done with this mail.

Toggle quote (2 lines)
>> > If you wish to submit further information on this problem, please
>> > send it to 49427@debbugs.gnu.org.
^^^^^

--
Sarah
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49427@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49427
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help