[PATCH] gnu: coq: Update to 8.13.2.

  • Done
  • quality assurance status badge
Details
3 participants
  • Julien Lepiller
  • Ludovic Courtès
  • Xinglu Chen
Owner
unassigned
Submitted by
Julien Lepiller
Severity
normal
J
J
Julien Lepiller wrote on 6 Jul 2021 00:06
(address . guix-patches@gnu.org)
20210706000640.4630e3bb@tachikoma.lepiller.eu
Hi guix!

this small series updates coq to the latest version. I had to update
zarith and a few dependencies (some of which cannot be updated
independently of coq), and fix the installation of lablgtk.

This version of coq uses dune, and I split the coq package into coq,
coq-ide-server (contains coqidetop) and coq-ide (contains the graphical
interface). This also simplifies the dependency graph for coq packages,
as they no longer need the graphical stack.

I tried building the documentation too, but it complains about missing
coq package, even if I added it to the inputs of coq-doc, so it's not
part of this series.
From 73fc06926c86e8dad8bbb61f6a1728343fd2a487 Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Mon, 5 Jul 2021 17:31:10 +0200
Subject: [PATCH 1/4] gnu: ocaml-zarith: Update to 1.12.

* gnu/packages/ocaml.scm (ocaml-zarith): Update to 1.12.
---
gnu/packages/ocaml.scm | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index cec6eb4f89..5f4ed3ae35 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1428,7 +1428,7 @@ files in these formats.")
(define-public ocaml-zarith
(package
(name "ocaml-zarith")
- (version "1.9.1")
+ (version "1.12")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1437,7 +1437,7 @@ files in these formats.")
(file-name (git-file-name name version))
(sha256
(base32
- "0hv5ywz1q2cgn8apfz490clwk5hcynr937g2v8i13x2ax4bnv0lz"))))
+ "1jslm1rv1j0ya818yh23wf3bb6hz7qqj9pn5fwl45y9mqyqa01s9"))))
(build-system ocaml-build-system)
(native-inputs
`(("perl" ,perl)))
@@ -1448,7 +1448,14 @@ files in these formats.")
#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda _ (invoke "./configure"))))))
+ (lambda _ (invoke "./configure")))
+ (add-after 'install 'move-sublibs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib/ocaml/site-lib")))
+ (mkdir-p (string-append lib "/stublibs"))
+ (rename-file (string-append lib "/zarith/dllzarith.so")
+ (string-append lib "/stublibs/dllzarith.so"))))))))
(home-page "https://forge.ocamlcore.org/projects/zarith/")
(synopsis "Implements arbitrary-precision integers")
(description "Implements arithmetic and logical operations over
--
2.32.0
From 76a337769e67e84a32c5b85d80ab6bc160792aef Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Mon, 5 Jul 2021 17:52:03 +0200
Subject: [PATCH 2/4] gnu: lablgtk3: Install with version information.

This is required so recent versions of coq can check version
requirements.

* gnu/packages/ocaml.scm (lablgtk3)[arguments]: Ensure version is added
to the META file.
---
gnu/packages/ocaml.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5f4ed3ae35..4c8f04f29c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6902,6 +6902,12 @@ support for Mparser.")))
(for-each (lambda (file)
(chmod file #o644))
(find-files "." "."))
+ #t))
+ (add-before 'build 'set-version
+ (lambda _
+ (substitute* "dune-project"
+ (("\\(name lablgtk3\\)")
+ (string-append "(name lablgtk3)\n(version " ,version ")")))
#t)))))
(propagated-inputs
`(("ocaml-cairo2" ,ocaml-cairo2)))
--
2.32.0
From 8f374c9e8001db83a12ef6feee8404cbef4daaab Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Mon, 5 Jul 2021 23:41:16 +0200
Subject: [PATCH 3/4] gnu: coq-stdpp: Update to 1.5.0.

* gnu/packages/coq.scm (coq-stdpp): Update to 1.5.0.
---
gnu/packages/coq.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index fa1f4078b8..a18eddeb0f 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -598,7 +598,7 @@ kernel.")
(define-public coq-stdpp
(package
(name "coq-stdpp")
- (version "1.4.0")
+ (version "1.5.0")
(synopsis "Alternative Coq standard library std++")
(source (origin
(method git-fetch)
@@ -608,7 +608,7 @@ kernel.")
(file-name (git-file-name name version))
(sha256
(base32
- "1m6c7ibwc99jd4cv14v3r327spnfvdf3x2mnq51f9rz99rffk68r"))))
+ "1ym0fy620imah89p8b6rii8clx2vmnwcrbwxl3630h24k42092nf"))))
(build-system gnu-build-system)
(inputs
`(("coq" ,coq)))
--
2.32.0
L
L
Ludovic Courtès wrote on 21 Jul 2021 16:07
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 49423@debbugs.gnu.org)
87lf5zhi9y.fsf@gnu.org
Hi,

Julien Lepiller <julien@lepiller.eu> skribis:

Toggle quote (4 lines)
> this small series updates coq to the latest version. I had to update
> zarith and a few dependencies (some of which cannot be updated
> independently of coq), and fix the installation of lablgtk.

I haven’t tested it but the whole series LGTM!

Thanks,
Ludo’.
X
X
Xinglu Chen wrote on 24 Jul 2021 15:17
Re: [bug#49423] [PATCH] gnu: coq: Update to 8.13.2.
87lf5v3l7e.fsf@yoctocell.xyz
On Tue, Jul 06 2021, Julien Lepiller wrote:

Toggle quote (89 lines)
> Hi guix!
>
> this small series updates coq to the latest version. I had to update
> zarith and a few dependencies (some of which cannot be updated
> independently of coq), and fix the installation of lablgtk.
>
> This version of coq uses dune, and I split the coq package into coq,
> coq-ide-server (contains coqidetop) and coq-ide (contains the graphical
> interface). This also simplifies the dependency graph for coq packages,
> as they no longer need the graphical stack.
>
> I tried building the documentation too, but it complains about missing
> coq package, even if I added it to the inputs of coq-doc, so it's not
> part of this series.
> From 73fc06926c86e8dad8bbb61f6a1728343fd2a487 Mon Sep 17 00:00:00 2001
> From: Julien Lepiller <julien@lepiller.eu>
> Date: Mon, 5 Jul 2021 17:31:10 +0200
> Subject: [PATCH 1/4] gnu: ocaml-zarith: Update to 1.12.
>
> * gnu/packages/ocaml.scm (ocaml-zarith): Update to 1.12.
> ---
> gnu/packages/ocaml.scm | 13 ++++++++++---
> 1 file changed, 10 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index cec6eb4f89..5f4ed3ae35 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -1428,7 +1428,7 @@ files in these formats.")
> (define-public ocaml-zarith
> (package
> (name "ocaml-zarith")
> - (version "1.9.1")
> + (version "1.12")
> (source (origin
> (method git-fetch)
> (uri (git-reference
> @@ -1437,7 +1437,7 @@ files in these formats.")
> (file-name (git-file-name name version))
> (sha256
> (base32
> - "0hv5ywz1q2cgn8apfz490clwk5hcynr937g2v8i13x2ax4bnv0lz"))))
> + "1jslm1rv1j0ya818yh23wf3bb6hz7qqj9pn5fwl45y9mqyqa01s9"))))
> (build-system ocaml-build-system)
> (native-inputs
> `(("perl" ,perl)))
> @@ -1448,7 +1448,14 @@ files in these formats.")
> #:phases
> (modify-phases %standard-phases
> (replace 'configure
> - (lambda _ (invoke "./configure"))))))
> + (lambda _ (invoke "./configure")))
> + (add-after 'install 'move-sublibs
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (lib (string-append out "/lib/ocaml/site-lib")))
> + (mkdir-p (string-append lib "/stublibs"))
> + (rename-file (string-append lib "/zarith/dllzarith.so")
> + (string-append lib "/stublibs/dllzarith.so"))))))))
> (home-page "https://forge.ocamlcore.org/projects/zarith/")
> (synopsis "Implements arbitrary-precision integers")
> (description "Implements arithmetic and logical operations over
> --
> 2.32.0
>
> From 76a337769e67e84a32c5b85d80ab6bc160792aef Mon Sep 17 00:00:00 2001
> From: Julien Lepiller <julien@lepiller.eu>
> Date: Mon, 5 Jul 2021 17:52:03 +0200
> Subject: [PATCH 2/4] gnu: lablgtk3: Install with version information.
>
> This is required so recent versions of coq can check version
> requirements.
>
> * gnu/packages/ocaml.scm (lablgtk3)[arguments]: Ensure version is added
> to the META file.
> ---
> gnu/packages/ocaml.scm | 6 ++++++
> 1 file changed, 6 insertions(+)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index 5f4ed3ae35..4c8f04f29c 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -6902,6 +6902,12 @@ support for Mparser.")))
> (for-each (lambda (file)
> (chmod file #o644))
> (find-files "." "."))
> + #t))

Nit: no need to add a trailing #t.

Toggle quote (7 lines)
> + (add-before 'build 'set-version
> + (lambda _
> + (substitute* "dune-project"
> + (("\\(name lablgtk3\\)")
> + (string-append "(name lablgtk3)\n(version " ,version ")")))
> #t)))))

Likewise.

Otherwise, looks good; everything builds fine. :)
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmD8EuUVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5eQoP/3iNFFmYkKxO0IlSYjzgElx/AhTl
yXteOJSI6aV3YTJ8FbjwnYBEtYyEQ3CPCf3kGFpg0B3iXGheqkgtAy3SmnEPQygw
dM5qu5HU/IAcK/hwWSvji04STwCtpRBj1Dhe06LM+5Mb3kQScHAIGkrfANRlG9qe
QbCI7t87jVQaKCFJrInB04StAErEYMy4tTFI4xT33IOoWCx5b5n45LX72g5kmSRo
xewKamw0cUkWJry4fKDs9Out1OzoCekqISkusELm5tqdBNgeUNFcduRgVas3pyaS
6B5HFbqE+6RIcEJVXG8qzi142wQH3bf+N/dawPXxPL1qSBwhLlp4FNR9+5Wx2Ad/
mH9HDohYiHh15wOjkKjwP+ZJCV3EdfK6DflsFToFJQQSNjQ1BzRdkLg9rMIWwvaR
QkBSiG/o1XRWmcDtYHHvxncNz2S1TUfGrlR95BhesVDMxVy0I7wFY0zanrKvBue2
U7+lMVQP+/nZFF9AgrfB9lflx4EagTfT8yC+14Nj9s2IglqQIQCjAeiJ1l6mGVaZ
fxzYjy15+LsRcAOLFlTA98CZpiAcvE20vFIRdmNDlOsigdvcbGSL6M3qBDrYeQkI
X5m1BSJP1OtirhEzVBT8LZGdqw+NcfFZnOVB2ZRLp7EsvqQA9FTw7pOIklxSOQ1v
CgZs7dAHUtYmJxkK
=0CHK
-----END PGP SIGNATURE-----

J
J
Julien Lepiller wrote on 31 Jul 2021 23:07
(address . 49423-done@debbugs.gnu.org)
20210731230731.5f7813ef@tachikoma.lepiller.eu
Le Tue, 6 Jul 2021 00:06:40 +0200,
Julien Lepiller <julien@lepiller.eu> a écrit :

Toggle quote (15 lines)
> Hi guix!
>
> this small series updates coq to the latest version. I had to update
> zarith and a few dependencies (some of which cannot be updated
> independently of coq), and fix the installation of lablgtk.
>
> This version of coq uses dune, and I split the coq package into coq,
> coq-ide-server (contains coqidetop) and coq-ide (contains the
> graphical interface). This also simplifies the dependency graph for
> coq packages, as they no longer need the graphical stack.
>
> I tried building the documentation too, but it complains about missing
> coq package, even if I added it to the inputs of coq-doc, so it's not
> part of this series.

Pushed to master as 96707d5a309d083b1a9bf1f0c8fc1251cf203337 to
e38b4d5ceb344c9707917a7d32df50d0ced082b5, thanks!
Closed
?