[PATCH core-updates] build-system/gnu: Re-introduce %build-inputs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Maxime Devos
Owner
unassigned
Submitted by
Maxime Devos
Severity
normal
M
M
Maxime Devos wrote on 5 Jul 2021 15:26
(address . guix-patches@gnu.org)
95f586a42c5dfaf8916a2fffc50f62be3a1d2f7c.camel@telenet.be
%build-inputs was not defined anymore when cross-compiling.
This causes some build failures on core-updates, see e.g.
to civodul on IRC, this removal of %build-inputs was
accidental, so re-introduce it.

This allows "guix build grep --target=aarch64-linux-gnu" to
succeed on a x86_64-linux machine. The resulting binary
is executable under qemu-aarch64.
From 97923752ae25b5fe9d48d43fd2d4a4eab03f8a90 Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Mon, 5 Jul 2021 15:17:53 +0200
Subject: [PATCH core-updates] build-system/gnu: Re-introduce %build-inputs.

%build-inputs was not defined anymore when cross-compiling.
This causes some build failures on core-updates, see e.g.
to civodul on IRC, this removal of %build-inputs was
accidental, so re-introduce it.

This allows "guix build grep --target=aarch64-linux-gnu" to
succeed on a x86_64-linux machine. The resulting binary
is executable under qemu-aarch64.

* guix/build-system/gnu.scm
(gnu-cross-build)[builder]: Define '%build-inputs', again.
---
guix/build-system/gnu.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (23 lines)
diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index c74acb51b0..3af848034f 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -516,6 +517,9 @@ platform."
(append #$(input-tuples->gexp host-inputs)
#+(input-tuples->gexp target-inputs)))
+ (define %build-inputs
+ (append %build-host-inputs %build-target-inputs))
+
(define %outputs
#$(outputs->gexp outputs))
--
2.32.0
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYOMIcBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7jZUAQC2kWIXE2Gj11V+RWjKdBL/TSmq
rDUq4gYwv2tEds5HzQD/bFEU3OpLCteoEj5uNqzJ59+Jq91q716g6zTIo9cB8wg=
=ihYD
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 5 Jul 2021 16:32
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 49416-done@debbugs.gnu.org)
87pmvwu8zn.fsf@gnu.org
Hi Maxime,

Maxime Devos <maximedevos@telenet.be> skribis:

Toggle quote (39 lines)
> From 97923752ae25b5fe9d48d43fd2d4a4eab03f8a90 Mon Sep 17 00:00:00 2001
> From: Maxime Devos <maximedevos@telenet.be>
> Date: Mon, 5 Jul 2021 15:17:53 +0200
> Subject: [PATCH core-updates] build-system/gnu: Re-introduce %build-inputs.
>
> %build-inputs was not defined anymore when cross-compiling.
> This causes some build failures on core-updates, see e.g.
> <https://ci.guix.gnu.org/build/653883/log/raw>. According
> to civodul on IRC, this removal of %build-inputs was
> accidental, so re-introduce it.
>
> This allows "guix build grep --target=aarch64-linux-gnu" to
> succeed on a x86_64-linux machine. The resulting binary
> is executable under qemu-aarch64.
>
> * guix/build-system/gnu.scm
> (gnu-cross-build)[builder]: Define '%build-inputs', again.
> ---
> guix/build-system/gnu.scm | 4 ++++
> 1 file changed, 4 insertions(+)
>
> diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
> index c74acb51b0..3af848034f 100644
> --- a/guix/build-system/gnu.scm
> +++ b/guix/build-system/gnu.scm
> @@ -1,5 +1,6 @@
> ;;; GNU Guix --- Functional package management for GNU
> ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
> +;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -516,6 +517,9 @@ platform."
> (append #$(input-tuples->gexp host-inputs)
> #+(input-tuples->gexp target-inputs)))
>
> + (define %build-inputs
> + (append %build-host-inputs %build-target-inputs))

I pushed the same thing independently as
8a4830231871c578c80523e973ecd85f1f596ba6, sorry for duplicated work!

I had it in store but wanted to fix issues one at a time, and that took
a while… ‘core-updates’ is starting to be in a better state, so
hopefully we’ll have a better idea of what the status is now.

Thanks,
Ludo’.
Closed
?