[PATCH] gnu darktable update to 3.6.0

  • Done
  • quality assurance status badge
Details
3 participants
  • John Kehayias
  • Nicolas Goaziou
  • Vinicius Monego
Owner
unassigned
Submitted by
John Kehayias
Severity
normal

Debbugs page

John Kehayias wrote 4 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
tNuBKoaI8bHsZaFio2MR9KrBJ5_yzvB38GqnX45U2Z174ERcD2rAEgEV76tS5RnZ2Yl3WHkzhKUUJ81zvkEj3xJ7x-Ibad2tU_X3Dqtiemw=@protonmail.com
Update for darktable to latest release, 3.6.0 (tested build locally, no problems).
Toggle diff (22 lines)
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index e2d76d9908..673989e06b 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -471,7 +471,7 @@ photographic equipment.")
(define-public darktable
(package
(name "darktable")
- (version "3.4.1")
+ (version "3.6.0")
(source
(origin
(method url-fetch)
@@ -479,7 +479,7 @@ photographic equipment.")
"https://github.com/darktable-org/darktable/releases/"
"download/release-" version "/darktable-" version ".tar.xz"))
(sha256
- (base32 "07llfhhz5dhh43smhv4ax4xi1diym8hrzl7cad87rkcvv98zihvz"))))
+ (base32 "0f8aqwkgw4gs97b5i4ygiqk5zilwq7ax7zwdd31r72zk98cd1g46"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBINARY_PACKAGE_BUILD=On"
Vinicius Monego wrote 4 years ago
(address . 49357@debbugs.gnu.org)
e831f9988a9cd90fb45e404a9a9a934c9c9b1c64.camel@posteo.net
Hello,

I noticed a warning in the build that darktable now expects LLVM-12,
and this:

Toggle quote (10 lines)
> CMake Warning at src/CMakeLists.txt:332 (find_package):
> Could not find a configuration file for package "OpenEXR" that is
> compatible with requested version "3.0".
>
> The following configuration files were considered but not accepted:
>
> /gnu/store/rhixcbc778wwbi9g7j7qdcbbzpv5rgf7-openexr-
> 2.5.5/lib/cmake/OpenEXR/OpenEXRConfig.cmake, version: 2.5.5
>

Is the openexr export working in the compiled package? If not, I'd
suggest renaming openexr to openexr-2, packaging openexr 3, and then
updating darktable to keep the same set of features. WDYT?

OpenEXR 3 seems to be incompatible with version 2 [1].

[1]
John Kehayias wrote 4 years ago
(name . 49357@debbugs.gnu.org)(address . 49357@debbugs.gnu.org)
1yD_s5FBJA76ROAWQgJ0OAyHXsSD8b-Ygf0phy90kb1C8-Z2-UPxBDLCL5audIOcpAfOphVNhw0O6W_-U-iitkDK8r4QnGC_q-pTd54Lp34=@protonmail.com
Thanks, did not catch those. For LLVM, I don't think Darktable cares about version, as this commit just shows they added v12 since it was reported to work: https://github.com/darktable-org/darktable/commit/4215f9995fdcc308eb9c6769b839ffac83ded5d9

As for OpenEXR, I have not tested it nor used that feature in the past. I just tried and "darktable --version" does show OpenEXR support. Also, it does export a photo with openexr without complaint and I can open it (I just tried in Gimp).

It seems like moving to openexr 3 should be done to address security issues: https://issues.guix.gnu.org/47509This looks like it may involve patching many of the dependent packages, based on what I see in Arch (which only has openexr 3 and numerous small patches, though looked easy enough).

So I think this update to Darktable is okay, but we should move to openexr 3 for everything due to #47509. How does that sound to you?
Vinicius Monego wrote 4 years ago
(address . 49357@debbugs.gnu.org)
a76e9e2941715b864042c80527a32ab95cc7549e.camel@posteo.net
Toggle quote (6 lines)
> It seems like moving to openexr 3 should be done to address security
> issues: https://issues.guix.gnu.org/47509This looks like it may
> involve patching many of the dependent packages, based on what I see
> in Arch (which only has openexr 3 and numerous small patches, though
> looked easy enough).

I left a comment on that issue. OpenEXR addressed those vulnerabilities
in version 2.5.4, while we're at 2.5.5.

Toggle quote (3 lines)
> So I think this update to Darktable is okay, but we should move to
> openexr 3 for everything due to #47509.

Looking at the releases page for openexr, it seems that both versions 2
and 3 are being actively maintained. We can have both, and IMO we
should. But there's no need to work on it immediately.

I built the package and executed darktable --version and also see that
openexr support is enabled. This patch LGTM then. I will now wait for a
committer to review.

Thanks,

Vinicius
John Kehayias wrote 4 years ago
(name . 49357@debbugs.gnu.org)(address . 49357@debbugs.gnu.org)
WDz9Ab56SmmumStkz2cgmItxI6tvpbT2UOcEfyf-Eslq-zgrgvxPtUvKV9-JgrlUxLp5a6xWapOLBukA_DyxXVqBAkAPvqvh2KuiI-drvJE=@protonmail.com
Thanks for the follow-up, that sounds good to me!
Nicolas Goaziou wrote 4 years ago
(name . John Kehayias via Guix-patches via)(address . guix-patches@gnu.org)(name . John Kehayias)(address . john.kehayias@protonmail.com)(name . 49357@debbugs.gnu.org)(address . 49357-done@debbugs.gnu.org)
871r89qmag.fsf@nicolasgoaziou.fr
Hello,

John Kehayias via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> Thanks for the follow-up, that sounds good to me!

I applied your patch, thank you! And thanks to Vinicius Monego for the
review.

I also added a proper commit message. Next time, please use "git
format-patch" to generate one. You may want to look at the "Submitting
Patches" section of the Guix manual for more information.

Regards,
--
Nicolas Goaziou
Closed
John Kehayias wrote 4 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(name . 49357@debbugs.gnu.org)(address . 49357-done@debbugs.gnu.org)(name . John Kehayias via Guix-patches via)(address . guix-patches@gnu.org)
p1wtGunrl92z_GYclGsuEdBWpP3hLAc4vPtE6pKLouaOIrxxJpuckBz7PB_egALMs4lq2DkupyOiqHlCMUzac-yLNxub0flp2g4fKp8Lrho=@protonmail.com
‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Thursday, July 8th, 2021 at 3:47 AM, Nicolas Goaziou wrote:

Toggle quote (16 lines)
> Hello,
>
> John Kehayias via Guix-patches via guix-patches@gnu.org writes:
>
> > Thanks for the follow-up, that sounds good to me!
>
> I applied your patch, thank you! And thanks to Vinicius Monego for the
>
> review.
>
> I also added a proper commit message. Next time, please use "git
>
> format-patch" to generate one. You may want to look at the "Submitting
>
> Patches" section of the Guix manual for more information.
>
Thanks, and will do for the next ones!
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49357@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49357
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help