(address . bug-guix@gnu.org)
Hello:
I've been trying to set up a Jupyter environment with the Guix kernel inside a
guix environment using:
`guix environment --ad-hoc guix-jupyter jupyter -- jupyter notebook`.
Jupyter starts up fine, but when I create an empty notebook with the Guix kernel
it spams Nudge messages in the console, followed by a crash:
```
[W 16:25:40.117 NotebookApp] Nudge: attempt 120 on kernel 14569df8-e4d1-4847-ae1f-c68e13feeed8
[E 16:25:40.479 NotebookApp] Uncaught exception GET /api/kernels/14569df8-e4d1-4847-ae1f-c68e13feeed8/channels?session_id=05319f9c28b3455cad1b9f4fcf9e0e41 (127.0.0.1)
HTTPServerRequest(protocol='http', host='localhost:8888', method='GET', uri='/api/kernels/14569df8-e4d1-4847-ae1f-c68e13feeed8/channels?session_id=05319f9c28b3455cad1b9f4fcf9e0e41', version='HTTP/1.1', remote_ip='127.0.0.1')
Traceback (most recent call last):
File "/gnu/store/zkjmzfd8li7p7yaihm9rs617vqq9n5qh-python-tornado-6.1/lib/python3.8/site-packages/tornado/websocket.py", line 956, in _accept_connection
await open_result
tornado.util.TimeoutError: Timeout
```
Attempting to run anything in the notebook such as
`;;guix environment matplotlib-env <- python-ipykernel python-numpy python-matplotlib`
simply does nothing. I'm not sure if this is an issue with me misconfiguring
something or if it's actually a bug, but I haven't been able to chase it down
as I don't really understand the internals of Jupyter all that well.
Adding `python-ipykernel` and using a Python kernel works fine.
--
Domagoj
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCAAdFiEE7JyU1wrLyiw5G92zcc2InUujXj0FAmDggpwACgkQcc2InUuj
Xj021A/+LHBoHATEJsfucdrEcdjSwa86OXyNoWPyaO82aqY9Qrs96X0rAXaTxHih
6WUW5MPJ1BhFxF4bvSFmt38cXVIUWAjcTKtVH9QS7nBGatBwMZ1+es3X5bJNKO0O
wfMJx/yuzKaEMOUhfE5q2dP/inPry1vaNBXZLeYtJ6sEI+ZWldvDXp9tvOpyXznc
0acLrAfRb0ZB86aH6nICn6Bfz6ED6alR3yDIUKgjM0Dfup7z+RBGnRbPHep4m/Ri
7tOMlil30UDHQ4/sp0NpvpJr0PvZO895bFJ6XRhNfYRJoR3rQW87N8xG9RvzV5yb
8AMio7NJfD5kchEoMXWoYZqq5yc4JMCEHNTIi7e6ZOieUsAOahGF5bPApgmhAHpp
VawwE8iiVhUlA7XBvaMBPx+/FNtY7+pO0DtcM0rJM/0mwIrLFX8nL0cUi31v417l
esXLKihajvG0EqmWd/3sqOuIkVg2UUy0Dqf/RKdz4KR3hcSszqhubmDht7+BYSJx
LY72QfPLJCvrLr/iJNsvqnZXNw08/aEG4TR/hxQEG8mUtIyKtjCQX40pHVwtJII9
+1OTfAJnYzVlMpEHZEpTMOmEvYpDadUzU4CR0l5yBcBvWbkFmz9bpWjLRJHTr3wl
/N/MuFLkHA3HsYKTJqGL5WPqwJyJvxj0Xoen4JjCuzZMI7tGX4s=
=Nn+L
-----END PGP SIGNATURE-----