[guix-jupyter] timeout issue running the kernel

  • Done
  • quality assurance status badge
Details
2 participants
  • Domagoj Stolfa
  • Ludovic Courtès
Owner
unassigned
Submitted by
Domagoj Stolfa
Severity
normal
D
D
Domagoj Stolfa wrote on 3 Jul 2021 17:30
(address . bug-guix@gnu.org)
YOCCnDGOaRLj06mV@pepehands
Hello:

I've been trying to set up a Jupyter environment with the Guix kernel inside a
guix environment using:

`guix environment --ad-hoc guix-jupyter jupyter -- jupyter notebook`.

Jupyter starts up fine, but when I create an empty notebook with the Guix kernel
it spams Nudge messages in the console, followed by a crash:

```
[W 16:25:40.117 NotebookApp] Nudge: attempt 120 on kernel 14569df8-e4d1-4847-ae1f-c68e13feeed8
[E 16:25:40.479 NotebookApp] Uncaught exception GET /api/kernels/14569df8-e4d1-4847-ae1f-c68e13feeed8/channels?session_id=05319f9c28b3455cad1b9f4fcf9e0e41 (127.0.0.1)
HTTPServerRequest(protocol='http', host='localhost:8888', method='GET', uri='/api/kernels/14569df8-e4d1-4847-ae1f-c68e13feeed8/channels?session_id=05319f9c28b3455cad1b9f4fcf9e0e41', version='HTTP/1.1', remote_ip='127.0.0.1')
Traceback (most recent call last):
File "/gnu/store/zkjmzfd8li7p7yaihm9rs617vqq9n5qh-python-tornado-6.1/lib/python3.8/site-packages/tornado/websocket.py", line 956, in _accept_connection
await open_result
tornado.util.TimeoutError: Timeout
```

Attempting to run anything in the notebook such as

`;;guix environment matplotlib-env <- python-ipykernel python-numpy python-matplotlib`

simply does nothing. I'm not sure if this is an issue with me misconfiguring
something or if it's actually a bug, but I haven't been able to chase it down
as I don't really understand the internals of Jupyter all that well.

Adding `python-ipykernel` and using a Python kernel works fine.

--
Domagoj
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE7JyU1wrLyiw5G92zcc2InUujXj0FAmDggpwACgkQcc2InUuj
Xj021A/+LHBoHATEJsfucdrEcdjSwa86OXyNoWPyaO82aqY9Qrs96X0rAXaTxHih
6WUW5MPJ1BhFxF4bvSFmt38cXVIUWAjcTKtVH9QS7nBGatBwMZ1+es3X5bJNKO0O
wfMJx/yuzKaEMOUhfE5q2dP/inPry1vaNBXZLeYtJ6sEI+ZWldvDXp9tvOpyXznc
0acLrAfRb0ZB86aH6nICn6Bfz6ED6alR3yDIUKgjM0Dfup7z+RBGnRbPHep4m/Ri
7tOMlil30UDHQ4/sp0NpvpJr0PvZO895bFJ6XRhNfYRJoR3rQW87N8xG9RvzV5yb
8AMio7NJfD5kchEoMXWoYZqq5yc4JMCEHNTIi7e6ZOieUsAOahGF5bPApgmhAHpp
VawwE8iiVhUlA7XBvaMBPx+/FNtY7+pO0DtcM0rJM/0mwIrLFX8nL0cUi31v417l
esXLKihajvG0EqmWd/3sqOuIkVg2UUy0Dqf/RKdz4KR3hcSszqhubmDht7+BYSJx
LY72QfPLJCvrLr/iJNsvqnZXNw08/aEG4TR/hxQEG8mUtIyKtjCQX40pHVwtJII9
+1OTfAJnYzVlMpEHZEpTMOmEvYpDadUzU4CR0l5yBcBvWbkFmz9bpWjLRJHTr3wl
/N/MuFLkHA3HsYKTJqGL5WPqwJyJvxj0Xoen4JjCuzZMI7tGX4s=
=Nn+L
-----END PGP SIGNATURE-----


D
D
Domagoj Stolfa wrote on 5 Jul 2021 22:54
(address . 49355@debbugs.gnu.org)
YONxeahruuTTnUXP@pepehands
Having done some time-machining, I can confirm that
68c9e0a56e008f19427bd213cf5b24bdd8fe5922 is a good commit. The guix kernel
works fine on it. I don't however yet know which commit caused the regression,
but if nobody finds it until I have more time to bisect, I'll report back.

--
Domagoj
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE7JyU1wrLyiw5G92zcc2InUujXj0FAmDjcXkACgkQcc2InUuj
Xj264g//VSN4SgPNur7zYgqW1TjMVmv4TYT+ZrldQyiApu4xVoh9ZKpulKhEGYsJ
5RJCzkhhbbxq0JLcl9tKvripTcSa9bG+Bf6oYLB512B2MoE9SdBFcGPHbJmz2X7d
aLPCZR5oUbcxZZPfK/m6EiXSzlog0IzaL1lmjsWeFwAhyuWYF9dWxvcNFwNUMknz
IxX5TFX/bflYzazjlZSnqi4MnMPOaZccP3uKM/S25BDs0gufPzAnAf+SGJvEbb64
N2C4twXIT0gEMlbY2HnM/R+0QG8652hdV/zKwAM/e9iwsRGr+SYkRhXANaEI1EgE
iReWOh8kh6fkGol9eHMy3j7BOUtl+GD3Ysz+XrWhhYKRRHLZT2Whagg+nsG7wzhF
s5iTcULLkjn6nqSf02aVn0Js5AuIMTGY/1zoRAMKj0htUVQSEcD8sYzfu9+gUG32
BnlNCTHM7Si76n2FSs7znkzHqehSx338hiEWhLKNyIvkNpPOjfo3wSvSBSDa4JBu
Df16c28lKqHu6crlOTniAv80OvdUK5YsKnl/G6YeAHTd/IT5SzbvxsPTC0Ri8STq
hkYarv8uCUK1kkqb1Xe3IdJd9DzePqiEzLl7J6tozFEX86UvrNg+oMoge4twWUGY
tVjGTRaDznTIHLtkfzs2t00fFS7+i/3l9YV9syC/rgbdfD5IW54=
=ngs0
-----END PGP SIGNATURE-----


D
D
Domagoj Stolfa wrote on 6 Jul 2021 03:31
(address . 49355@debbugs.gnu.org)
YOOyi0jCB3naP8R8@pepehands
After a very painful bisect with various issues appearing in jupyter (unrelated
to this one), I've identified the first good commit and the first bad commit.

The commit range which caused the problem is between

95f25c9b13e22603c35f3acd9048fbd1c8671925

and

9e7f09cbec40257619e57edfdd700c775e96833d

which is a series of commits by Ricardo updating a bunch of python stuff,
including jupyter. My suspicion is that the update to jupyter-core from 4.4.0 to
4.7.1 (2a12cbaaab970bcab09002e952e062da0274f0b6) caused jupyter-core to no
longer agree with the guix kernel. I haven't diagnosed further.

The first good commit is 85788dd64d5c54ff52f19c8bb6c8c522ed581b2c and the first
bad commit I was able to actually get jupyter to work on is
9e7f09cbec40257619e57edfdd700c775e96833d.

--
Domagoj
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE7JyU1wrLyiw5G92zcc2InUujXj0FAmDjsosACgkQcc2InUuj
Xj0GAw/+J72tQL+ErXk6kc+8svyZ2slynFQijySL8XQ5mnxGcyPYIpBS8dBLNml7
21XBdU2J18WZE2Z+/ErmtH7V3NtiUM8TAHIXJcuda7E9pXyucOxnxaQnQKFQw2e8
zBk830p2RYDQwe10HAkDpZNaA3AOk25/dHgvI/+7aMw0UFJ2Ut4ZiIuZQN2MV+yj
puBAOyGVkArxPrkQqbojnFFgZ1PIyhfCGrD1lZwqWWqzwv0itRWVjzlXJiuPF7Ut
DWTtmeWYl0rqEkWun6h7C43FuhaMHZgGNqlADiZiVW7vBWpt8RiZdCF3G25w5ZoK
AvXiDRY71FNE0aogurer0N8XuGRJORtEkgPAS9WfuLEXLyRkNbK8qACfbxk56BPt
+5Kpngtf0q5gMFpT4qGEv4rEK8Ft1wDlFgF9hwRPYpckbwPXXEvSIqLVpJHucc7y
OfFXoznmJQR+vevNtCphBX1F54sSd00zqSACkLODwioBFhWahFpqclLMVLNEb00c
2N7uNKKGAeECciQIAIbpalpQ/9UVCNmVtQ6PNOEgdPl3KfoOdn5SvwLS/LWyK5ap
0NvY2W+2xjK475JmrXzvoMc8n1wX7p5jLAcMnq8YeIux1izeAW2lKyrHx9VRSWoa
EFfwocKgW2lkXiL3c2YtPuYuZpuFE9yT4SBwUNfWUWssBykYo/A=
=OHqa
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 6 Jul 2021 17:48
(name . Domagoj Stolfa)(address . ds815@gmx.com)(address . 49355@debbugs.gnu.org)
87zguzphnc.fsf@gnu.org
Hi,

Domagoj Stolfa <ds815@gmx.com> skribis:

Toggle quote (20 lines)
> After a very painful bisect with various issues appearing in jupyter (unrelated
> to this one), I've identified the first good commit and the first bad commit.
>
> The commit range which caused the problem is between
>
> 95f25c9b13e22603c35f3acd9048fbd1c8671925
>
> and
>
> 9e7f09cbec40257619e57edfdd700c775e96833d
>
> which is a series of commits by Ricardo updating a bunch of python stuff,
> including jupyter. My suspicion is that the update to jupyter-core from 4.4.0 to
> 4.7.1 (2a12cbaaab970bcab09002e952e062da0274f0b6) caused jupyter-core to no
> longer agree with the guix kernel. I haven't diagnosed further.
>
> The first good commit is 85788dd64d5c54ff52f19c8bb6c8c522ed581b2c and the first
> bad commit I was able to actually get jupyter to work on is
> 9e7f09cbec40257619e57edfdd700c775e96833d.

Thanks for bisecting!

I believe this is fixed by

You should be able to try it out by running:

guix environment --ad-hoc jupyter guix-jupyter \
--with-branch=guix-jupyter=master -- \
jupyter notebook --debug --no-browser

Hmm now that I re-test it seems to be unreliable. Perhaps I’m missing
something else.

Let me know if it works for you!

Ludo’.
D
D
Domagoj Stolfa wrote on 6 Jul 2021 18:12
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 49355@debbugs.gnu.org)
YOSA4scUbctikQk6@pepehands
Hi:

Toggle quote (2 lines)
> Let me know if it works for you!

Thanks for the quick fix!

So far it has worked well -- I haven't yet run into any unreliable behaviour,
but my notebooks are extremely simple at the moment, at most simply plotting
some stuff with matplotlib!

--
Domagoj
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE7JyU1wrLyiw5G92zcc2InUujXj0FAmDkgOIACgkQcc2InUuj
Xj33zxAAiV6CZnUVPI0KgJv4FZgyZg1J2ZUTxe/MLdLS6P9m9zBVs+hY7xX9kj35
ADpxWu6m50XvdEfrznknaLHKKfuvaxmdkbqDcQOTOaQmHS+LDWtibuZ+KUvtg28h
uZfWp4Vkfim92xV9WEHZ/uB0GsXq/81oXGu5S2zQF5T6o1TjD3qX6vIM3fBWOYG2
ubdVMT95f3ZI6PDC2PapoQud7vSDyULGTNBw9wdpaGrEqNV/t7SOVQYP1y0xrH6J
dLJQ4Qa3aKPzbc/1BvO3vV781PtY4rKNumeecUQeC4Rg0faKyjGFMdvTYk4QndWB
7+ZhKuzl+CiNXCTKmtnVmndV1yIXnXkyJ/3WhVVrcx2DLNVa4t/x4T6rWMR78C5c
ED0c8XNudxUkpzTENpjWvmGV57YkXyIypc52BviSbKpKExSTC7qZVsoqMcIwXQrp
O/EavqUdwSz1qdR0yGyJsOz4mBWHT67wxMq3VM26NorKp0g1JLUSKoNsrZ+EHz8n
f93DQTOjaTuNKiO3tgVv1utMP21KsSFlMO2/HU9dPETVgzr1qhnIsbid7xPsenl5
aJ01RuZSQOJ1ty5xkNs7fQ6k8aciLAw4FCSyxwiKrx9EQpmleSpbWx5ZRr8hvn/C
6WfNTkODwB9KQuaQY56JTIW0eRyK9amCn4dADkTnn5RobNReSzA=
=1GF5
-----END PGP SIGNATURE-----


D
D
Domagoj Stolfa wrote on 8 Jul 2021 18:42
[guix-jupyter] timeout issue running the kernel
(address . control@debbugs.gnu.org)
YOcq53TOKyWjNXud@pepehands
close 49355
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE7JyU1wrLyiw5G92zcc2InUujXj0FAmDnKucACgkQcc2InUuj
Xj27FRAAoYhYMaPQbQKDNwrEhEYznS0+2j9YWqBxzaQ0/AMrX9FCQ4+2uY48eDln
wyJEry0iLtKNe+HbHGJVY4EgX2+2HAu+iYUEiVQqyL1bhaatpM+AJKyMT14IDLg5
MrKkZeEYtqq9Ok1y3hQXxYVJkBKRzs35siOOgroh7pCR/zihTnRPt6vZ+BQLYFYK
44LhP6s+i2UCUsHs5v53XdvgnXVfKxrkTYmJblCEyXpF0xb597+OLPkJfuHXgxVO
xq4nbzoewZ12S+ocJLrVfNzrRAQt0eJ1xI5f/t5Njm6XCJf4uBOdo//0/zAaiQzz
tkMfnvGPfHhwvnnY3nf32NO9vOvDwkeA48WzxhW/M1eF229xIUdnnbkAuZMtYOsE
NvuZ0/R6Qba9H8AZ+HPRFS2eRIMaItSOgP2YlTDp34NsSZQvFWDWfMxnbXUEjy3x
xLUpfrDyeyT0/HRpvhYXqD7jmMnWS6+a/p8mKLrHaWyYH6FLPY0sZtvttVgIHY/A
Z3a4VKrP7fT82UbhcatirI1wYelny8cXV+ilLgQUuIlmvRfACfXgzUjxGCEM9DKi
3rNXRzE9AN3H0V8dV4A4ylrORoVnQAYugftu04v50epLpjXu+iTmFAqObgM2q2wC
8dZSzTe5ab3VPCBBeOREi4MHsEW3DmguVbJArr964oPi2j24h0s=
=214C
-----END PGP SIGNATURE-----


?