Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
From: Morgan Smith <Morgan.J.Smith@outlook.com>
* gnu/packages/vim.scm (vim)[arguments]<#:phases>: Add fix-install.sh phase.
---
gnu/packages/vim.scm | 5 +++++
1 file changed, 5 insertions(+)
Toggle diff (18 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 06c92b7d97..3d017ea46c 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -141,6 +141,11 @@
((".*Test_popup_drag_termwin.*" line)
(string-append line "return\n")))
#t))
+ (add-before 'install 'fix-installman.sh
+ (lambda _
+ (substitute* "src/installman.sh"
+ (("/bin/sh")
+ (which "sh")))))
(add-after 'install 'install-guix.vim
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((vimdir (string-append (assoc-ref outputs "out") "/share/vim")))
--
2.32.0