[PATCH] gnu: vim: Install manpages

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Efraim Flashner
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB40230E4E2323B1D569580B4EC51E9@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/vim.scm (vim)[arguments]<#:phases>: Add fix-install.sh phase.
---
gnu/packages/vim.scm | 5 +++++
1 file changed, 5 insertions(+)

Toggle diff (18 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 06c92b7d97..3d017ea46c 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -141,6 +141,11 @@
((".*Test_popup_drag_termwin.*" line)
(string-append line "return\n")))
#t))
+ (add-before 'install 'fix-installman.sh
+ (lambda _
+ (substitute* "src/installman.sh"
+ (("/bin/sh")
+ (which "sh")))))
(add-after 'install 'install-guix.vim
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((vimdir (string-append (assoc-ref outputs "out") "/share/vim")))
--
2.32.0
Efraim Flashner wrote 4 years ago
(address . Morgan.J.Smith@outlook.com)(address . 49354-done@debbugs.gnu.org)
YOK60B04O3kpe2vU@3900XT
Thanks! Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmDiutAACgkQQarn3Mo9
g1HtChAAveF0j5jgWiGPNQzodSouCJSAwmPtuAWzqtl0Pqtf4a4/cAZJOgWD4SQZ
h6oOZ46SNE9vW+2l2oqJaHXAaocgdHkV9qTJWdmhQPMbG+xFr6g1+NZmpbJV3+ZR
0WeX8V4AiVZ+QFU76xh7AnIUvKc+FhDNI1iFAeR7WL+jWWUIzmiC9tgwEv0yEx+Z
RZDcBd70BhzEjiRMfgzcl0NbR3S9/SPxcyWPX1jNkn6ghFPBrFjleDXzaCipgS+d
ZkbevB3eZjm813eQ0mculyF4mZzuI+B0F6XWf0TYVONLvS1EvKshAAIK7de9rtLI
yep8GafBiv64/E5NTPBUFSWszBhizjR5DkBBIO8Q6Bck01hicAHVNR1afxxDa30y
p9HP0wnZqqt5qJpwyB9/G02lRffvje0bpbFPD4AXYoSr4D6Gotc1lzRpMplYP2QD
TvCSSsuz/ysEx8MarbzKD54rL8x+zX6XPJz6yUiNaa9gk+cLpGM0i7NY7b5NXJir
7vE0jkvY80/yl7Rz3HkHbt9TeG0STQdpJel7hgc16RHAnx0T+jtoGqBWXSfYHsrh
O3vKsbuvOXAR7mhbYVdwCQgjU0XSXdOF4smKobNL0/dRw9qof0tcX8ofQcpan5kI
tG+ZmChbsOrINlh3RFtm9BWeDqLUfXw8w3RUx+ZfyBTV0SaMttQ=
=VmvT
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49354@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49354
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help