Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
From: Morgan Smith <Morgan.J.Smith@outlook.com>
* gnu/packages/emacs-xyz.scm (emacs-muse): New variable.
---
Not sure if the translators note is necessary.
I didn't test any of the exporters so I'm not sure if that works. I just wanted
some syntax highlighting
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ab04992fad..026c22cd2d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13435,6 +13435,28 @@ with CJK languages.")
to org file, you can use this tool to write orgify commentary.")
(license license:gpl2+)))
+(define-public emacs-muse
+ (package
+ (name "emacs-muse")
+ (version "3.20.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/muse-" version ".tar"))
+ (sha256
+ (base32 "0g2ff6x45x2k5dnkp31sk3bjj92jyhhnar7l5hzn8vp22l0rv8wn"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.gnu.org/software/emacs-muse/index.html")
+ (synopsis "Authoring and publishing environment for Emacs")
+ ;; TRANSLATORS: Muse should not be translated. That is the name of the software
+ (description "Authoring and publishing environment for Emacs.
+Muse uses a markup language to define hyperlinked documents. This is the markup
+language used by @url{https://www.emacswiki.org}.
+
+Muse files can be published in a variety of different formats, such as HTML,
+@code{LaTeX}, or PDF.")
+ (license license:gpl3+)))
+
(define-public emacs-mustache
(package
(name "emacs-mustache")
--
2.32.0