[PATCH] gnu: shellcheck: Generate and install manpage

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB402334206C8065A5A7AF2BB6C51F9@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/haskell-apps.scm (shellcheck)
[arguments]<#:phases>: Add build-manpage and install-manpage phases
[native-inputs]: Add pandoc
---
gnu/packages/haskell-apps.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index af777d1e3a..59e044b424 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2020 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2021 EuAndreh <eu@euandre.org>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -857,11 +858,27 @@ too slow and you'll get wound up in the scroll and crushed.")
(base32 "06m4wh891nah3y0br4wh3adpsb16zawkb2ijgf1vcz61fznj6ps1"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system haskell-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'build 'build-manpage
+ (lambda _
+ ;; Run script to generate manpage
+ (invoke "sh" "manpage")
+ #t))
+ (add-after 'install 'install-manpage
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "shellcheck.1"
+ (string-append (assoc-ref outputs "out")
+ "/share/man/man1/"))
+ #t)))))
(inputs
`(("ghc-aeson" ,ghc-aeson)
("ghc-diff" ,ghc-diff)
("ghc-quickcheck" ,ghc-quickcheck)
("ghc-regex-tdfa" ,ghc-regex-tdfa)))
+ (native-inputs
+ `(("pandoc" ,pandoc)))
(home-page "https://www.shellcheck.net/")
(synopsis "Static analysis for shell scripts")
(description "@code{shellcheck} provides static analysis for
--
2.32.0
Tobias Geerinckx-Rice wrote 4 years ago
(address . Morgan.J.Smith@outlook.com)
8735swv8y2.fsf@nckx
Morgan,

Morgan.J.Smith@outlook.com 写道:
Toggle quote (7 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/haskell-apps.scm (shellcheck)
> [arguments]<#:phases>: Add build-manpage and install-manpage
> phases
> [native-inputs]: Add pandoc

Thanks! I added full stops to some lines and pushed it.

Toggle quote (3 lines)
> + #t))
> + #t)))))

I removed these as well to avoid future noise: the requirement is
obsolete on core-updates, but unfortunately the warning can't be
removed on master.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYN9h9Q0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15P14A/ilsb7+taTqxTVemZ5nmSNhbWQRym4CCb3A8bgXm
sVM3AQDze8BeSONK9QBZJ6h7RSuFmcZgbep6HEVYsJUe0wkMCA==
=zxFN
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 49336@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49336
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help