Some tests/syscalls.scm skipped when running under -j20

  • Open
  • quality assurance status badge
Details
One participant
  • Domagoj Stolfa
Owner
unassigned
Submitted by
Domagoj Stolfa
Severity
normal
D
D
Domagoj Stolfa wrote on 30 Jun 2021 23:00
(address . bug-guix@gnu.org)
YNzbdmsAWtVifa8d@pepehands
Hi:

When I run `make check -j1`, all of the tests/syscalls.scm tests pass, however
when running it with `make check -j20`, the following two tests get skipped:

test-name: tcgetattr
location: /home/ds815/repos/guix/tests/syscalls.scm:553
source:
+ (test-assert
+ "tcgetattr"
+ (let ((termios (tcgetattr 0)))
+ (and (termios? termios)
+ (> (termios-input-speed termios) 0)
+ (> (termios-output-speed termios) 0))))
result: SKIP

test-name: tcsetattr
location: /home/ds815/repos/guix/tests/syscalls.scm:559
source:
+ (test-assert
+ "tcsetattr"
+ (let ((first (tcgetattr 0)))
+ (tcsetattr 0 (tcsetattr-action TCSANOW) first)
+ (equal? first (tcgetattr 0))))
result: SKIP


Running `make check -j20 TESTS="tests/syscalls.scm"` works fine and everything
passes. It seems like some other test is causing

(test-skip (if (and (file-exists? "/proc/self/fd/0")
(string-prefix? "/dev/pts/" (readlink "/proc/self/fd/0")))
0
2))

to skip the two tests by doing *something* to /proc/self/fd/0. Has anyone else
experienced this or is able to reproduce it?

Thanks!

--
Domagoj
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE7JyU1wrLyiw5G92zcc2InUujXj0FAmDc23YACgkQcc2InUuj
Xj1sFhAAityw+HjAB22247n0TgfYnKk+KFXWcL6nYxLsVXjSu5dZjfY29oaAPxdE
8hGCBwWM9TBfp4GLNRCK+3p8KKkzGa1+Q+qxz0VXt6WtzdS/oNZbfSACc15NCz6X
YKSXkWeLANc8JhA3l9FN4cB/fMicEWNzcHIMJJRcpHlcKTy+trlJ0d5+wvqQpfAT
xwaN+Os0qdmo3kcKS6fi4/h7UQxXhtN/HGFVVCW2jvD06Vuv2/vH2HqQOoQJvEYy
cgIDn16ATK22WlKdKuKVNYOIyeC0kuTRhc6YfkomCS0yTsx3cn6HOJP0GHeEfgme
1QiYtmjmFEdaYxvPSZRdYhPiTHdOzYRaDmp5eL+M1IWHe6T8rzIB402Wx4klG6gX
Rsww7hrUohSoPcY+jP1idWjo+tQ5Ls6FqDP2RBUhgVNrUI6dI9RRc1b1N0hlZkLS
8dW7SZdl+RifCT0J8utIM7PzwqhVWN85RVJLiAyxHjVxbzdvnbtdSbgsRM/fw1eG
TsXBk3t+IbsTHjtS1pZ+JPNO8WB0P2Mf9qJVhJiNCJZheUaPzYH4MKDPnOa/3cPD
uSUcUpB2424Cbm8F7ZsJU+gMer1xNVvp9gmYVqhpG3Vt9eaHDF1CpWVEoptTqC19
oMFhoy7iR+m0cH238ZZJgmQnQb2Ur5+PyZm60mAYjVd6WCZ7I5o=
=h1aE
-----END PGP SIGNATURE-----


?