kicad build failure: undefined reference

  • Open
  • quality assurance status badge
Details
2 participants
  • bdju
  • Christopher Howard
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal
C
C
Christopher Howard wrote on 30 Jun 2021 18:47
(name . bug-guix)(address . bug-guix@gnu.org)
50e42067ca3ac8fc6ca8368cb748ae7e4ab87e42.camel@librehacker.com
Hi, I have been attempting to rebuild my user profile from source.
Kicad, however, fails to build with the following error:

```
/gnu/store/rn75fm7adgx3pw5j8pg3bczfqq1y17lk-gcc-7.5.0/bin/c++ -Wall -
Wsuggest-override -Werror=vla -pthread -O3 -DNDEBUG -s -rdynamic
CMakeFiles/qa_eeschema.dir/__/__/common/base_units.cpp.o
CMakeFiles/qa_eeschema.dir/__/__/common/eda_text.cpp.o
CMakeFiles/qa_eeschema.dir/__/__/common/colors.cpp.o
CMakeFiles/qa_eeschema.dir/__/__/common/observable.cpp.o
CMakeFiles/qa_eeschema.dir/eeschema_test_utils.cpp.o
CMakeFiles/qa_eeschema.dir/test_module.cpp.o
CMakeFiles/qa_eeschema.dir/test_eagle_plugin.cpp.o -o qa_eeschema -
Wl,-rpath,/gnu/store/a18gskkhwwrrf7q28dfml1dk79yng79a-kicad-5.1.6/lib
../../eeschema/_eeschema.kiface ../../common/libcommon.a
../../common/libgal.a ../qa_utils/libqa_utils.a
../unit_test_utils/libunit_test_utils.a ../../common/liblegacy_gal.a
-lngspice ../../common/libcommon.a ../../common/libgal.a -lGLEW -lcairo
-lpixman-1 -lGL -lGLU ../../bitmaps_png/libbitmaps.a
../../polygon/libpolygon.a -lcurl -lssl -lcrypto
-L/gnu/store/3g181w880128ykysmcbid4nm0j6bwzdp-wxwidgets-3.0.5.1/lib
-pthread -L/gnu/store/jf269s6clr6r57p8v5c3c1qkyra6apq2-mesa-20.2.4/lib
-lwx_gtk3u_gl-3.0 -lwx_gtk3u_aui-3.0 -lwx_gtk3u_adv-3.0
-lwx_gtk3u_html-3.0 -lwx_gtk3u_core-3.0 -lwx_baseu_net-3.0 -lwx_baseu-
3.0 -lwx_baseu_xml-3.0 -lwx_gtk3u_stc-3.0
/gnu/store/vp2s1nxsc9vvc1ix66xpbf041f8nacxr-boost-
1.72.0/lib/libboost_unit_test_framework.so.1.72.0
/gnu/store/vp2s1nxsc9vvc1ix66xpbf041f8nacxr-boost-
1.72.0/lib/libboost_filesystem.so.1.72.0
/gnu/store/vp2s1nxsc9vvc1ix66xpbf041f8nacxr-boost-
1.72.0/lib/libboost_system.so.1.72.0
ld: /gnu/store/ff1n4xjs57k22np736ddqxd5pjl3wp5z-libngspice-
34/lib/libngspice.so: undefined reference to `history_file'
collect2: error: ld returned 1 exit status
make[2]: *** [qa/eeschema/CMakeFiles/qa_eeschema.dir/build.make:199:
qa/eeschema/qa_eeschema] Error 1
make[2]: Leaving directory '/tmp/guix-build-kicad-5.1.6.drv-0/build'
make[1]: *** [CMakeFiles/Makefile2:3042:
qa/eeschema/CMakeFiles/qa_eeschema.dir/all] Error 2
make[1]: Leaving directory '/tmp/guix-build-kicad-5.1.6.drv-0/build'
make: *** [Makefile:166: all] Error 2
command "make" "-j" "1" failed with status 2

```

My guix commit is a little old now (a little over a week) if that makes
a difference. My system information:

```
christopher@theoden ~$ neofetch --stdout
christopher@theoden
-------------------
OS: Guix System 4343476a3bffeb3714ad50ff7559c4b7f7c81551 x86_64
Host: OptiPlex 9020 00
Kernel: 5.12.8-gnu
Uptime: 5 days, 18 hours, 48 mins
Packages: 93 (guix-system), 109 (guix-user)
Shell: bash 5.0.16
Resolution: 1920x1080
DE: GNOME
Theme: Adwaita [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: kitty
CPU: Intel i5-4570 (4) @ 3.600GHz
GPU: Intel HD Graphics
GPU: AMD ATI Radeon HD 8490 / R5 235X OEM
Memory: 2363MiB / 7869MiB
```


--
Christopher Howard
Gemini capsule: gemini://gem.librehacker.com
Attachment: file
B
CCH4IHN90U78.1ODBEQ8BYVKWI@masaki
On Wed Jun 30, 2021 at 11:47 AM CDT, Christopher Howard wrote:
Toggle quote (6 lines)
> Hi, I have been attempting to rebuild my user profile from source.
> Kicad, however, fails to build
>
> My guix commit is a little old now (a little over a week) if that makes
> a difference.

I believe this was fixed recently, I reported the failure as bug #49161
and the thread was concluded with mention of a patch.
?