(address . guix-patches@gnu.org)
Currently untested, I'm mostly claiming a bug id to refer to
in some other commit message for now. This is important
for cross-compiling "isc-dhcp" though some other fixes are
also necessary.
From 64cfe798431a18675662318ca84702b33456fbef Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Wed, 30 Jun 2021 15:10:28 +0200
Subject: [PATCH] gnu-build-system: patch-shebangs: Also patch shebangs in
"/libexec".
Shebangs in "/bin" and "/sbin" subdirectories are currently
patched by patch-shebangs. But shebangs in "/libexec" currently
aren't, even though they occasionally need to be. E.g. when using
wrap-program on an executable in "libexec" without an explicit #:sh
when cross-compiling.
* guix/build/gnu-build-system.scm (patch-shebangs):
Add "/libexec" to 'bin-directories'.
---
guix/build/gnu-build-system.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Toggle diff (16 lines)
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index 28c719d9ca..d0f7413268 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -407,7 +407,8 @@ makefiles."
(match-lambda
((_ . dir)
(list (string-append dir "/bin")
- (string-append dir "/sbin")))))
+ (string-append dir "/sbin")
+ (string-append dir "/libexec")))))
(define output-bindirs
(append-map bin-directories outputs))
--
2.32.0
-----BEGIN PGP SIGNATURE-----
iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYNxu9xccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7tujAQC+Q+4K3nc8uEMc3XzOzzSI7Lma
lqJYkbzMK+ZoVSoFWgD9G6At/CG8VPA8O2HlbDTN3b1b7lCpaPvF6Wp85wgmVgY=
=vqBg
-----END PGP SIGNATURE-----